aboutsummaryrefslogtreecommitdiffstats
path: root/audio/snack/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-24 13:37:05 +0800
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-24 13:37:05 +0800
commit0e021394c6e81aea9caad3a9e73a79818537eaae (patch)
tree4656da0adb7324937f9ab0d19a1941f7ec11e033 /audio/snack/Makefile
parent6eb259c96a717d7c12b9f04d0b38344a57f69c71 (diff)
downloadfreebsd-ports-gnome-0e021394c6e81aea9caad3a9e73a79818537eaae.tar.gz
freebsd-ports-gnome-0e021394c6e81aea9caad3a9e73a79818537eaae.tar.zst
freebsd-ports-gnome-0e021394c6e81aea9caad3a9e73a79818537eaae.zip
add snack
The Snack Sound Toolkit
Diffstat (limited to 'audio/snack/Makefile')
-rw-r--r--audio/snack/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/audio/snack/Makefile b/audio/snack/Makefile
new file mode 100644
index 000000000000..41ac6265e8cd
--- /dev/null
+++ b/audio/snack/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# New ports collection makefile for: snack
+# Date created: Nov 24, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= snack
+PORTVERSION= 2.1.4
+CATEGORIES= audio tcl83 tk83
+MASTER_SITES= http://www.speech.kth.se/~kare/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/unix
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.3 \
+ --with-tk=${LOCALBASE}/lib/tk8.3
+PLIST_SUB= SNACK_VER=${PORTVERSION:R}
+
+post-patch:
+ @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile.in
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${CP} ${WRKSRC}/../doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>