aboutsummaryrefslogtreecommitdiffstats
path: root/audio/snd
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2009-03-10 23:47:50 +0800
committerdhn <dhn@FreeBSD.org>2009-03-10 23:47:50 +0800
commit311cf852c1bf20b9d5428094d4db0061e6d54691 (patch)
treec3b6225379656fc732e03ff947e42e5ee5a6e11f /audio/snd
parent7e915b11f1bbe551b00cc3523cd0f3fa54a8fa46 (diff)
downloadfreebsd-ports-gnome-311cf852c1bf20b9d5428094d4db0061e6d54691.tar.gz
freebsd-ports-gnome-311cf852c1bf20b9d5428094d4db0061e6d54691.tar.zst
freebsd-ports-gnome-311cf852c1bf20b9d5428094d4db0061e6d54691.zip
- Add Motif/GTK2 graphic support
- Remove ruby support - Bump PORTREVISION PR: 132280 Submitted by: Timothy Beyer <beyert@cs.ucr.edu> Approved by: maintainer, tabthorpe (co-mentor)
Diffstat (limited to 'audio/snd')
-rw-r--r--audio/snd/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/audio/snd/Makefile b/audio/snd/Makefile
index 86a28f8206b1..516aaaf11814 100644
--- a/audio/snd/Makefile
+++ b/audio/snd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= snd
PORTVERSION= 10.4
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF \
http://mirror.mcx2.org/
@@ -21,8 +22,9 @@ OPTIONS= ESD "Use Enlightened Sound Daemon" on \
S7 "Use S7 as the extension language" off \
LADSPA "Include support for LADSPA plugins" on \
NLS "Native Language Support" on \
- RUBY "Use Ruby as the extension language" off \
- X11 "Make Snd with Gtk+ graphics support" on
+ MOTIF "Make Snd with Motif graphics support" off \
+ GTK2 "Make Snd with Gtk+ graphics support" on \
+ X11 "Make Snd with GUI support" on
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
@@ -61,6 +63,7 @@ CONFIGURE_ARGS+= --without-gsl
.endif
.if !defined(WITHOUT_GUILE)
+CONFIGURE_ARGS+= --with-guile
LIB_DEPENDS+= guile.20:${PORTSDIR}/lang/guile
PLIST_SUB+= SCHEME=""
.else
@@ -89,20 +92,20 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_RUBY)
-USE_RUBY= yes
-.include "${PORTSDIR}/Mk/bsd.ruby.mk"
-CONFIGURE_ARGS+= --with-ruby
-PLIST_SUB+= SCHEME="@comment "
+.if defined(WITH_GTK2)
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+= --with-gtk
+PLIST_SUB+= X11=""
+.endif
+.if defined(WITH_MOTIF)
+USE_MOTIF= yes
+CONFIGURE_ARGS+= --with-motif
+PLIST_SUB+= X11=""
.endif
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --with-no-gui
PLIST_SUB+= X11="@comment "
-.else
-USE_GNOME+= gtk20
-CONFIGURE_ARGS+= --with-gtk
-PLIST_SUB+= X11=""
.endif
post-patch: