aboutsummaryrefslogtreecommitdiffstats
path: root/audio/sox
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-02-16 07:29:27 +0800
committerbeech <beech@FreeBSD.org>2008-02-16 07:29:27 +0800
commit02ca58cbdc2c735a280a68811c8af0bc56e99753 (patch)
treebd780e791a6851fb9d2d687056f063b42e2bd3e6 /audio/sox
parent0ef26836475445579015db88550c8f45b664b20f (diff)
downloadfreebsd-ports-gnome-02ca58cbdc2c735a280a68811c8af0bc56e99753.tar.gz
freebsd-ports-gnome-02ca58cbdc2c735a280a68811c8af0bc56e99753.tar.zst
freebsd-ports-gnome-02ca58cbdc2c735a280a68811c8af0bc56e99753.zip
- Update to 14.0.1
- Add PTHREAD_LIBS to LDFLAGS Bring sox up to the latest release. It can now decode any format recognized by ffmpeg or flac. PR: ports/120418 Submitted by: Dan Nelson <dnelson@allantgroup.com> (maintainer)
Diffstat (limited to 'audio/sox')
-rw-r--r--audio/sox/Makefile91
-rw-r--r--audio/sox/distinfo6
-rw-r--r--audio/sox/pkg-plist214
3 files changed, 289 insertions, 22 deletions
diff --git a/audio/sox/Makefile b/audio/sox/Makefile
index a736918c962e..d2ad4a3e1ca3 100644
--- a/audio/sox/Makefile
+++ b/audio/sox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sox
-PORTVERSION= 13.0.0
-PORTREVISION= 1
+PORTVERSION= 14.0.1
CATEGORIES= audio
MASTER_SITES= SF
@@ -17,44 +16,101 @@ COMMENT= SOund eXchange - universal sound sample translator
CONFLICTS= play-[0-9]*
MAN1= sox.1
-MAN3= libst.3
-MAN7= soxexam.7
+MAN3= libsox.3
+MAN7= soxexam.7 soxformat.7 soxeffect.7
MLINKS= sox.1 play.1 sox.1 rec.1
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LDCONFIG= yes
+USE_AUTOTOOLS= libltdl
# src/Makefile uses ${RM} but never sets it
MAKE_ENV+= RM="rm -f"
-OPTIONS= FLAC "Enable libflac" on \
+OPTIONS= AO "Enable libao output" on \
+ AMRNB "AMR Speech Codec (Narrowband)" off \
+ AMRWB "AMR Speech Codec (Wideband)" off \
+ FFMPEG "Enable ffmpeg en/decoding" on \
+ FLAC "Enable flac en/decoding with libflac" on \
GSM "Use libgsm from ports (else use bundled lib)" on \
+ LADSPA "Audio plugin support" off \
LAME "Enable mp3 encoding with LAME" on \
MAD "Enable mp3 decoding with MAD" on \
+ SAMPLERATE "Enable libsamplerate" on \
SNDFILE "Enable libsndfile" on \
VORBIS "Enable Ogg Vorbis support" on
.include <bsd.port.pre.mk>
-.if defined(WITH_FLAC) || defined(WITH_GSM) || defined(WITH_LAME) || \
- defined(WITH_MAD) || defined(WITH_SNDFILE) || defined(WITH_VORBIS)
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.if !defined(WITH_LAME) && !defined(WITH_MAD)
+PLIST_SUB+= PLIST_MP3="@comment "
+.else
+PLIST_SUB+= PLIST_MP3=""
+.endif
+
+.if defined(WITH_AO)
+CONFIGURE_ARGS+= --enable-libao
+LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
+PLIST_SUB+= PLIST_AO=""
+.else
+CONFIGURE_ARGS+= --disable-libao
+PLIST_SUB+= PLIST_AO="@comment "
+.endif
+
+.if defined(WITH_AMRNB)
+CONFIGURE_ARGS+= --with-amr-nb
+LIB_DEPENDS+= amrnb.3:${PORTSDIR}/audio/libamrnb
+PLIST_SUB+= PLIST_AMRNB=""
+.else
+CONFIGURE_ARGS+= --without-amr-nb
+PLIST_SUB+= PLIST_AMRNB="@comment "
+.endif
+
+.if defined(WITH_AMRWB)
+CONFIGURE_ARGS+= --with-amr-wb
+LIB_DEPENDS+= amrwb.3:${PORTSDIR}/audio/libamrwb
+PLIST_SUB+= PLIST_AMRWB=""
+.else
+CONFIGURE_ARGS+= --without-amr-wb
+PLIST_SUB+= PLIST_AMRWB="@comment "
+.endif
+
+.if defined(WITH_FFMPEG)
+CONFIGURE_ARGS+= --with-ffmpeg
+LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg
+PLIST_SUB+= PLIST_FFMPEG=""
+.else
+CONFIGURE_ARGS+= --without-ffmpeg
+PLIST_SUB+= PLIST_FFMPEG="@comment "
.endif
.if defined(WITH_VORBIS)
-CONFIGURE_ARGS+= --with-ogg-vorbis
+CONFIGURE_ARGS+= --with-ogg
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+PLIST_SUB+= PLIST_VORBIS=""
.else
-CONFIGURE_ARGS+= --without-ogg-vorbis
-# Above configure flag does not exist, so workaround with the below line
-CONFIGURE_ENV+= ac_cv_header_vorbis_codec_h=no
+CONFIGURE_ARGS+= --without-ogg
+PLIST_SUB+= PLIST_VORBIS="@comment "
.endif
.if defined(WITH_SNDFILE)
CONFIGURE_ARGS+= --with-sndfile
LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
+PLIST_SUB+= PLIST_SNDFILE=""
.else
CONFIGURE_ARGS+= --without-sndfile
+PLIST_SUB+= PLIST_SNDFILE="@comment "
+.endif
+
+.if defined(WITH_LADSPA)
+CONFIGURE_ARGS+= --with-ladspa
+RUN_DEPENDS+= ${LOCALBASE}/lib/ladspa/filter.so:${PORTSDIR}/audio/ladspa
+BUILD_DEPENDS+= ${LOCALBASE}/lib/ladspa/filter.so:${PORTSDIR}/audio/ladspa
+.else
+CONFIGURE_ARGS+= --without-ladspa
.endif
.if defined(WITH_LAME)
@@ -67,8 +123,10 @@ CONFIGURE_ARGS+= --without-lame
.if defined(WITH_FLAC)
CONFIGURE_ARGS+= --with-flac
LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
+PLIST_SUB+= PLIST_FLAC=""
.else
CONFIGURE_ARGS+= --without-flac
+PLIST_SUB+= PLIST_FLAC="@comment "
.endif
.if defined(WITH_MAD)
@@ -81,10 +139,19 @@ CONFIGURE_ARGS+= --without-mad
.if defined(WITH_GSM)
CONFIGURE_ARGS+= --with-external-gsm
LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
+PLIST_SUB+= PLIST_GSM=""
.else
CONFIGURE_ARGS+= --without-external-gsm
# Above configure flag does not exist, so workaround with the below line
CONFIGURE_ENV+= ac_cv_header_gsm_h=no
+PLIST_SUB+= PLIST_GSM="@comment "
+.endif
+
+.if defined(WITH_SAMPLERATE)
+CONFIGURE_ARGS+= --with-samplerate
+LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
+.else
+CONFIGURE_ARGS+= --without-samplerate
.endif
# Tell configure that libgsm's headers are in $LOCALDIR/include
diff --git a/audio/sox/distinfo b/audio/sox/distinfo
index b6b90833c46a..ca1b6b738715 100644
--- a/audio/sox/distinfo
+++ b/audio/sox/distinfo
@@ -1,3 +1,3 @@
-MD5 (sox-13.0.0.tar.gz) = 0243d62895caee558b5294d5b78cfbcb
-SHA256 (sox-13.0.0.tar.gz) = c66c52cfa42fe126592563c3d8974007a9858bd35d2c1136389a721eeebb9f8e
-SIZE (sox-13.0.0.tar.gz) = 725259
+MD5 (sox-14.0.1.tar.gz) = 6c95af60b20b9655531bf3162c0be937
+SHA256 (sox-14.0.1.tar.gz) = 52398a49bef64aa6e06b158cb59b3e1790fa1bf94262b896688bcfdcf539ca73
+SIZE (sox-14.0.1.tar.gz) = 859538
diff --git a/audio/sox/pkg-plist b/audio/sox/pkg-plist
index ed905f5d9c00..ab5e2c40ea8d 100644
--- a/audio/sox/pkg-plist
+++ b/audio/sox/pkg-plist
@@ -1,11 +1,211 @@
@comment $FreeBSD$
-bin/libst-config
bin/play
bin/rec
bin/sox
-include/st.h
-include/ststdint.h
-lib/libst.a
-lib/libst.la
-lib/libst.so
-lib/libst.so.0
+include/sox.h
+include/soxstdint.h
+lib/libsfx.a
+lib/libsfx.la
+lib/libsfx.so
+lib/libsfx.so.0
+lib/libsox.a
+lib/libsox.la
+lib/libsox.so
+lib/libsox.so.0
+lib/sox/libsox_fmt_aifc.a
+lib/sox/libsox_fmt_aifc.la
+lib/sox/libsox_fmt_aifc.so
+lib/sox/libsox_fmt_aifc.so.0
+lib/sox/libsox_fmt_aiff.a
+lib/sox/libsox_fmt_aiff.la
+lib/sox/libsox_fmt_aiff.so
+lib/sox/libsox_fmt_aiff.so.0
+lib/sox/libsox_fmt_al.a
+lib/sox/libsox_fmt_al.la
+lib/sox/libsox_fmt_al.so
+lib/sox/libsox_fmt_al.so.0
+%%PLIST_AMRNB%%lib/sox/libsox_fmt_amr_nb.a
+%%PLIST_AMRNB%%lib/sox/libsox_fmt_amr_nb.la
+%%PLIST_AMRNB%%lib/sox/libsox_fmt_amr_nb.so
+%%PLIST_AMRNB%%lib/sox/libsox_fmt_amr_nb.so.0
+%%PLIST_AMRWB%%lib/sox/libsox_fmt_amr_wb.a
+%%PLIST_AMRWB%%lib/sox/libsox_fmt_amr_wb.la
+%%PLIST_AMRWB%%lib/sox/libsox_fmt_amr_wb.so
+%%PLIST_AMRWB%%lib/sox/libsox_fmt_amr_wb.so.0
+%%PLIST_AO%%lib/sox/libsox_fmt_ao.a
+%%PLIST_AO%%lib/sox/libsox_fmt_ao.la
+%%PLIST_AO%%lib/sox/libsox_fmt_ao.so
+%%PLIST_AO%%lib/sox/libsox_fmt_ao.so.0
+lib/sox/libsox_fmt_au.a
+lib/sox/libsox_fmt_au.la
+lib/sox/libsox_fmt_au.so
+lib/sox/libsox_fmt_au.so.0
+lib/sox/libsox_fmt_auto.a
+lib/sox/libsox_fmt_auto.la
+lib/sox/libsox_fmt_auto.so
+lib/sox/libsox_fmt_auto.so.0
+lib/sox/libsox_fmt_avr.a
+lib/sox/libsox_fmt_avr.la
+lib/sox/libsox_fmt_avr.so
+lib/sox/libsox_fmt_avr.so.0
+lib/sox/libsox_fmt_cdr.a
+lib/sox/libsox_fmt_cdr.la
+lib/sox/libsox_fmt_cdr.so
+lib/sox/libsox_fmt_cdr.so.0
+lib/sox/libsox_fmt_cvsd.a
+lib/sox/libsox_fmt_cvsd.la
+lib/sox/libsox_fmt_cvsd.so
+lib/sox/libsox_fmt_cvsd.so.0
+lib/sox/libsox_fmt_dat.a
+lib/sox/libsox_fmt_dat.la
+lib/sox/libsox_fmt_dat.so
+lib/sox/libsox_fmt_dat.so.0
+lib/sox/libsox_fmt_dvms.a
+lib/sox/libsox_fmt_dvms.la
+lib/sox/libsox_fmt_dvms.so
+lib/sox/libsox_fmt_dvms.so.0
+%%PLIST_FFMPEG%%lib/sox/libsox_fmt_ffmpeg.a
+%%PLIST_FFMPEG%%lib/sox/libsox_fmt_ffmpeg.la
+%%PLIST_FFMPEG%%lib/sox/libsox_fmt_ffmpeg.so
+%%PLIST_FFMPEG%%lib/sox/libsox_fmt_ffmpeg.so.0
+%%PLIST_FLAC%%lib/sox/libsox_fmt_flac.a
+%%PLIST_FLAC%%lib/sox/libsox_fmt_flac.la
+%%PLIST_FLAC%%lib/sox/libsox_fmt_flac.so
+%%PLIST_FLAC%%lib/sox/libsox_fmt_flac.so.0
+lib/sox/libsox_fmt_gsm.a
+lib/sox/libsox_fmt_gsm.la
+lib/sox/libsox_fmt_gsm.so
+lib/sox/libsox_fmt_gsm.so.0
+lib/sox/libsox_fmt_hcom.a
+lib/sox/libsox_fmt_hcom.la
+lib/sox/libsox_fmt_hcom.so
+lib/sox/libsox_fmt_hcom.so.0
+lib/sox/libsox_fmt_ima.a
+lib/sox/libsox_fmt_ima.la
+lib/sox/libsox_fmt_ima.so
+lib/sox/libsox_fmt_ima.so.0
+lib/sox/libsox_fmt_la.a
+lib/sox/libsox_fmt_la.la
+lib/sox/libsox_fmt_la.so
+lib/sox/libsox_fmt_la.so.0
+lib/sox/libsox_fmt_lpc10.a
+lib/sox/libsox_fmt_lpc10.la
+lib/sox/libsox_fmt_lpc10.so
+lib/sox/libsox_fmt_lpc10.so.0
+lib/sox/libsox_fmt_lu.a
+lib/sox/libsox_fmt_lu.la
+lib/sox/libsox_fmt_lu.so
+lib/sox/libsox_fmt_lu.so.0
+lib/sox/libsox_fmt_maud.a
+lib/sox/libsox_fmt_maud.la
+lib/sox/libsox_fmt_maud.so
+lib/sox/libsox_fmt_maud.so.0
+%%PLIST_MP3%%lib/sox/libsox_fmt_mp3.a
+%%PLIST_MP3%%lib/sox/libsox_fmt_mp3.la
+%%PLIST_MP3%%lib/sox/libsox_fmt_mp3.so
+%%PLIST_MP3%%lib/sox/libsox_fmt_mp3.so.0
+lib/sox/libsox_fmt_nul.a
+lib/sox/libsox_fmt_nul.la
+lib/sox/libsox_fmt_nul.so
+lib/sox/libsox_fmt_nul.so.0
+lib/sox/libsox_fmt_oss.a
+lib/sox/libsox_fmt_oss.la
+lib/sox/libsox_fmt_oss.so
+lib/sox/libsox_fmt_oss.so.0
+lib/sox/libsox_fmt_prc.a
+lib/sox/libsox_fmt_prc.la
+lib/sox/libsox_fmt_prc.so
+lib/sox/libsox_fmt_prc.so.0
+lib/sox/libsox_fmt_raw.a
+lib/sox/libsox_fmt_raw.la
+lib/sox/libsox_fmt_raw.so
+lib/sox/libsox_fmt_raw.so.0
+lib/sox/libsox_fmt_s1.a
+lib/sox/libsox_fmt_s1.la
+lib/sox/libsox_fmt_s1.so
+lib/sox/libsox_fmt_s1.so.0
+lib/sox/libsox_fmt_s2.a
+lib/sox/libsox_fmt_s2.la
+lib/sox/libsox_fmt_s2.so
+lib/sox/libsox_fmt_s2.so.0
+lib/sox/libsox_fmt_s3.a
+lib/sox/libsox_fmt_s3.la
+lib/sox/libsox_fmt_s3.so
+lib/sox/libsox_fmt_s3.so.0
+lib/sox/libsox_fmt_s4.a
+lib/sox/libsox_fmt_s4.la
+lib/sox/libsox_fmt_s4.so
+lib/sox/libsox_fmt_s4.so.0
+lib/sox/libsox_fmt_sf.a
+lib/sox/libsox_fmt_sf.la
+lib/sox/libsox_fmt_sf.so
+lib/sox/libsox_fmt_sf.so.0
+lib/sox/libsox_fmt_smp.a
+lib/sox/libsox_fmt_smp.la
+lib/sox/libsox_fmt_smp.so
+lib/sox/libsox_fmt_smp.so.0
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sndfile.a
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sndfile.la
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sndfile.so
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sndfile.so.0
+lib/sox/libsox_fmt_sndrtool.a
+lib/sox/libsox_fmt_sndrtool.la
+lib/sox/libsox_fmt_sndrtool.so
+lib/sox/libsox_fmt_sndrtool.so.0
+lib/sox/libsox_fmt_sphere.a
+lib/sox/libsox_fmt_sphere.la
+lib/sox/libsox_fmt_sphere.so
+lib/sox/libsox_fmt_sphere.so.0
+lib/sox/libsox_fmt_svx.a
+lib/sox/libsox_fmt_svx.la
+lib/sox/libsox_fmt_svx.so
+lib/sox/libsox_fmt_svx.so.0
+lib/sox/libsox_fmt_txw.a
+lib/sox/libsox_fmt_txw.la
+lib/sox/libsox_fmt_txw.so
+lib/sox/libsox_fmt_txw.so.0
+lib/sox/libsox_fmt_u1.a
+lib/sox/libsox_fmt_u1.la
+lib/sox/libsox_fmt_u1.so
+lib/sox/libsox_fmt_u1.so.0
+lib/sox/libsox_fmt_u2.a
+lib/sox/libsox_fmt_u2.la
+lib/sox/libsox_fmt_u2.so
+lib/sox/libsox_fmt_u2.so.0
+lib/sox/libsox_fmt_u3.a
+lib/sox/libsox_fmt_u3.la
+lib/sox/libsox_fmt_u3.so
+lib/sox/libsox_fmt_u3.so.0
+lib/sox/libsox_fmt_u4.a
+lib/sox/libsox_fmt_u4.la
+lib/sox/libsox_fmt_u4.so
+lib/sox/libsox_fmt_u4.so.0
+lib/sox/libsox_fmt_ul.a
+lib/sox/libsox_fmt_ul.la
+lib/sox/libsox_fmt_ul.so
+lib/sox/libsox_fmt_ul.so.0
+lib/sox/libsox_fmt_voc.a
+lib/sox/libsox_fmt_voc.la
+lib/sox/libsox_fmt_voc.so
+lib/sox/libsox_fmt_voc.so.0
+%%PLIST_VORBIS%%lib/sox/libsox_fmt_vorbis.a
+%%PLIST_VORBIS%%lib/sox/libsox_fmt_vorbis.la
+%%PLIST_VORBIS%%lib/sox/libsox_fmt_vorbis.so
+%%PLIST_VORBIS%%lib/sox/libsox_fmt_vorbis.so.0
+lib/sox/libsox_fmt_vox.a
+lib/sox/libsox_fmt_vox.la
+lib/sox/libsox_fmt_vox.so
+lib/sox/libsox_fmt_vox.so.0
+lib/sox/libsox_fmt_wav.a
+lib/sox/libsox_fmt_wav.la
+lib/sox/libsox_fmt_wav.so
+lib/sox/libsox_fmt_wav.so.0
+lib/sox/libsox_fmt_wve.a
+lib/sox/libsox_fmt_wve.la
+lib/sox/libsox_fmt_wve.so
+lib/sox/libsox_fmt_wve.so.0
+lib/sox/libsox_fmt_xa.a
+lib/sox/libsox_fmt_xa.la
+lib/sox/libsox_fmt_xa.so
+lib/sox/libsox_fmt_xa.so.0
+@dirrm lib/sox