aboutsummaryrefslogtreecommitdiffstats
path: root/audio/speak_freely/Makefile
diff options
context:
space:
mode:
authorimura <imura@FreeBSD.org>2000-01-15 02:36:37 +0800
committerimura <imura@FreeBSD.org>2000-01-15 02:36:37 +0800
commit26cf4b5c7aac1759c4311ef40222584fabf86bb2 (patch)
tree0f171d4de15fb9faa8739c7d42b4564413bea959 /audio/speak_freely/Makefile
parent66b4e56c91f5f716142fdfd9319847cc973a7b52 (diff)
downloadfreebsd-ports-gnome-26cf4b5c7aac1759c4311ef40222584fabf86bb2.tar.gz
freebsd-ports-gnome-26cf4b5c7aac1759c4311ef40222584fabf86bb2.tar.zst
freebsd-ports-gnome-26cf4b5c7aac1759c4311ef40222584fabf86bb2.zip
- Add sfreflect and sflaunch to be installed
- System-wide CFLAGS received appropriate respect - System md5 library used instead of port's own - GSM library now used properly from GSM port instead of SF port - portlint (add dummy Whom: line in Makefile) - move WWWs from Makefile to DESCR PR: 15921 Submitted by: Maxim Sobolev <sobomax@altavista.net>
Diffstat (limited to 'audio/speak_freely/Makefile')
-rw-r--r--audio/speak_freely/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/audio/speak_freely/Makefile b/audio/speak_freely/Makefile
index 1d76a6cfed47..ecd1824f93ab 100644
--- a/audio/speak_freely/Makefile
+++ b/audio/speak_freely/Makefile
@@ -1,7 +1,7 @@
# New ports collection makefile for: speak_freely
-# Original WWW site: http://www.fourmilab.ch/speakfree/unix/index.html
# Version required: 7.1
# Date created: 18 Apr 1996
+# Whom: Mister X (to make portlint happy ;)
#
# $FreeBSD$
#
@@ -14,15 +14,17 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm
-UTILS= sfspeaker sfmike sflwl
-DEMNS= sfecho sflwld
+UTILS= sfspeaker sfmike sflwl sflaunch
+DEMNS= sfecho sflwld sfreflect
DDEMNS= sfvod
SFLIB= ${PREFIX}/lib/speak_freely
MAN1= ${UTILS:S/$/.1/} ${DEMNS:S/$/.1/} ${DDEMNS:S/$/.1/}
+MAKE_ENV="OPTFLAGS=${CFLAGS}"
+
do-install:
if [ ! -d ${SFLIB} ]; then \
- install -d -o ${BINOWN} -g ${BINGRP} -m 755 ${SFLIB}; \
+ ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755 ${SFLIB}; \
fi
cd ${WRKSRC}; \
$(INSTALL_DATA) busy.au ring.au ${SFLIB}