aboutsummaryrefslogtreecommitdiffstats
path: root/audio/speex-devel/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-30 16:52:54 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-30 16:52:54 +0800
commita3b063f6460dd9d72a94fddb7ac89986771fc22f (patch)
tree19bc69bc5cd06b01e9050ebe15ca5c49443b31d3 /audio/speex-devel/Makefile
parent9be60a7c8374c1ca6a465ca6b0b3da029920b89e (diff)
downloadfreebsd-ports-gnome-a3b063f6460dd9d72a94fddb7ac89986771fc22f.tar.gz
freebsd-ports-gnome-a3b063f6460dd9d72a94fddb7ac89986771fc22f.tar.zst
freebsd-ports-gnome-a3b063f6460dd9d72a94fddb7ac89986771fc22f.zip
add speex 0.5.2
An open-source (LGPL) patent-free voice codec
Diffstat (limited to 'audio/speex-devel/Makefile')
-rw-r--r--audio/speex-devel/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/audio/speex-devel/Makefile b/audio/speex-devel/Makefile
new file mode 100644
index 000000000000..942db9a23c0c
--- /dev/null
+++ b/audio/speex-devel/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# Ports collection makefile for: Speex
+# Date created: Jul 30, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= speex
+PORTVERSION= 0.5.2
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Speex-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+.include <bsd.port.mk>