aboutsummaryrefslogtreecommitdiffstats
path: root/audio/synthpod-lv2
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /audio/synthpod-lv2
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'audio/synthpod-lv2')
-rw-r--r--audio/synthpod-lv2/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/audio/synthpod-lv2/Makefile b/audio/synthpod-lv2/Makefile
index fab69536d737..e4dad90e08ed 100644
--- a/audio/synthpod-lv2/Makefile
+++ b/audio/synthpod-lv2/Makefile
@@ -58,11 +58,13 @@ JACK_LIB_DEPENDS= libjack.so:audio/jack \
JACK_CMAKE_OFF= -DBUILD_JACK="OFF"
KX_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_KX="ON"
KX_USE= XORG=x11,xcb,xext GL=glu
+QT4_USES= qt:4
QT4_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_QT4="ON"
-QT4_USE= XORG=x11,xcb,xext GL=glu QT4=corelib,gui
+QT4_USE= XORG=x11,xcb,xext GL=glu QT=corelib,gui
+QT5_USES= qt:5
QT5_BROKEN= Build fails: https://github.com/OpenMusicKontrollers/synthpod/issues/10
QT5_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_QT5="ON"
-QT5_USE= XORG=x11,xcb,xext GL=glu QT5=core,gui
+QT5_USE= XORG=x11,xcb,xext GL=glu QT=core,gui
SHOW_USE= XORG=x11,xcb,xext GL=glu
SHOW_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_SHOW="ON"
X11_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_X11="ON"