aboutsummaryrefslogtreecommitdiffstats
path: root/audio/synthpod-lv2
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-12-06 15:25:31 +0800
committeryuri <yuri@FreeBSD.org>2018-12-06 15:25:31 +0800
commite86e6a546e3579ff221d69224744f07991c6d4fa (patch)
treebcecfbcc93394485ca41b323da6dcdae0d240618 /audio/synthpod-lv2
parent2b368549e666490b60f688613f5916e587a45207 (diff)
downloadfreebsd-ports-gnome-e86e6a546e3579ff221d69224744f07991c6d4fa.tar.gz
freebsd-ports-gnome-e86e6a546e3579ff221d69224744f07991c6d4fa.tar.zst
freebsd-ports-gnome-e86e6a546e3579ff221d69224744f07991c6d4fa.zip
audio/synthpod-lv2: Remove the Qt4 option due to deprecation
Diffstat (limited to 'audio/synthpod-lv2')
-rw-r--r--audio/synthpod-lv2/Makefile24
-rw-r--r--audio/synthpod-lv2/pkg-plist1
2 files changed, 10 insertions, 15 deletions
diff --git a/audio/synthpod-lv2/Makefile b/audio/synthpod-lv2/Makefile
index 4966ce5aa78d..e8970e374cb9 100644
--- a/audio/synthpod-lv2/Makefile
+++ b/audio/synthpod-lv2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= synthpod
PORTVERSION= g20170810
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@@ -19,18 +19,18 @@ LIB_DEPENDS= liblilv-0.so:audio/lilv \
libsord-0.so:devel/sord \
libsratom-0.so:audio/sratom
-USES= cmake compiler:c++11-lib pkgconfig localbase
+USES= cmake:outsource compiler:c++11-lib pkgconfig localbase
USE_GITHUB= yes
GH_ACCOUNT= OpenMusicKontrollers
GH_TAGNAME= 07cae54
USE_CXXSTD= c++11
-CMAKE_ARGS= -DBUILD_ALSA="OFF"
+CMAKE_OFF= BUILD_ALSA BUILD_SANDBOX_QT4
OPTIONS_DEFINE= JACK DUMMY DOT
OPTIONS_DEFAULT=JACK X11 SHOW KX
OPTIONS_GROUP= UI
-OPTIONS_GROUP_UI= X11 GTK2 GTK3 QT4 QT5 SHOW KX
+OPTIONS_GROUP_UI= X11 GTK2 GTK3 QT5 SHOW KX
OPTIONS_SUB= yes
DUMMY_DESC= Build DUMMY standalone host
@@ -40,7 +40,6 @@ JACK_DESC= Build JACK standalone host
X11_DESC= Build X11 sandbox
GTK2_DESC= Build GTK-2 sandbox
GTK3_DESC= Build GTK-3 sandbox
-QT4_DESC= Build Qt-4 sandbox
QT5_DESC= Build Qt-5 sandbox
SHOW_DESC= Build show-iface sandbox
@@ -50,35 +49,32 @@ DUMMY_LIB_DEPENDS= libuv.so:devel/libuv
GTK2_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_GTK2="ON"
GTK2_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
+GTK2_USES= gl gnome
GTK2_USE= XORG=x11,xcb,xext GL=gl,glu GNOME=glib20,gtk20,gdkpixbuf2,atk,cairo,pango gettext-runtime
GTK3_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_GTK3="ON"
+GTK3_USES= gl gnome
GTK3_USE= XORG=x11,xcb,xext GL=glu GNOME=glib20,gtk30,gdkpixbuf2,atk,cairo,pango gettext-runtime
JACK_LIB_DEPENDS= libjack.so:audio/jack \
libuv.so:devel/libuv
JACK_CMAKE_OFF= -DBUILD_JACK="OFF"
KX_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_KX="ON"
+KX_USES= gl
KX_USE= XORG=x11,xcb,xext GL=glu
-QT4_USES= qt:4
-QT4_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_QT4="ON"
-QT4_USE= XORG=x11,xcb,xext GL=glu QT=corelib,gui
QT5_USES= qt:5
QT5_BROKEN= Build fails: https://github.com/OpenMusicKontrollers/synthpod/issues/10
QT5_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_QT5="ON"
QT5_USE= XORG=x11,xcb,xext GL=glu QT=core,gui
+SHOW_USES= gl
SHOW_USE= XORG=x11,xcb,xext GL=glu
SHOW_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_SHOW="ON"
X11_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_X11="ON"
X11_LIB_DEPENDS= libxcb-icccm.so:x11/xcb-util-wm
+X11_USES= gl
X11_USE= XORG=x11,xcb,xext GL=gl,glu
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MQT4}
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
-.endif
-
-.if ${PORT_OPTIONS:MX11} || ${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGTK3} || ${PORT_OPTIONS:MQT4} || ${PORT_OPTIONS:MQT5} || ${PORT_OPTIONS:MSHOW} || ${PORT_OPTIONS:MKX}
+.if ${PORT_OPTIONS:MX11} || ${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGTK3} || ${PORT_OPTIONS:MQT5} || ${PORT_OPTIONS:MSHOW} || ${PORT_OPTIONS:MKX}
PLIST_SUB+= UI=""
.else
PLIST_SUB+= UI="@comment "
diff --git a/audio/synthpod-lv2/pkg-plist b/audio/synthpod-lv2/pkg-plist
index e4f7a51624a2..2c0454b07065 100644
--- a/audio/synthpod-lv2/pkg-plist
+++ b/audio/synthpod-lv2/pkg-plist
@@ -4,7 +4,6 @@
%%X11%%bin/synthpod_sandbox_x11
%%GTK2%%bin/synthpod_sandbox_gtk2
%%GTK3%%bin/synthpod_sandbox_gtk3
-%%QT4%%bin/synthpod_sandbox_qt4
%%QT5%%bin/synthpod_sandbox_qt5
%%SHOW%%bin/synthpod_sandbox_show
%%KX%%bin/synthpod_sandbox_kx