aboutsummaryrefslogtreecommitdiffstats
path: root/audio/vorbis-tools
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2001-03-24 02:07:44 +0800
committerjeh <jeh@FreeBSD.org>2001-03-24 02:07:44 +0800
commit0854eff357005dab6cd4b737611bde20f2d032c9 (patch)
tree4cd71b3f788c3bd7e106850624caadd36edcbae0 /audio/vorbis-tools
parentdff795243e47f0f7c1171e9c8b1829879226aadb (diff)
downloadfreebsd-ports-gnome-0854eff357005dab6cd4b737611bde20f2d032c9.tar.gz
freebsd-ports-gnome-0854eff357005dab6cd4b737611bde20f2d032c9.tar.zst
freebsd-ports-gnome-0854eff357005dab6cd4b737611bde20f2d032c9.zip
- changes MAINTAINER,
- fixes a bug in shared memory handling where SYSVSHM segments wouldn't be destroyed on program exit, - prefers memory sharing by mmap() over SYSVSHM, - bumps PORTREVISION due to the fix above, - contains miscellaneous clean-ups and autoconf-related changes. PR: 25942 Submitted by: Christian Weisgerber <naddy@mips.inka.de> Approved by: Theo van Klaveren <t.vanklaveren@student.utwente.nl>
Diffstat (limited to 'audio/vorbis-tools')
-rw-r--r--audio/vorbis-tools/Makefile22
-rw-r--r--audio/vorbis-tools/files/patch-aa18
-rw-r--r--audio/vorbis-tools/files/patch-ab69
-rw-r--r--audio/vorbis-tools/pkg-descr3
4 files changed, 75 insertions, 37 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index e49da22929ba..24307d124f57 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -7,36 +7,26 @@
PORTNAME= vorbis-tools
PORTVERSION= 1.0b4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= http://www.vorbis.com/files/beta4/unix/ \
http://home.student.utwente.nl/t.vanklaveren/distfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/beta/}
-MAINTAINER= t.vanklaveren@student.utwente.nl
+MAINTAINER= naddy@mips.inka.de
LIB_DEPENDS= ao.1:${PORTSDIR}/audio/libao \
ogg.1:${PORTSDIR}/audio/libogg \
vorbis.0:${PORTSDIR}/audio/libvorbis
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USE_AUTOCONF= yes
USE_LIBTOOL= yes
-CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-ogg=${LOCALBASE} \
- --with-ao=${LOCALBASE}
+CONFIGURE_ARGS= --with-ao=${LOCALBASE} \
+ --with-ogg=${LOCALBASE} \
+ --with-vorbis=${LOCALBASE}
MAN1= ogg123.1 oggenc.1
-#post-build:
-# This is probably evil, and should be in a Makefile.
-# cd ${WRKSRC}/oggenc && ${CC} ${CFLAGS} -c getopt1.c
-# cd ${WRKSRC}/ogg123 && ${CC} ${CFLAGS} -c ogg123.c -I../oggenc -I${LOCALBASE}/include
-# cd ${WRKSRC}/ogg123 && ${CC} ${LDFLAGS} -o ogg123 ogg123.o ../oggenc/getopt.o ../oggenc/getopt1.o -L${LOCALBASE}/lib -logg -lvorbis -lao -lvorbisfile
-#
-#post-install:
-# ${INSTALL_PROGRAM} ${WRKSRC}/ogg123/ogg123 ${PREFIX}/bin/
-# ${INSTALL_MAN} ${WRKSRC}/ogg123/ogg123.1 ${PREFIX}/man/man1/
-
.include <bsd.port.mk>
diff --git a/audio/vorbis-tools/files/patch-aa b/audio/vorbis-tools/files/patch-aa
index 5f927e6b5100..e568ca3628a1 100644
--- a/audio/vorbis-tools/files/patch-aa
+++ b/audio/vorbis-tools/files/patch-aa
@@ -1,11 +1,11 @@
---- configure.old Tue Feb 27 14:55:50 2001
-+++ configure Tue Feb 27 14:55:57 2001
-@@ -1822,7 +1822,7 @@
- AO_LIBS="-L$ao_prefix/lib"
- fi
+--- configure.in.orig Mon Feb 26 06:51:00 2001
++++ configure.in Sun Mar 18 23:21:51 2001
+@@ -67,7 +68,7 @@ dnl ------------------------------------
+ dnl Check for library functions
+ dnl --------------------------------------------------
-- AO_LIBS="$AO_LIBS -lao -ldl"
-+ AO_LIBS="$AO_LIBS -lao"
+-dnl none
++AC_FUNC_SMMAP
- echo $ac_n "checking for ao""... $ac_c" 1>&6
- echo "configure:1829: checking for ao" >&5
+ dnl --------------------------------------------------
+ dnl Work around FHS stupidity
diff --git a/audio/vorbis-tools/files/patch-ab b/audio/vorbis-tools/files/patch-ab
index fa97832d41fb..4207e753c0e2 100644
--- a/audio/vorbis-tools/files/patch-ab
+++ b/audio/vorbis-tools/files/patch-ab
@@ -1,14 +1,65 @@
---- ogg123/buffer.c.orig Tue Feb 27 14:57:30 2001
-+++ ogg123/buffer.c Tue Feb 27 14:58:25 2001
-@@ -14,7 +14,11 @@
- #include <fcntl.h>
+--- ogg123/buffer.c.orig Tue Jan 30 11:42:48 2001
++++ ogg123/buffer.c Sat Mar 17 17:12:02 2001
+@@ -6,17 +6,16 @@
+ */
- #ifndef DARWIN
-+#ifdef __FreeBSD__
-+#include <stdlib.h>
+ #include <sys/types.h>
++#if HAVE_SMMAP
++#include <sys/mman.h>
+#else
- #include <malloc.h>
+ #include <sys/ipc.h>
+ #include <sys/shm.h>
+-#include <sys/stat.h>
+#endif
- #endif
+ #include <sys/time.h>
+ #include <unistd.h> /* for fork and pipe*/
+ #include <fcntl.h>
+-#ifndef DARWIN
+-#include <malloc.h>
+-#endif
+-
#include "ogg123.h"
+ #include "buffer.h"
+
+@@ -73,10 +72,26 @@ buf_t *fork_writer (long size, devices_t
+ int childpid;
+ buf_t *buf;
+
++#if HAVE_SMMAP
++ int fd;
++
++ if ((fd = open("/dev/zero", O_RDWR)) < 0)
++ {
++ perror ("cannot open /dev/zero");
++ exit (1);
++ }
++ if ((buf = (buf_t *) mmap (0, sizeof(buf_t) + sizeof (chunk_t) * (size - 1),
++ PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0)) < 0)
++ {
++ perror("mmap");
++ exit(1);
++ }
++ close(fd);
++#else
+ /* Get the shared memory segment. */
+ int shmid = shmget (IPC_PRIVATE,
+ sizeof(buf_t) + sizeof (chunk_t) * (size - 1),
+- IPC_CREAT|S_IREAD|S_IWRITE);
++ IPC_CREAT|SHM_R|SHM_W);
+
+ if (shmid == -1)
+ {
+@@ -92,7 +107,11 @@ buf_t *fork_writer (long size, devices_t
+ perror ("shmat");
+ exit (1);
+ }
+-
++
++ /* Remove segment after last process detaches it or terminates. */
++ shmctl(shmid, IPC_RMID, 0);
++#endif /* HAVE_SMMAP */
++
+ buffer_init (buf, size);
+
+ /* Create a pipe for communication between the two processes. Unlike
diff --git a/audio/vorbis-tools/pkg-descr b/audio/vorbis-tools/pkg-descr
index b4046279575f..865bda108068 100644
--- a/audio/vorbis-tools/pkg-descr
+++ b/audio/vorbis-tools/pkg-descr
@@ -10,6 +10,3 @@ This package contains utilities to encode and decode vorbis streams, and to
add comments to them.
WWW: http://www.vorbis.com
-
-- Theo van Klaveren
-t.vanklaveren@student.utwente.nl