aboutsummaryrefslogtreecommitdiffstats
path: root/audio/vorbis
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-10-05 14:36:23 +0800
committerJeremy Lea <reg@FreeBSD.org>2000-10-05 14:36:23 +0800
commitfda2e985daa21bcac7cf4e4882e560933d7ad5e8 (patch)
tree4ccb4a868e97ff347416395233e3825776b24951 /audio/vorbis
parentd0cdca8bc326260560504ebb5d4b206942ca5125 (diff)
downloadfreebsd-ports-gnome-fda2e985daa21bcac7cf4e4882e560933d7ad5e8.tar.gz
freebsd-ports-gnome-fda2e985daa21bcac7cf4e4882e560933d7ad5e8.tar.zst
freebsd-ports-gnome-fda2e985daa21bcac7cf4e4882e560933d7ad5e8.zip
Implement USE_GTK, part 1.
Diffstat (limited to 'audio/vorbis')
-rw-r--r--audio/vorbis/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/audio/vorbis/Makefile b/audio/vorbis/Makefile
index 779decd0377c..69e13923b0e1 100644
--- a/audio/vorbis/Makefile
+++ b/audio/vorbis/Makefile
@@ -14,21 +14,21 @@ MAINTAINER= t.vanklaveren@student.utwente.nl
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
xmms.1:${PORTSDIR}/audio/xmms
-RUN_DEPENDS= ${X11BASE}/bin/xmms:${PORTSDIR}/audio/xmms
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+WRKSRC= ${WRKDIR}/${PORTNAME}
# Vorbis doesn't depend on X, but it's needed for the XMMS plugin :-(
USE_X_PREFIX= yes
+USE_GTK= yes
USE_AUTOCONF= yes
-GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/vorbis
+
+MAN1= ogg123.1 vorbize.1 oggenc.1
post-build:
cd ${WRKSRC}/vorbis-tools/libao && ${SETENV} ${MAKE_ENV} ${MAKE}
cd ${WRKSRC}/vorbis-tools && ${SETENV} ${MAKE_ENV} ${MAKE} ${ALL_TARGET}
- cd ${WRKSRC}/xmms && ${SETENV} ${MAKE_ENV} ${MAKE} GLIB_CONFIG=${GLIB_CONFIG} GTK_CONFIG=${GTK_CONFIG} target
+ cd ${WRKSRC}/xmms && ${SETENV} ${MAKE_ENV} ${MAKE} target
+
do-install:
# Install all vorbis libraries and headers by hand. There is no target for it.
${INSTALL_PROGRAM} ${WRKSRC}/lib/libvorbis.a ${PREFIX}/lib/
@@ -49,6 +49,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/include/vorbis/*.h ${PREFIX}/include/vorbis/
${INSTALL_DATA} ${WRKSRC}/include/vorbis/book/*.vqh ${PREFIX}/include/vorbis/book/
-MAN1= ogg123.1 vorbize.1 oggenc.1
-
.include <bsd.port.mk>