aboutsummaryrefslogtreecommitdiffstats
path: root/audio/vorbisgain/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-01-03 19:09:45 +0800
committerijliao <ijliao@FreeBSD.org>2003-01-03 19:09:45 +0800
commit869c7caa6d3527ca230d8b4f86fcfa21eada63b6 (patch)
tree17c2995da15e70a4aadee597f2fc301a8e828f70 /audio/vorbisgain/Makefile
parent43af50cf7bf0655281bfb0ca639e8d8f1f6662e9 (diff)
downloadfreebsd-ports-gnome-869c7caa6d3527ca230d8b4f86fcfa21eada63b6.tar.gz
freebsd-ports-gnome-869c7caa6d3527ca230d8b4f86fcfa21eada63b6.tar.zst
freebsd-ports-gnome-869c7caa6d3527ca230d8b4f86fcfa21eada63b6.zip
add vorbisgain 0.32
Calculates a percieved sound level of an Ogg Vorbis file
Diffstat (limited to 'audio/vorbisgain/Makefile')
-rw-r--r--audio/vorbisgain/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/audio/vorbisgain/Makefile b/audio/vorbisgain/Makefile
new file mode 100644
index 000000000000..bd08c82ceced
--- /dev/null
+++ b/audio/vorbisgain/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: vorbisgain
+# Date created: Jan 3, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= vorbisgain
+PORTVERSION= 0.32
+CATEGORIES= audio
+MASTER_SITES= http://sjeng.sourceforge.net/ftp/vorbis/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
+ vorbis.2:${PORTSDIR}/audio/libvorbis
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lm -logg -lvorbis -lvorbisfile"
+USE_GMAKE= yes
+
+MAN1= vorbisgain.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,-ldir,," ${WRKSRC}/configure
+
+.include <bsd.port.mk>