aboutsummaryrefslogtreecommitdiffstats
path: root/audio/waon/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-10-09 17:25:38 +0800
committermiwi <miwi@FreeBSD.org>2007-10-09 17:25:38 +0800
commit6fc36a6db679d40a95203d23419650d15878c15d (patch)
tree7d42685d7528ccd6431a172f4f7501e6feda3828 /audio/waon/Makefile
parent0d10da12913301220fff8d93b2a3ad4f4e1167a9 (diff)
downloadfreebsd-ports-gnome-6fc36a6db679d40a95203d23419650d15878c15d.tar.gz
freebsd-ports-gnome-6fc36a6db679d40a95203d23419650d15878c15d.tar.zst
freebsd-ports-gnome-6fc36a6db679d40a95203d23419650d15878c15d.zip
WaoN is a Wave-to-Notes transcriber (converts audio file into midi file)
and some utility tools such as gWaoN, graphical visualization of the spectra, and phase vocoder for time-stretching and pitch-shifting. WWW: http://waon.sourceforge.net/ PR: ports/117034 Submitted by: Kengo Ichiki <kichiki at users.sourceforge.net>
Diffstat (limited to 'audio/waon/Makefile')
-rw-r--r--audio/waon/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/waon/Makefile b/audio/waon/Makefile
new file mode 100644
index 000000000000..bccd3b5f9f95
--- /dev/null
+++ b/audio/waon/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: waon
+# Date created: 8 October 2007
+# Whom: Kengo Ichiki <kichiki@users.sourceforge.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= waon
+PORTVERSION= 0.8
+CATEGORIES= audio
+MASTER_SITES= SF
+
+MAINTAINER= kichiki@users.sourceforge.net
+COMMENT= A Wave-to-Notes transcriber and some utility tools
+
+LIB_DEPENDS= fftw3.4:${PORTSDIR}/math/fftw3 \
+ ao.3:${PORTSDIR}/audio/libao \
+ sndfile.1:${PORTSDIR}/audio/libsndfile \
+ samplerate.1:${PORTSDIR}/audio/libsamplerate
+
+USE_GNOME= gtk20
+
+PLIST_FILES= bin/waon bin/pv bin/gwaon
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/waon ${PREFIX}/bin/waon
+ ${INSTALL_PROGRAM} ${WRKSRC}/pv ${PREFIX}/bin/pv
+ ${INSTALL_PROGRAM} ${WRKSRC}/gwaon ${PREFIX}/bin/gwaon
+
+.include <bsd.port.mk>