aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-mailnotify
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-04-06 01:43:03 +0800
committerarved <arved@FreeBSD.org>2003-04-06 01:43:03 +0800
commita6013aa8cd53385e176866d2ce19545ab74d4246 (patch)
treeea5ec365ad1cd0f693bcb2d195204b1f8520d0fe /audio/xmms-mailnotify
parent08048c33adeaaa318e9b1816e23e48e38bfaf2bc (diff)
downloadfreebsd-ports-gnome-a6013aa8cd53385e176866d2ce19545ab74d4246.tar.gz
freebsd-ports-gnome-a6013aa8cd53385e176866d2ce19545ab74d4246.tar.zst
freebsd-ports-gnome-a6013aa8cd53385e176866d2ce19545ab74d4246.zip
Continue playing music after a new mail arrived.
Submitted by: joerg
Diffstat (limited to 'audio/xmms-mailnotify')
-rw-r--r--audio/xmms-mailnotify/Makefile2
-rw-r--r--audio/xmms-mailnotify/files/patch-ac26
2 files changed, 27 insertions, 1 deletions
diff --git a/audio/xmms-mailnotify/Makefile b/audio/xmms-mailnotify/Makefile
index 8dd1fb90298c..9b5345aaec9b 100644
--- a/audio/xmms-mailnotify/Makefile
+++ b/audio/xmms-mailnotify/Makefile
@@ -6,7 +6,7 @@
PORTNAME= xmms-mailnotify
PORTVERSION= 0.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= arved
diff --git a/audio/xmms-mailnotify/files/patch-ac b/audio/xmms-mailnotify/files/patch-ac
new file mode 100644
index 000000000000..a9c55359fe45
--- /dev/null
+++ b/audio/xmms-mailnotify/files/patch-ac
@@ -0,0 +1,26 @@
+--- mailnotify.c.orig Mon Mar 31 16:55:38 2003
++++ mailnotify.c Mon Mar 31 16:55:52 2003
+@@ -675,16 +675,18 @@
+ dummy = xmms_remote_get_playlist_file(mailnotify.xmms_session, saved_position);
+ printf(" which is %s\n", dummy);
+ #endif
+- if(!wasplaying)
+- xmms_remote_stop(mailnotify.xmms_session);
+-
++ xmms_remote_stop(mailnotify.xmms_session);
+ xmms_remote_set_playlist_pos(mailnotify.xmms_session, saved_position);
+ xmms_remote_playlist_delete(mailnotify.xmms_session, afpos);
+
+-#ifdef CONTINUE_WHERE_INTERRUPTED
+ if(wasplaying)
++ {
++ xmms_remote_play(mailnotify.xmms_session);
++#ifdef CONTINUE_WHERE_INTERRUPTED
+ xmms_remote_jump_to_time(mailnotify.xmms_session, saved_offset);
+ #endif
++ }
++
+ }
+ else
+ {
+