aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmmsctrl
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-10-02 07:44:44 +0800
committerjylefort <jylefort@FreeBSD.org>2005-10-02 07:44:44 +0800
commitb74f1a775ec210fb1b3d3b06e191d03ff557655a (patch)
treef373da9f8d880d46526ae6a2dd402afe5406ce79 /audio/xmmsctrl
parent70797567d6cebdfb9a036460126fe2f99f591462 (diff)
downloadfreebsd-ports-gnome-b74f1a775ec210fb1b3d3b06e191d03ff557655a.tar.gz
freebsd-ports-gnome-b74f1a775ec210fb1b3d3b06e191d03ff557655a.tar.zst
freebsd-ports-gnome-b74f1a775ec210fb1b3d3b06e191d03ff557655a.zip
Add xmmsctrl.
xmmsctrl is a small utility to control XMMS from the command line. Its goal is to be used coupled with sh to test XMMS state and perform an appropriate action, e.g. if playing then pause else play. The interest of this is to bind keys in a window manager to have control over XMMS with keys that do play/next/pause, prev, control sound... WWW: http://user.it.uu.se/~adavid/utils/ PR: ports/86534 Submitted by: Jason E. Hale <jhale@bluebottle.com>
Diffstat (limited to 'audio/xmmsctrl')
-rw-r--r--audio/xmmsctrl/Makefile37
-rw-r--r--audio/xmmsctrl/distinfo2
-rw-r--r--audio/xmmsctrl/files/patch-Makefile23
-rw-r--r--audio/xmmsctrl/files/patch-removefile.c20
-rw-r--r--audio/xmmsctrl/pkg-descr7
-rw-r--r--audio/xmmsctrl/pkg-plist13
6 files changed, 102 insertions, 0 deletions
diff --git a/audio/xmmsctrl/Makefile b/audio/xmmsctrl/Makefile
new file mode 100644
index 000000000000..0bdd15975169
--- /dev/null
+++ b/audio/xmmsctrl/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: xmmsctrl
+# Date created: 22 September 2005
+# Whom: Jason E. Hale <jhale@bluebottle.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmmsctrl
+PORTVERSION= 1.8
+CATEGORIES= audio
+MASTER_SITES= http://user.it.uu.se/~adavid/utils/
+
+MAINTAINER= jhale@bluebottle.com
+COMMENT= A small utility to control XMMS from the command line
+
+BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+
+USE_GMAKE= yes
+MAKE_ENV= CC="${CC}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+PORTDOCS= Changelog README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmmsctrl ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/samples && \
+ ${INSTALL_DATA} emacs-transcriber twmrc_bindings \
+ ${EXAMPLESDIR} && \
+ ${INSTALL_SCRIPT} *.sh ${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/audio/xmmsctrl/distinfo b/audio/xmmsctrl/distinfo
new file mode 100644
index 000000000000..af993bf2c2d9
--- /dev/null
+++ b/audio/xmmsctrl/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmmsctrl-1.8.tar.gz) = 0774f3e61cfc89c1fd3f0526c48b35db
+SIZE (xmmsctrl-1.8.tar.gz) = 14043
diff --git a/audio/xmmsctrl/files/patch-Makefile b/audio/xmmsctrl/files/patch-Makefile
new file mode 100644
index 000000000000..096d19a9cc47
--- /dev/null
+++ b/audio/xmmsctrl/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig Fri Apr 2 15:00:12 2004
++++ Makefile Sun Oct 2 01:30:57 2005
+@@ -6,17 +6,15 @@
+ VERSION := 1.8
+ DIRNAME := $(shell basename $(PWD))
+
+-CC := gcc
+ WARN := -Wall -Wshadow -Wmissing-prototypes -W
+ DEFS := -DPRETTY_PRINT -D_GNU_SOURCE -DVERSION=\"$(VERSION)\"
+-CFLAGS := $(WARN) -O2 $(shell xmms-config --cflags) $(DEFS)
+-LDFLAGS := $(shell xmms-config --libs)
++CFLAGS += $(WARN) $(shell xmms-config --cflags) $(DEFS) $(PTHREAD_CFLAGS)
++LDFLAGS := $(shell xmms-config --libs) $(PTHREAD_LIBS)
+
+-all : $(TARGET) HELP
++all : $(TARGET)
+
+ $(TARGET) : xmmsctrl.c removefile.c
+ $(CC) -o $(TARGET) xmmsctrl.c removefile.c $(CFLAGS) $(LDFLAGS)
+- strip xmmsctrl
+
+ HELP : xmmsctrl
+ ./xmmsctrl > HELP || true
diff --git a/audio/xmmsctrl/files/patch-removefile.c b/audio/xmmsctrl/files/patch-removefile.c
new file mode 100644
index 000000000000..b99afb9fdb1e
--- /dev/null
+++ b/audio/xmmsctrl/files/patch-removefile.c
@@ -0,0 +1,20 @@
+--- removefile.c.orig Thu Apr 1 08:26:19 2004
++++ removefile.c Thu Sep 22 13:41:04 2005
+@@ -111,7 +111,7 @@
+ DIR *dir = opendir(".");
+ if (dir) {
+ /* xmms uses absolute paths */
+- char *pwd = get_current_dir_name();
++ char *pwd = getcwd(NULL,PATH_MAX);
+ struct dirent *entry;
+ struct stat file_stat;
+
+@@ -189,7 +189,7 @@
+ gint *remove_pos = (gint*) malloc(list_size*sizeof(gint));
+
+ if (remove_pos) {
+- char *pwd = get_current_dir_name();
++ char *pwd = getcwd(NULL,PATH_MAX);
+ int root_len = strlen(pwd)+1; /* +1: jump appended / */
+ gint i;
+
diff --git a/audio/xmmsctrl/pkg-descr b/audio/xmmsctrl/pkg-descr
new file mode 100644
index 000000000000..9ec0df4ebb5e
--- /dev/null
+++ b/audio/xmmsctrl/pkg-descr
@@ -0,0 +1,7 @@
+xmmsctrl is a small utility to control XMMS from the command line. Its
+goal is to be used coupled with sh to test XMMS state and perform an
+appropriate action, e.g. if playing then pause else play. The interest
+of this is to bind keys in a window manager to have control over XMMS
+with keys that do play/next/pause, prev, control sound...
+
+WWW: http://user.it.uu.se/~adavid/utils/
diff --git a/audio/xmmsctrl/pkg-plist b/audio/xmmsctrl/pkg-plist
new file mode 100644
index 000000000000..c5da5a948a43
--- /dev/null
+++ b/audio/xmmsctrl/pkg-plist
@@ -0,0 +1,13 @@
+bin/xmmsctrl
+%%EXAMPLESDIR%%/emacs-transcriber
+%%EXAMPLESDIR%%/pause_stop_play.sh
+%%EXAMPLESDIR%%/play_pause.sh
+%%EXAMPLESDIR%%/play_unpause_next.sh
+%%EXAMPLESDIR%%/playlist2html.sh
+%%EXAMPLESDIR%%/twmrc_bindings
+%%EXAMPLESDIR%%/win_playlist.sh
+%%EXAMPLESDIR%%/window_shown.sh
+%%EXAMPLESDIR%%/xmmsnext.sh
+%%EXAMPLESDIR%%/xmmsprev.sh
+%%EXAMPLESDIR%%/xmmsswitch.sh
+@dirrm %%EXAMPLESDIR%%