aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmp
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-13 00:55:22 +0800
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-13 00:55:22 +0800
commitecaa0b842ad1b3afc9c15cc9204964f754371726 (patch)
tree0c11352e2f06aaefacdabd57efb6d3abf86d142b /audio/xmp
parentdd83a864464e35cf5e3e995b2b7d76a66126484a (diff)
downloadfreebsd-ports-gnome-ecaa0b842ad1b3afc9c15cc9204964f754371726.tar.gz
freebsd-ports-gnome-ecaa0b842ad1b3afc9c15cc9204964f754371726.tar.zst
freebsd-ports-gnome-ecaa0b842ad1b3afc9c15cc9204964f754371726.zip
Update to 3.4.0 and drop audacious plugin support for now as the plugin does not
compile with the current audacious plugin API. Note that the current version of the audacious plugin also stopped working when multimedia/audacious was last updated. Also drop aRts support, does not compile.
Diffstat (limited to 'audio/xmp')
-rw-r--r--audio/xmp/Makefile34
-rw-r--r--audio/xmp/distinfo4
-rw-r--r--audio/xmp/pkg-plist1
3 files changed, 11 insertions, 28 deletions
diff --git a/audio/xmp/Makefile b/audio/xmp/Makefile
index 3d4f6bd14353..e7fc72a57866 100644
--- a/audio/xmp/Makefile
+++ b/audio/xmp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmp
-PORTVERSION= 3.3.0
-PORTREVISION= 2
+PORTVERSION= 3.4.0
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= SF
@@ -15,18 +14,18 @@ MASTER_SITES= SF
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A player for many different Amiga and PC module formats
+LICENSE= GPLv2
+
USE_GMAKE= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc --disable-arts \
+ --disable-audacious-plugin
MAN1= xmp.1
OPTIONS= ALSA "ALSA output driver" off \
- ARTS "aRts output driver" off \
- AUDACIOUS "Audacious plugin" off \
BMP "BeepMP plugin" off \
ESOUND "EsounD output driver" off \
NAS "Network Audio System ouptut driver" off \
@@ -36,8 +35,6 @@ OPTIONS= ALSA "ALSA output driver" off \
MAKE_JOBS_SAFE= yes
-LICENSE= GPLv2
-
.include <bsd.port.pre.mk>
.if !defined(NOPORTDOCS)
@@ -52,22 +49,6 @@ CONFIGURE_ARGS+= --enable-alsa
CONFIGURE_ARGS+= --disable-alsa
.endif
-.if defined(WITH_ARTS)
-LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
-CONFIGURE_ARGS+= --enable-arts
-.else
-CONFIGURE_ARGS+= --disable-arts
-.endif
-
-.if defined(WITH_AUDACIOUS)
-LIB_DEPENDS+= audclient.2:${PORTSDIR}/multimedia/audacious
-CONFIGURE_ARGS+= --enable-audacious-plugin
-PLIST_SUB+= AUDACIOUS=""
-.else
-CONFIGURE_ARGS+= --disable-audacious-plugin
-PLIST_SUB+= AUDACIOUS="@comment "
-.endif
-
.if defined(WITH_BMP)
LIB_DEPENDS+= beep.2:${PORTSDIR}/multimedia/beep-media-player
CONFIGURE_ARGS+= --enable-bmp-plugin
@@ -120,6 +101,9 @@ post-patch: .SILENT
${REINPLACE_CMD} -e \
'/$$(INSTALL_DATA)/s|\([[:alnum:]]*\.conf\).*$$|&\1.sample|' \
${WRKSRC}/etc/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|-Wno-unknown-warning-option -Wno-unused-but-set-variable||' \
+ ${WRKSRC}/configure
post-install: .SILENT
if [ ! -f ${ETCDIR}/${PORTNAME}.conf ]; then \
diff --git a/audio/xmp/distinfo b/audio/xmp/distinfo
index 585e055d48cd..5fb5a3088e9a 100644
--- a/audio/xmp/distinfo
+++ b/audio/xmp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xmp-3.3.0.tar.gz) = 9ddfc1954a9faf4863f15cab2309f90d87b8aad11968f888a7f21accc42b0c54
-SIZE (xmp-3.3.0.tar.gz) = 848652
+SHA256 (xmp-3.4.0.tar.gz) = ad1895cfa21e6952c01186cea26c939d1c6f15e284217c80cc03727bc3ee7438
+SIZE (xmp-3.4.0.tar.gz) = 857700
diff --git a/audio/xmp/pkg-plist b/audio/xmp/pkg-plist
index c181f8540545..4edc76eaefe0 100644
--- a/audio/xmp/pkg-plist
+++ b/audio/xmp/pkg-plist
@@ -5,7 +5,6 @@ bin/xmp
@unexec if cmp -s %D/%%ETCDIR%%/modules.conf.sample %D/%%ETCDIR%%/modules.conf; then rm -f %D/%%ETCDIR%%/modules.conf; fi
%%ETCDIR%%/modules.conf.sample
@exec if [ ! -f %D/%%ETCDIR%%/modules.conf ]; then cp -p %D/%F %B/modules.conf; fi
-%%AUDACIOUS%%lib/audacious/Input/xmp-audacious.so
%%BMP%%lib/bmp/Input/xmp-bmp.so
%%XMMS%%lib/xmms/Input/xmp-xmms.so
@dirrmtry %%ETCDIR%%