aboutsummaryrefslogtreecommitdiffstats
path: root/audio/zinf/Makefile
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-03-14 13:58:51 +0800
committerpat <pat@FreeBSD.org>2002-03-14 13:58:51 +0800
commit328e00d46c4fbf1168b57e06902be42d117ee25d (patch)
tree1527fd3015d27caf42f410140c4bb3a099f6605a /audio/zinf/Makefile
parentfb5dbf0843a286968def87f366570f2bfd6d315b (diff)
downloadfreebsd-ports-gnome-328e00d46c4fbf1168b57e06902be42d117ee25d.tar.gz
freebsd-ports-gnome-328e00d46c4fbf1168b57e06902be42d117ee25d.tar.zst
freebsd-ports-gnome-328e00d46c4fbf1168b57e06902be42d117ee25d.zip
Depend on freetype2 libs and fix ORBit detection
PR: 35881, 35845 Submitted by: maintainer, Steve Wills <steve@stevenwills.com>
Diffstat (limited to 'audio/zinf/Makefile')
-rw-r--r--audio/zinf/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/zinf/Makefile b/audio/zinf/Makefile
index 931a0443a6b7..963b3eb118bd 100644
--- a/audio/zinf/Makefile
+++ b/audio/zinf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freeamp
PORTVERSION= 2.1.1
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.freeamp.org/download/src/
@@ -16,7 +17,7 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= musicbrainz.1:${PORTSDIR}/audio/musicbrainz \
ORBit.2:${PORTSDIR}/devel/ORBit \
gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
- ttf.4:${PORTSDIR}/print/freetype
+ freetype.9:${PORTSDIR}/print/freetype2
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
@@ -24,7 +25,9 @@ USE_GTK= yes
WANT_ESOUND= yes
USE_GMAKE= yes
USE_AUTOCONF_VER=213
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ORBIT_CFLAGS!= orbit-config --cflags server
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
+ ${ORBIT_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>