aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2013-11-07 23:29:22 +0800
committerdbn <dbn@FreeBSD.org>2013-11-07 23:29:22 +0800
commit05f096e57482d67f8b0316d161d06cbe9b0d958a (patch)
tree61bfa34c6f47af17178a3ad05c99f7047ea19408 /audio
parent35ad7e8ecde87f76d75e978d5a462b6ddf578ece (diff)
downloadfreebsd-ports-gnome-05f096e57482d67f8b0316d161d06cbe9b0d958a.tar.gz
freebsd-ports-gnome-05f096e57482d67f8b0316d161d06cbe9b0d958a.tar.zst
freebsd-ports-gnome-05f096e57482d67f8b0316d161d06cbe9b0d958a.zip
Add stage support to audio/kaudiocreator.
- Convert LIB_DEPENDS to new format.
Diffstat (limited to 'audio')
-rw-r--r--audio/kaudiocreator/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/audio/kaudiocreator/Makefile b/audio/kaudiocreator/Makefile
index 8b49b2ff9bb6..adc1f28dedea 100644
--- a/audio/kaudiocreator/Makefile
+++ b/audio/kaudiocreator/Makefile
@@ -13,8 +13,8 @@ COMMENT= Audio-cd ripper and encoder for KDE4
LICENSE= GPLv2
-LIB_DEPENDS= discid:${PORTSDIR}/audio/libdiscid \
- tag:${PORTSDIR}/audio/taglib
+LIB_DEPENDS= libdiscid.so:${PORTSDIR}/audio/libdiscid \
+ libtag.so:${PORTSDIR}/audio/taglib
RUN_DEPENDS= flac:${PORTSDIR}/audio/flac \
oggenc:${PORTSDIR}/audio/vorbis-tools
.if !defined(PACKAGE_BUILDING)
@@ -22,7 +22,6 @@ RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
.endif
USE_BZIP2= yes
-NO_STAGE= yes
USES= cmake
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_KDE4= automoc4 kdehier kdeprefix libkcddb libkcompactdisc
@@ -30,18 +29,14 @@ USE_KDE4= automoc4 kdehier kdeprefix libkcddb libkcompactdisc
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-
+.if empty(PORT_OPTIONS:MNLS)
post-patch:
${REINPLACE_CMD} 's,add_subdirectory(po),,' ${WRKSRC}/CMakeLists.txt
-
.endif
.include <bsd.port.mk>