aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2006-09-04 22:05:33 +0800
committermich <mich@FreeBSD.org>2006-09-04 22:05:33 +0800
commit08f417629feaeda6bc9d5a2ea8a9a8ac7f30ed4a (patch)
tree3704026c9a2baa08f859eb13418468111c13b69f /audio
parent340e4784f1f44509dfa1897a1444e0bbcb542cac (diff)
downloadfreebsd-ports-gnome-08f417629feaeda6bc9d5a2ea8a9a8ac7f30ed4a.tar.gz
freebsd-ports-gnome-08f417629feaeda6bc9d5a2ea8a9a8ac7f30ed4a.tar.zst
freebsd-ports-gnome-08f417629feaeda6bc9d5a2ea8a9a8ac7f30ed4a.zip
- Add support for Nomad Jukebox support (via libnjb) [1]
- Change instances of amaroK to Amarok Submitted by: Vyacheslav Druzhinin <dvg_lab@mail.ru> [1]
Diffstat (limited to 'audio')
-rw-r--r--audio/amarok-kde4/Makefile9
-rw-r--r--audio/amarok-kde4/pkg-descr2
-rw-r--r--audio/amarok-kde4/pkg-message2
-rw-r--r--audio/amarok-kde4/pkg-plist4
-rw-r--r--audio/amarok/Makefile9
-rw-r--r--audio/amarok/pkg-descr2
-rw-r--r--audio/amarok/pkg-message2
-rw-r--r--audio/amarok/pkg-plist4
8 files changed, 30 insertions, 4 deletions
diff --git a/audio/amarok-kde4/Makefile b/audio/amarok-kde4/Makefile
index 5a0557c923ad..aeb5d786f515 100644
--- a/audio/amarok-kde4/Makefile
+++ b/audio/amarok-kde4/Makefile
@@ -29,6 +29,7 @@ USE_RUBY= yes
USE_LDCONFIG= yes
OPTIONS= GPOD "iPod support" on \
+ NJB "Creative Nomad and Dell support" on \
XMMS "XMMS visualizations" off \
OPENGL "OpenGL support" on \
AMAZON "Amazon cover fetching support" on \
@@ -54,6 +55,14 @@ CONFIGURE_ARGS+=--with-libgpod
PLIST_SUB+= GPOD=""
.endif
+.if !defined(WITH_NJB)
+PLIST_SUB+= NJB="@comment "
+.else
+LIB_DEPENDS+= njb.6:${PORTSDIR}/audio/libnjb
+CONFIGURE_ARGS+=--with-libnjb
+PLIST_SUB+= NJB=""
+.endif
+
.if !defined(WITH_XMMS)
PLIST_SUB+= XMMS="@comment "
CONFIGURE_ARGS+=--without-xmms
diff --git a/audio/amarok-kde4/pkg-descr b/audio/amarok-kde4/pkg-descr
index f9c4f3cdefff..9478adb3787e 100644
--- a/audio/amarok-kde4/pkg-descr
+++ b/audio/amarok-kde4/pkg-descr
@@ -1,4 +1,4 @@
-amaroK is a media player for KDE. It uses the multimedia
+Amarok is a media player for KDE. It uses the multimedia
framework-independent frontend to play audio files, and
features a fresh and efficient approach to playlist handling.
Emphasis is on the quick and easy user interface, allowing
diff --git a/audio/amarok-kde4/pkg-message b/audio/amarok-kde4/pkg-message
index dcb2ece81bf0..1aa6bc0e39c1 100644
--- a/audio/amarok-kde4/pkg-message
+++ b/audio/amarok-kde4/pkg-message
@@ -1,6 +1,6 @@
ATTENTION:
-You have installed amaroK with libvisual support. If you want to be able to
+You have installed Amarok with libvisual support. If you want to be able to
access any visualizations, you must install the graphics/libvisual-plugins
port.
diff --git a/audio/amarok-kde4/pkg-plist b/audio/amarok-kde4/pkg-plist
index 4d4db50491df..69b1d11d2034 100644
--- a/audio/amarok-kde4/pkg-plist
+++ b/audio/amarok-kde4/pkg-plist
@@ -26,6 +26,9 @@ lib/kde3/libamarok_smb-device.a
%%GPOD%%lib/kde3/libamarok_ipod-mediadevice.so
%%GPOD%%lib/kde3/libamarok_ipod-mediadevice.la
%%GPOD%%lib/kde3/libamarok_ipod-mediadevice.a
+%%NJB%%lib/kde3/libamarok_njb-mediadevice.so
+%%NJB%%lib/kde3/libamarok_njb-mediadevice.la
+%%NJB%%lib/kde3/libamarok_njb-mediadevice.a
lib/kde3/libamarok_generic-mediadevice.so
lib/kde3/libamarok_generic-mediadevice.la
lib/kde3/libamarok_generic-mediadevice.a
@@ -962,6 +965,7 @@ share/locale/uz/LC_MESSAGES/amarok.mo
share/locale/zh_CN/LC_MESSAGES/amarok.mo
share/locale/zh_TW/LC_MESSAGES/amarok.mo
%%GPOD%%share/services/amarok_ipod-mediadevice.desktop
+%%NJB%%share/services/amarok_njb-mediadevice.desktop
share/services/amarokitpc.protocol
share/services/amaroklastfm.protocol
share/services/amarokpcast.protocol
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index 5a0557c923ad..aeb5d786f515 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -29,6 +29,7 @@ USE_RUBY= yes
USE_LDCONFIG= yes
OPTIONS= GPOD "iPod support" on \
+ NJB "Creative Nomad and Dell support" on \
XMMS "XMMS visualizations" off \
OPENGL "OpenGL support" on \
AMAZON "Amazon cover fetching support" on \
@@ -54,6 +55,14 @@ CONFIGURE_ARGS+=--with-libgpod
PLIST_SUB+= GPOD=""
.endif
+.if !defined(WITH_NJB)
+PLIST_SUB+= NJB="@comment "
+.else
+LIB_DEPENDS+= njb.6:${PORTSDIR}/audio/libnjb
+CONFIGURE_ARGS+=--with-libnjb
+PLIST_SUB+= NJB=""
+.endif
+
.if !defined(WITH_XMMS)
PLIST_SUB+= XMMS="@comment "
CONFIGURE_ARGS+=--without-xmms
diff --git a/audio/amarok/pkg-descr b/audio/amarok/pkg-descr
index f9c4f3cdefff..9478adb3787e 100644
--- a/audio/amarok/pkg-descr
+++ b/audio/amarok/pkg-descr
@@ -1,4 +1,4 @@
-amaroK is a media player for KDE. It uses the multimedia
+Amarok is a media player for KDE. It uses the multimedia
framework-independent frontend to play audio files, and
features a fresh and efficient approach to playlist handling.
Emphasis is on the quick and easy user interface, allowing
diff --git a/audio/amarok/pkg-message b/audio/amarok/pkg-message
index dcb2ece81bf0..1aa6bc0e39c1 100644
--- a/audio/amarok/pkg-message
+++ b/audio/amarok/pkg-message
@@ -1,6 +1,6 @@
ATTENTION:
-You have installed amaroK with libvisual support. If you want to be able to
+You have installed Amarok with libvisual support. If you want to be able to
access any visualizations, you must install the graphics/libvisual-plugins
port.
diff --git a/audio/amarok/pkg-plist b/audio/amarok/pkg-plist
index 4d4db50491df..69b1d11d2034 100644
--- a/audio/amarok/pkg-plist
+++ b/audio/amarok/pkg-plist
@@ -26,6 +26,9 @@ lib/kde3/libamarok_smb-device.a
%%GPOD%%lib/kde3/libamarok_ipod-mediadevice.so
%%GPOD%%lib/kde3/libamarok_ipod-mediadevice.la
%%GPOD%%lib/kde3/libamarok_ipod-mediadevice.a
+%%NJB%%lib/kde3/libamarok_njb-mediadevice.so
+%%NJB%%lib/kde3/libamarok_njb-mediadevice.la
+%%NJB%%lib/kde3/libamarok_njb-mediadevice.a
lib/kde3/libamarok_generic-mediadevice.so
lib/kde3/libamarok_generic-mediadevice.la
lib/kde3/libamarok_generic-mediadevice.a
@@ -962,6 +965,7 @@ share/locale/uz/LC_MESSAGES/amarok.mo
share/locale/zh_CN/LC_MESSAGES/amarok.mo
share/locale/zh_TW/LC_MESSAGES/amarok.mo
%%GPOD%%share/services/amarok_ipod-mediadevice.desktop
+%%NJB%%share/services/amarok_njb-mediadevice.desktop
share/services/amarokitpc.protocol
share/services/amaroklastfm.protocol
share/services/amarokpcast.protocol