aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2018-02-26 23:27:34 +0800
committerjhale <jhale@FreeBSD.org>2018-02-26 23:27:34 +0800
commit09f2439aa2b7f33491131e3038954ff78170f6ef (patch)
treed5e982ae142cec293d0815e66eb2529c398eef0d /audio
parent1e0a43618a42d4d7270c5f1d7f01c4c2a2142cfc (diff)
downloadfreebsd-ports-gnome-09f2439aa2b7f33491131e3038954ff78170f6ef.tar.gz
freebsd-ports-gnome-09f2439aa2b7f33491131e3038954ff78170f6ef.tar.zst
freebsd-ports-gnome-09f2439aa2b7f33491131e3038954ff78170f6ef.zip
Fix stage-qa errors when building a non-default Python flavor when DOCS option
is enabled. (e.g. py27 default, try to build py36) ===> Checking for items in STAGEDIR missing from pkg-plist Error: Orphaned: %%PYTHON_SITELIBDIR%%/pyaudio.pyc ===> Checking for items in pkg-plist which are not in STAGEDIR ===> Error: Plist issues found. textproc/py-sphinx is only needed for DOCS here and should be the same flavor as the port being built to avoid bytecode leftovers. Do DOCS build in the build stage and simplify DOCS installation Approved by: portmgr (blanket)
Diffstat (limited to 'audio')
-rw-r--r--audio/py-pyaudio/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/audio/py-pyaudio/Makefile b/audio/py-pyaudio/Makefile
index a0dbcf85b510..39f5ba9572ef 100644
--- a/audio/py-pyaudio/Makefile
+++ b/audio/py-pyaudio/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pyaudio
PORTVERSION= 0.2.11
+PORTREVISION= 1
CATEGORIES= audio python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,30 +15,30 @@ COMMENT= Portaudio toolkit bindings for Python
LICENSE= MIT
LIB_DEPENDS= libportaudio.so:audio/portaudio
-BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
USES= python gmake
USE_PYTHON= distutils autoplist
+MAKE_ENV= PYTHON=${PYTHON_CMD} \
+ SPHINX=sphinx-build-${PYTHON_VER}
+PORTDOCS= *
WRKSRC= ${WRKDIR}/PyAudio-${PORTVERSION}
OPTIONS_DEFINE= DOCS
-PORTDOCS= *
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
post-patch:
@${REINPLACE_CMD} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/setup.py
-pre-install:
- (cd ${BUILD_WRKSRC} && ${MAKE_CMD} PYTHON=${PYTHON_CMD} docs)
+post-build-DOCS-on:
+ (cd ${BUILD_WRKSRC} && ${DO_MAKE_BUILD} docs)
+
+post-install-DOCS-on:
+ (cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -path *doctrees*")
post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.html ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.js ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.inv ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC}/docs && ${COPYTREE_SHARE} _static ${STAGEDIR}${DOCSDIR}/
- @cd ${WRKSRC}/docs && ${COPYTREE_SHARE} _sources ${STAGEDIR}${DOCSDIR}/
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_portaudio.so
.include <bsd.port.mk>