aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
committeraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
commit0a9e5efb9de6b8811964b263c03b83ec89719f71 (patch)
treeaf6266e338105f6caa968f90afd0c4e98288d6f5 /audio
parent161ee4e405ddee7d6c945754c827684829ef8e90 (diff)
downloadfreebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.gz
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.zst
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'audio')
-rw-r--r--audio/mp32ogg/Makefile11
-rw-r--r--audio/p5-Shout/Makefile8
2 files changed, 6 insertions, 13 deletions
diff --git a/audio/mp32ogg/Makefile b/audio/mp32ogg/Makefile
index 14b75a822c18..43a027fbfbf1 100644
--- a/audio/mp32ogg/Makefile
+++ b/audio/mp32ogg/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: mp32ogg
-# Date created: Nov 4, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= mp32ogg
PORTVERSION= 0.11
@@ -24,6 +19,8 @@ RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123 \
p5-String-ShellQuote>=0:${PORTSDIR}/textproc/p5-String-ShellQuote
USE_PERL5= yes
+USES= shebangfix
+SHEBANG_FILES= mp32ogg
NO_WRKSUBDIR= yes
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS= #
@@ -32,7 +29,7 @@ NO_BUILD= yes
PLIST_FILES= bin/mp32ogg
post-patch:
- @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/mp32ogg
+ @${REINPLACE_CMD} -i '' -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/mp32ogg
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/mp32ogg ${PREFIX}/bin
diff --git a/audio/p5-Shout/Makefile b/audio/p5-Shout/Makefile
index bea8ece05f70..09e9c61da460 100644
--- a/audio/p5-Shout/Makefile
+++ b/audio/p5-Shout/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Shout
-# Date created: 18 April 2001
-# Whom: leo
-#
+# Created by: leo
# $FreeBSD$
-#
PORTNAME= Shout
PORTVERSION= 2.1
@@ -23,7 +19,7 @@ MAN3= Shout.3
DOCSDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
post-patch:
- @${PERL} -i -pe 's/CCFLAGS/INC/;' ${WRKSRC}/Makefile.PL
+ ${REINPLACE_CMD} -i '' -e 's/CCFLAGS/INC/' ${WRKSRC}/Makefile.PL
post-configure:
@${PERL} -i -pe '$$_ .= " ${PTHREAD_LIBS}" if /^LDDLFLAGS/;' ${WRKSRC}/Makefile