aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-09-24 16:21:47 +0800
committergahr <gahr@FreeBSD.org>2013-09-24 16:21:47 +0800
commit0abeb44147c2091db30f8240505550a578d2af9f (patch)
tree8e8e0aa5830ed18e55ce4357b0aad27d5f9c1de2 /audio
parentac923ff3945b9ec6abe8280b67380a510e9d3868 (diff)
downloadfreebsd-ports-gnome-0abeb44147c2091db30f8240505550a578d2af9f.tar.gz
freebsd-ports-gnome-0abeb44147c2091db30f8240505550a578d2af9f.tar.zst
freebsd-ports-gnome-0abeb44147c2091db30f8240505550a578d2af9f.zip
- Convert to USES+=tcl
- Fix build on all supported versions
Diffstat (limited to 'audio')
-rw-r--r--audio/tclmidi/Makefile6
-rw-r--r--audio/tclmidi/files/patch-ac17
-rw-r--r--audio/tclmidi/files/patch-smf_SMFHead.cxx13
-rw-r--r--audio/tclmidi/files/patch-smf_SMFHead.h15
-rw-r--r--audio/tclmidi/files/patch-tclmUtil.cxx30
5 files changed, 67 insertions, 14 deletions
diff --git a/audio/tclmidi/Makefile b/audio/tclmidi/Makefile
index d5fae21cf615..6c1cf1ff7707 100644
--- a/audio/tclmidi/Makefile
+++ b/audio/tclmidi/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://ringtail.its.monash.edu.au/pub/midi/PROGRAMS/
MAINTAINER= ports@FreeBSD.org
COMMENT= Language designed for creating and editing standard MIDI files
-USE_TCL= 84+
+USES+= tcl
NO_STAGE= yes
MAKE_ENV= TCL_INCLUDEDIR="${TCL_INCLUDEDIR}" TCL_LIBDIR="${TCL_LIBDIR}"
MAKE_ENV+= TCLSH=${TCLSH} FILESDIR="${FILESDIR}" MAN="${MAN1} ${MANN}"
@@ -26,6 +26,10 @@ MANN= midiconf.n midievnt.n midifree.n midiget.n midigrep.n \
miditrck.n mididev.n miditime.n midifeat.n
MANCOMPRESSED= maybe
+post-patch:
+ ${FIND} ${WRKSRC} -type f | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|iostream.h|iostream|g; s|iomanip.h|iomanip|g'
+
post-build:
cd ${WRKSRC} && echo pkg_mkIndex . tclmidi31.so | ${TCLSH}
diff --git a/audio/tclmidi/files/patch-ac b/audio/tclmidi/files/patch-ac
index 4bb47854e3ef..457060c0f032 100644
--- a/audio/tclmidi/files/patch-ac
+++ b/audio/tclmidi/files/patch-ac
@@ -1,20 +1,11 @@
---- smf/SMFTrack.cxx.orig Mon Aug 5 05:47:36 1996
-+++ smf/SMFTrack.cxx Wed May 14 03:51:51 2003
-@@ -352,10 +352,17 @@
- return (1);
- }
-
-+#include <sys/param.h>
+--- smf/SMFTrack.cxx.orig 1996-08-05 05:47:36.000000000 +0200
++++ smf/SMFTrack.cxx 2013-09-24 09:53:53.000000000 +0200
+@@ -355,7 +355,8 @@
ostream &
operator<<(ostream &os, const SMFTrack &t)
{
- long i, prev_flags;
-+#if __FreeBSD_version < 500000
-+ long
-+#else
-+ std::_Ios_Fmtflags
-+#endif
-+ prev_flags;
++ std::ios_base::fmtflags prev_flags;
+ long i;
int prev_width;
unsigned char *ptr;
diff --git a/audio/tclmidi/files/patch-smf_SMFHead.cxx b/audio/tclmidi/files/patch-smf_SMFHead.cxx
new file mode 100644
index 000000000000..897dedea31e8
--- /dev/null
+++ b/audio/tclmidi/files/patch-smf_SMFHead.cxx
@@ -0,0 +1,13 @@
+--- smf/SMFHead.cxx.orig 2013-09-24 09:16:20.000000000 +0200
++++ smf/SMFHead.cxx 2013-09-24 09:16:53.000000000 +0200
+@@ -160,8 +160,8 @@
+ return (1);
+ }
+
+-ostream &
+-operator<<(ostream &os, const SMFHead &h)
++std::ostream &
++operator<<(std::ostream &os, const SMFHead &h)
+ {
+
+ os << "Format: " << h.format << " Num. Tracks: " << h.num_tracks
diff --git a/audio/tclmidi/files/patch-smf_SMFHead.h b/audio/tclmidi/files/patch-smf_SMFHead.h
new file mode 100644
index 000000000000..791aefa61f18
--- /dev/null
+++ b/audio/tclmidi/files/patch-smf_SMFHead.h
@@ -0,0 +1,15 @@
+--- smf/SMFHead.h.orig 2013-09-24 09:15:40.000000000 +0200
++++ smf/SMFHead.h 2013-09-24 09:15:50.000000000 +0200
+@@ -34,10 +34,10 @@
+ extern "C" {
+ #include <tcl.h>
+ }
+-#include <iostream.h>
++#include <iostream>
+
+ class SMFHead {
+- friend ostream &operator<<(ostream &os, const SMFHead &h);
++ friend std::ostream &operator<<(std::ostream &os, const SMFHead &h);
+ public:
+ SMFHead();
+ SMFHead(short form, short num, short div);
diff --git a/audio/tclmidi/files/patch-tclmUtil.cxx b/audio/tclmidi/files/patch-tclmUtil.cxx
new file mode 100644
index 000000000000..a4dde2a2285d
--- /dev/null
+++ b/audio/tclmidi/files/patch-tclmUtil.cxx
@@ -0,0 +1,30 @@
+--- tclmUtil.cxx.orig 2013-09-24 09:20:50.000000000 +0200
++++ tclmUtil.cxx 2013-09-24 09:22:32.000000000 +0200
+@@ -31,8 +31,8 @@
+ extern "C" {
+ #include <tcl.h>
+ }
+-#include <iostream.h>
+-#include <iomanip.h>
++#include <iostream>
++#include <iomanip>
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <string.h>
+@@ -99,12 +99,12 @@
+ }
+
+ void
+-Tclm_PrintData(ostream &buf, const unsigned char *data, long length)
++Tclm_PrintData(std::ostream &buf, const unsigned char *data, long length)
+ {
+ long i;
+
+- buf.setf(ios::showbase | ios::internal);
+- buf << hex << setw(4) << setfill('0') << (int)data[0];
++ buf.setf(std::ios::showbase | std::ios::internal);
++ buf << std::hex << std::setw(4) << std::setfill('0') << (int)data[0];
+ for (i = 1; i < length; i++)
+- buf << " " << hex << setw(4) << setfill('0') << (int)data[i];
++ buf << " " << std::hex << std::setw(4) << std::setfill('0') << (int)data[i];
+ }