aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
committerlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
commit12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5 (patch)
treeee1202c5a5464562474562e70212261185323b7d /audio
parent82b2604cbc93a294ed39ce8da691d406c1342992 (diff)
downloadfreebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.gz
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.zst
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.zip
Fix build on gcc-based archs by updating USES.
Tested on powerpc64 and amd64 (for no regression). While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'audio')
-rw-r--r--audio/beatslash-lv2/Makefile2
-rw-r--r--audio/eq10q-lv2/Makefile2
-rw-r--r--audio/midi-matrix-lv2/Makefile4
-rw-r--r--audio/oaml/Makefile2
4 files changed, 4 insertions, 6 deletions
diff --git a/audio/beatslash-lv2/Makefile b/audio/beatslash-lv2/Makefile
index cc157719e132..1bbdeb566881 100644
--- a/audio/beatslash-lv2/Makefile
+++ b/audio/beatslash-lv2/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= lv2>0:audio/lv2 \
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= pkgconfig waf
+USES= compiler:c++11-lang pkgconfig waf
USE_GITHUB= yes
GH_ACCOUNT= blablack
GH_PROJECT= ${PORTNAME}-lv2
diff --git a/audio/eq10q-lv2/Makefile b/audio/eq10q-lv2/Makefile
index 50a22a25b367..4eaf5bedc664 100644
--- a/audio/eq10q-lv2/Makefile
+++ b/audio/eq10q-lv2/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= cmake:outsource dos2unix localbase:ldflags pkgconfig
+USES= cmake:outsource compiler:c++11-lang dos2unix localbase:ldflags pkgconfig
USE_GNOME= glib20 gtk20 gtkmm24 gdkpixbuf2 atkmm cairo cairomm pangomm
DOS2UNIX_FILES= dsp/vu.h
diff --git a/audio/midi-matrix-lv2/Makefile b/audio/midi-matrix-lv2/Makefile
index 33b22836d08b..090acf842afa 100644
--- a/audio/midi-matrix-lv2/Makefile
+++ b/audio/midi-matrix-lv2/Makefile
@@ -13,11 +13,9 @@ COMMENT= LV2 'Midi Matrix' plugin bundle: 'Channel Filter'
LICENSE= ART20
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to build: cc1: unrecognized command line option -std=gnu11
-
BUILD_DEPENDS= lv2>0:audio/lv2
-USES= cmake pkgconfig
+USES= cmake compiler:c11 pkgconfig
USE_XORG= x11 xext
USE_GL= gl glu
diff --git a/audio/oaml/Makefile b/audio/oaml/Makefile
index 660086f42958..41c8e655ca97 100644
--- a/audio/oaml/Makefile
+++ b/audio/oaml/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libogg.so:audio/libogg \
USE_GITHUB= yes
GH_ACCOUNT= oamldev
-USES= cmake
+USES= cmake compiler:c++11-lang
CMAKE_ARGS= -DENABLE_UNITYPLUGIN:BOOL=OFF
PORTDOCS= *