aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2014-12-29 17:01:34 +0800
committerxmj <xmj@FreeBSD.org>2014-12-29 17:01:34 +0800
commit161fee14278fc9ccb3197d3dcfaea35ac3b97e96 (patch)
treebb17421ff787b70f73134c32d308039ef17fa47e /audio
parentd3383eee0aa2b3a76d3d46fe1f8e81ad37e81595 (diff)
downloadfreebsd-ports-gnome-161fee14278fc9ccb3197d3dcfaea35ac3b97e96.tar.gz
freebsd-ports-gnome-161fee14278fc9ccb3197d3dcfaea35ac3b97e96.tar.zst
freebsd-ports-gnome-161fee14278fc9ccb3197d3dcfaea35ac3b97e96.zip
audio/ncmpcpp: Update to 0.6.2
- Remove broken MASTER_SITES - Force a C++11 compiler and stdlib - Add dependency to devel/boost-libs - Force BOOST_LIB_SUFFIX to be empty (required for configure) - Enable UTF8 by default (most music collections nowadays have files with utf-8 encoded names and tags) - Enable TAGLIB by default (taglib is nice to have but adds a dependecy to the rather small audio/taglib) - Do not install ${DOCSDIR}/keys since it was removed - Install ${DOCSDIR}/ncmpcpp-completion.bash and ${DOCSDIR}/bindings - Update pkg-message - Remove files/patch-src__visualizer.h since it's not needed any more PR: 195070 Differential Revision: https://reviews.freebsd.org/D1325 Submitted by: yamagi@yamagi.org Approved by: maintainer timeout (4 weeks) Approved by: koobs (mentor)
Diffstat (limited to 'audio')
-rw-r--r--audio/ncmpcpp/Makefile75
-rw-r--r--audio/ncmpcpp/distinfo4
-rw-r--r--audio/ncmpcpp/files/patch-src__status.cpp11
-rw-r--r--audio/ncmpcpp/files/patch-src__visualizer.h11
-rw-r--r--audio/ncmpcpp/pkg-descr2
-rw-r--r--audio/ncmpcpp/pkg-message9
6 files changed, 39 insertions, 73 deletions
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index cfd65e06cb0c..fe254c65b521 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -1,28 +1,26 @@
-# Created by: Dennis Herrmann <adox@mcx2.org>
# $FreeBSD$
PORTNAME= ncmpcpp
-PORTVERSION= 0.5.10
-PORTREVISION= 4
+PORTVERSION= 0.6.2
CATEGORIES= audio
-MASTER_SITES= http://unkart.ovh.org/ncmpcpp/ \
- http://mirror.mcx2.org/
+MASTER_SITES= http://ncmpcpp.rybczak.net/stable/
MAINTAINER= dhn@FreeBSD.org
COMMENT= ncurses mpd client, clone of ncmpc with some new features
LIB_DEPENDS= libmpdclient.so:${PORTSDIR}/audio/libmpdclient \
- libfftw3.so:${PORTSDIR}/math/fftw3
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libboost_filesystem.so:${PORTSDIR}/devel/boost-libs
-USES= iconv libtool ncurses pkgconfig tar:bzip2
-USE_GCC= any
+USES= compiler:c++11-lib iconv libtool ncurses pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= glib20
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV= BOOST_LIB_SUFFIX=""
-OPTIONS_DEFINE= CURL CLOCK UTF8 TAGLIB OUTPUTS VISUALIZER DOCS
-OPTIONS_DEFAULT= CURL CLOCK OUTPUTS VISUALIZER
+OPTIONS_DEFINE= CURL CLOCK DOCS OUTPUTS TAGLIB UTF8 VISUALIZER
+OPTIONS_DEFAULT= CURL CLOCK OUTPUTS TAGLIB UTF8 VISUALIZER
CURL_DESC= Enable fetching lyrics from the Internet
CLOCK_DESC= clock-screen support
TAGLIB_DESC= taglib support
@@ -32,49 +30,23 @@ VISUALIZER_DESC= Enable music visualizer screen
.include <bsd.port.options.mk>
PLIST_FILES= bin/ncmpcpp \
- man/man1/ncmpcpp.1.gz \
- %%DOCSDIR%%/config \
- %%DOCSDIR%%/keys \
- %%DOCSDIR%%/NEWS \
- %%DOCSDIR%%/AUTHORS \
- %%DOCSDIR%%/COPYING
-
-.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+= --with-curl
-.else
-CONFIGURE_ARGS+= --with-curl=no
-.endif
+ man/man1/ncmpcpp.1.gz
+PORTDOCS= AUTHORS COPYING NEWS bindings config ncmpcpp-completion.bash
-.if ${PORT_OPTIONS:MCLOCK}
-CONFIGURE_ARGS+= --enable-clock
-.else
-CONFIGURE_ARGS+= --disable-clock
-.endif
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+CURL_CONFIGURE_WITH= curl
-.if ${PORT_OPTIONS:MUTF8}
-CONFIGURE_ARGS+= --enable-unicode
-.else
-CONFIGURE_ARGS+= --disable-unicode
-.endif
+CLOCK_CONFIGURE_ENABLE= clock
-.if ${PORT_OPTIONS:MTAGLIB}
-LIB_DEPENDS+= libtag.so:${PORTSDIR}/audio/taglib
-CONFIGURE_ARGS+= --with-taglib
-.else
-CONFIGURE_ARGS+= --with-taglib=no
-.endif
+UTF8_CONFIGURE_ENABLE= unicode
-.if ${PORT_OPTIONS:MOUTPUTS}
-CONFIGURE_ARGS+= --enable-outputs
-.else
-CONFIGURE_ARGS+= --disable-outputs
-.endif
+TAGLIB_LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib
+TAGLIB_CONFIGURE_WITH= taglib
-.if ${PORT_OPTIONS:MVISUALIZER}
-BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
-CONFIGURE_ARGS+= --enable-visualizer
-.endif
+OUTPUTS_CONFIGURE_ENABLE= outputs
+
+VISUALIZER_BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
+VISUALIZER_CONFIGURE_ENABLE= visualizer
.include <bsd.port.pre.mk>
@@ -87,11 +59,8 @@ post-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/ncmpcpp ${STAGEDIR}${PREFIX}/bin/
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}/NEWS
- ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${STAGEDIR}${DOCSDIR}/AUTHORS
- ${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}/COPYING
- ${INSTALL_DATA} ${WRKSRC}/doc/config ${STAGEDIR}${DOCSDIR}/config
- ${INSTALL_DATA} ${WRKSRC}/doc/keys ${STAGEDIR}${DOCSDIR}/keys
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${WRKSRC}/AUTHORS ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/bindings ${WRKSRC}/doc/config ${WRKSRC}/doc/ncmpcpp-completion.bash ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.post.mk>
diff --git a/audio/ncmpcpp/distinfo b/audio/ncmpcpp/distinfo
index ebc09ce7a123..5516fc35fb46 100644
--- a/audio/ncmpcpp/distinfo
+++ b/audio/ncmpcpp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ncmpcpp-0.5.10.tar.bz2) = ff6d5376a2d9caba6f5bb78e68af77cefbdb2f04cd256f738e39f8ac9a79a4a8
-SIZE (ncmpcpp-0.5.10.tar.bz2) = 381162
+SHA256 (ncmpcpp-0.6.2.tar.bz2) = 93ad5f3a460578873376ecaa588305fc446560bfd1a49e6e67da01784d352dd7
+SIZE (ncmpcpp-0.6.2.tar.bz2) = 423708
diff --git a/audio/ncmpcpp/files/patch-src__status.cpp b/audio/ncmpcpp/files/patch-src__status.cpp
new file mode 100644
index 000000000000..61651221eaea
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src__status.cpp
@@ -0,0 +1,11 @@
+--- src/status.cpp_orig 2014-11-16 09:21:55.651181899 +0100
++++ src/status.cpp 2014-11-16 09:21:59.233203196 +0100
+@@ -21,6 +21,8 @@
+ #include <boost/date_time/posix_time/posix_time.hpp>
+ #include <netinet/tcp.h>
+ #include <netinet/in.h>
++#include <sys/types.h>
++#include <sys/socket.h>
+
+ #include "browser.h"
+ #include "charset.h"
diff --git a/audio/ncmpcpp/files/patch-src__visualizer.h b/audio/ncmpcpp/files/patch-src__visualizer.h
deleted file mode 100644
index 8114ee6e1f53..000000000000
--- a/audio/ncmpcpp/files/patch-src__visualizer.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/visualizer.h.orig 2012-04-01 20:49:09.000000000 +0400
-+++ src/visualizer.h 2014-06-16 19:07:34.000000000 +0400
-@@ -34,6 +34,8 @@
- # include <fftw3.h>
- #endif
-
-+#include <sys/time.h>
-+
- class Visualizer : public Screen<Window>
- {
- public:
diff --git a/audio/ncmpcpp/pkg-descr b/audio/ncmpcpp/pkg-descr
index 18609adf91e8..7d8f7d260ab9 100644
--- a/audio/ncmpcpp/pkg-descr
+++ b/audio/ncmpcpp/pkg-descr
@@ -2,4 +2,4 @@ Ncmpcpp is almost exact clone of ncmpc but it contains some
new features ncmpc doesn't have. It's been also rewritten
from scratch in C++.
-WWW: http://unkart.ovh.org/ncmpcpp/
+WWW: http://unkart.ovh.org/ncmpcpp
diff --git a/audio/ncmpcpp/pkg-message b/audio/ncmpcpp/pkg-message
index 9b4f61c2c713..a8a8fcd78b7e 100644
--- a/audio/ncmpcpp/pkg-message
+++ b/audio/ncmpcpp/pkg-message
@@ -1,14 +1,11 @@
###########################################################################
ncmpcpp has been installed.
-Attention: ncmpcpp doesn't use ~/.ncmpcpprc and ~/.ncmpcpp_keys as config
-files anymore. It's been using respectively ~/.ncmpcpp/config and
-~/.ncmpcpp/keys for this since ver. 0.2.4!
+Attention:
+ncmcpp no longer uses ~/.ncmpcpp/keys for configuration. It has been replaced
+by the incompatible ~/.ncmpcpp/bindings.
--------------------------------------------------------------------------
-Attention: Marker for right alignment in song format has changed from %r
-to $R since 0.4 version.
---------------------------------------------------------------------------
A default config has been installed to:
PREFIX/share/doc/ncmpcpp/config