aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-08 01:49:52 +0800
committerwill <will@FreeBSD.org>2001-01-08 01:49:52 +0800
commit17fc78c61a40e51c25675da0e3d99e222c1abdd3 (patch)
treea8b19a050dd6847de35f8b185751c1b52138d171 /audio
parent98a4931c0a8138d6f6fb6de52d4fd949a15ae520 (diff)
downloadfreebsd-ports-gnome-17fc78c61a40e51c25675da0e3d99e222c1abdd3.tar.gz
freebsd-ports-gnome-17fc78c61a40e51c25675da0e3d99e222c1abdd3.tar.zst
freebsd-ports-gnome-17fc78c61a40e51c25675da0e3d99e222c1abdd3.zip
Clean up inefficient perl invocations; use multiple REs in the same call.
Diffstat (limited to 'audio')
-rw-r--r--audio/holyshout/Makefile6
-rw-r--r--audio/snowstar/Makefile6
2 files changed, 4 insertions, 8 deletions
diff --git a/audio/holyshout/Makefile b/audio/holyshout/Makefile
index 4c98541e0ddf..bffcb72fbae0 100644
--- a/audio/holyshout/Makefile
+++ b/audio/holyshout/Makefile
@@ -15,9 +15,7 @@ MAINTAINER= hollywar@mail.holywar.net
USE_GMAKE= yes
post-patch:
- (cd ${WRKSRC} && find . -name Makefile | xargs ${PERL} -pi -e \
- "s@-O20@${CFLAGS}@g")
- (cd ${WRKSRC} && find . -name Makefile | xargs ${PERL} -pi -e \
- "s@-O2@${CFLAGS}@g")
+ (find ${WRKSRC} -name Makefile | xargs ${PERL} -pi -e \
+ "s@-O20@${CFLAGS}@g ; s@-O2@${CFLAGS}@g")
.include <bsd.port.mk>
diff --git a/audio/snowstar/Makefile b/audio/snowstar/Makefile
index 864dafdcd425..a4d998c6ea3a 100644
--- a/audio/snowstar/Makefile
+++ b/audio/snowstar/Makefile
@@ -21,11 +21,9 @@ NO_WRKSUBDIR= true
DOC_FILES= CHANGES TODO README_Snowstar LICENSE
# somehow snowstar.tcl managed to get loaded with ^M's.
-post-extract:
- @${PERL} -pi -e "s|\r\n|\n|g" ${WRKSRC}/snowstar.tcl
-
post-patch:
- @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/snowstar.tcl
+ @${PERL} -pi -e "s|\r\n|\n|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/snowstar.tcl
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/snowstar.tcl ${PREFIX}/bin/snowstar