aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-10-27 19:50:58 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-10-27 19:50:58 +0800
commit19fb9b432be999e8d61c7892e6e3a884bf85ff4f (patch)
tree74eba052c6d25d4a6a8756c5bd25cf19cfb1f218 /audio
parent7176acb592a62921bd872c40e3ba28cd1212d260 (diff)
downloadfreebsd-ports-gnome-19fb9b432be999e8d61c7892e6e3a884bf85ff4f.tar.gz
freebsd-ports-gnome-19fb9b432be999e8d61c7892e6e3a884bf85ff4f.tar.zst
freebsd-ports-gnome-19fb9b432be999e8d61c7892e6e3a884bf85ff4f.zip
Fix build with GCC-based architectures for various kde@ ports.
- Qt5 required c++11 support. Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> PR: 232726 PR: 232725 PR: 232723 PR: 232722 PR: 232721 PR: 232720 PR: 232719 PR: 232697 PR: 232682 PR: 232669 PR: 232668 PR: 232667 PR: 232666 PR: 232665 PR: 232664 PR: 232662 PR: 232661 PR: 232655 PR: 232654 PR: 232652 PR: 232648 PR: 232647 PR: 232641 PR: 232640 PR: 232638 PR: 232635 PR: 232634 PR: 232632 PR: 232631 PR: 232630 PR: 232629 PR: 232628 PR: 232627 PR: 232625 PR: 232624 PR: 232623 PR: 232614 PR: 232613 PR: 232612 PR: 232611 PR: 232610 PR: 232609 PR: 232607 PR: 232606 PR: 232605 PR: 232604 PR: 232603 PR: 232602 PR: 232597 PR: 232589 PR: 232585 PR: 232584 PR: 232583 PR: 232581 PR: 232580 PR: 232579 PR: 232578 PR: 232576 PR: 232575 PR: 232574 PR: 232573 PR: 232570
Diffstat (limited to 'audio')
-rw-r--r--audio/kmix/Makefile2
-rw-r--r--audio/libkcddb/Makefile2
-rw-r--r--audio/libkcompactdisc/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/audio/kmix/Makefile b/audio/kmix/Makefile
index c09c6f16189f..9187c0fc0a39 100644
--- a/audio/kmix/Makefile
+++ b/audio/kmix/Makefile
@@ -11,7 +11,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libasound.so:audio/alsa-lib
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons dbusaddons ecm \
emoticons globalaccel i18n iconthemes init itemmodels \
itemviews kcmutils kdelibs4support notifications package \
diff --git a/audio/libkcddb/Makefile b/audio/libkcddb/Makefile
index 3b1c35d9752e..a2fa860f81af 100644
--- a/audio/libkcddb/Makefile
+++ b/audio/libkcddb/Makefile
@@ -9,7 +9,7 @@ COMMENT= KDE CDDB library
LIB_DEPENDS= libmusicbrainz5.so:audio/libmusicbrainz5
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets \
coreaddons ecm i18n jobwidgets kio service \
widgetsaddons
diff --git a/audio/libkcompactdisc/Makefile b/audio/libkcompactdisc/Makefile
index f44444727abb..cfbda4d194d1 100644
--- a/audio/libkcompactdisc/Makefile
+++ b/audio/libkcompactdisc/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= audio kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE library for interfacing with audio CDs
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= coreaddons ecm emoticons i18n itemmodels itemviews \
kdelibs4support solid
USE_QT= core dbus phonon4\