aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-05-20 04:43:02 +0800
committerMax Brazhnikov <makc@FreeBSD.org>2010-05-20 04:43:02 +0800
commit1c621ed881c6db36ce3c078cf64a5fa6606f5d77 (patch)
tree12274395ab5af053480c16f584db3ca0c045b8ba /audio
parent6fb6e5384ca1057a2b89a7345bb484e3acbd265c (diff)
downloadfreebsd-ports-gnome-1c621ed881c6db36ce3c078cf64a5fa6606f5d77.tar.gz
freebsd-ports-gnome-1c621ed881c6db36ce3c078cf64a5fa6606f5d77.tar.zst
freebsd-ports-gnome-1c621ed881c6db36ce3c078cf64a5fa6606f5d77.zip
Add new port audio/tepsonic:
TepSonic is a simple and fast audio player but it has all the basic functions that every good audio player should have. TepSonic is not trying to be like Amarok or Banshee, it stays small and simple. WWW: http://www.tepsonic.org/ PR: ports/146700 Submitted by: Gvozdikov Veniamin <g.veniamin at googlemail.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/tepsonic/Makefile28
-rw-r--r--audio/tepsonic/distinfo3
-rw-r--r--audio/tepsonic/files/patch-player-collections-collectionbuilder.cpp15
-rw-r--r--audio/tepsonic/files/patch-player-player.cpp15
-rw-r--r--audio/tepsonic/files/patch-player-playlist-playlistmodel.cpp15
-rw-r--r--audio/tepsonic/pkg-descr5
-rw-r--r--audio/tepsonic/pkg-plist32
7 files changed, 113 insertions, 0 deletions
diff --git a/audio/tepsonic/Makefile b/audio/tepsonic/Makefile
new file mode 100644
index 000000000000..90b10f05ad78
--- /dev/null
+++ b/audio/tepsonic/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: tepsonic
+# Date created: 2010-05-18
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tepsonic
+PORTVERSION= 0.96.0
+CATEGORIES= audio
+MASTER_SITES= http://www.tepsonic.org/files/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= TepSonic is a simple and fast audio player
+
+LIB_DEPENDS= tag.1:${PORTSDIR}/audio/taglib
+
+USE_CMAKE= yes
+USE_QT_VER= 4
+USE_LDCONFIG= yes
+CMAKE_USE_PTHREAD= yes
+QT_COMPONENTS= gui xml sql phonon network linguist_build \
+ rcc_build qmake_build uic_build moc_build
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/audio/tepsonic/distinfo b/audio/tepsonic/distinfo
new file mode 100644
index 000000000000..bd0845149a16
--- /dev/null
+++ b/audio/tepsonic/distinfo
@@ -0,0 +1,3 @@
+MD5 (tepsonic-0.96.0-src.tar.gz) = fb1f7d1ea614e43f1e0a5a9d7fc49913
+SHA256 (tepsonic-0.96.0-src.tar.gz) = e613fa24ecd8212497a89d4c4ceffffd2f3206c0307d7cd591ec918f8ed2afee
+SIZE (tepsonic-0.96.0-src.tar.gz) = 674313
diff --git a/audio/tepsonic/files/patch-player-collections-collectionbuilder.cpp b/audio/tepsonic/files/patch-player-collections-collectionbuilder.cpp
new file mode 100644
index 000000000000..e28a9a4e26e9
--- /dev/null
+++ b/audio/tepsonic/files/patch-player-collections-collectionbuilder.cpp
@@ -0,0 +1,15 @@
+--- player/collections/collectionbuilder.cpp.orig 2010-05-18 02:04:47.000000000 +0800
++++ player/collections/collectionbuilder.cpp 2010-05-18 18:09:23.000000000 +0800
+@@ -22,9 +22,9 @@
+ #include "collectionmodel.h"
+ #include "databasemanager.h"
+
+-#include <taglib/fileref.h>
+-#include <taglib/tag.h>
+-#include <taglib/tstring.h>
++#include <fileref.h>
++#include <tag.h>
++#include <tstring.h>
+
+ #include <QDebug>
+
diff --git a/audio/tepsonic/files/patch-player-player.cpp b/audio/tepsonic/files/patch-player-player.cpp
new file mode 100644
index 000000000000..141d876f0fdd
--- /dev/null
+++ b/audio/tepsonic/files/patch-player-player.cpp
@@ -0,0 +1,15 @@
+--- player/player.cpp.orig 2010-05-18 02:04:47.000000000 +0800
++++ player/player.cpp 2010-05-18 18:07:34.000000000 +0800
+@@ -27,9 +27,9 @@
+ #include <phonon/AudioOutput>
+ #include <phonon/MediaSource>
+
+-#include <taglib/fileref.h>
+-#include <taglib/tag.h>
+-#include <taglib/tstring.h>
++#include <fileref.h>
++#include <tag.h>
++#include <tstring.h>
+
+ Player::Player()
+ {
diff --git a/audio/tepsonic/files/patch-player-playlist-playlistmodel.cpp b/audio/tepsonic/files/patch-player-playlist-playlistmodel.cpp
new file mode 100644
index 000000000000..7604e44fc556
--- /dev/null
+++ b/audio/tepsonic/files/patch-player-playlist-playlistmodel.cpp
@@ -0,0 +1,15 @@
+--- player/playlist/playlistmodel.cpp.orig 2010-05-18 02:04:47.000000000 +0800
++++ player/playlist/playlistmodel.cpp 2010-05-18 18:11:45.000000000 +0800
+@@ -21,9 +21,9 @@
+ #include <QtGui>
+ #include <QTime>
+
+-#include <taglib/fileref.h>
+-#include <taglib/tag.h>
+-#include <taglib/tstring.h>
++#include <fileref.h>
++#include <tag.h>
++#include <tstring.h>
+
+ #include "playlistmodel.h"
+ #include "playlistitem.h"
diff --git a/audio/tepsonic/pkg-descr b/audio/tepsonic/pkg-descr
new file mode 100644
index 000000000000..2d819f17f43f
--- /dev/null
+++ b/audio/tepsonic/pkg-descr
@@ -0,0 +1,5 @@
+TepSonic is a simple and fast audio player but it has all the basic functions
+that every good audio player should have. TepSonic is not trying to be
+like Amarok or Banshee, it stays small and simple.
+
+WWW: http://www.tepsonic.org/
diff --git a/audio/tepsonic/pkg-plist b/audio/tepsonic/pkg-plist
new file mode 100644
index 000000000000..fb4592d142b3
--- /dev/null
+++ b/audio/tepsonic/pkg-plist
@@ -0,0 +1,32 @@
+bin/tepsonic
+lib/libtepsonic_lastfmscrobbler.so
+lib/libtepsonic_lastfmscrobbler.so.0.1.0
+lib/libtepsonic_lastfmscrobbler.so.1
+share/applications/tepsonic.desktop
+share/icons/hicolor/128x128/apps/tepsonic.png
+share/icons/hicolor/16x16/apps/tepsonic.png
+share/icons/hicolor/256x256/apps/tepsonic.png
+share/icons/hicolor/32x32/apps/tepsonic.png
+share/icons/hicolor/48x48/apps/tepsonic.png
+share/icons/hicolor/64x64/apps/tepsonic.png
+share/tepsonic/locale/lastfmscrobbler/cs_CZ.qm
+share/tepsonic/locale/tepsonic/cs_CZ.qm
+@dirrm share/tepsonic/locale/tepsonic
+@dirrm share/tepsonic/locale/lastfmscrobbler
+@dirrm share/tepsonic/locale
+@dirrm share/tepsonic
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/256x256/apps
+@dirrmtry share/icons/hicolor/256x256
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications