aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2018-10-17 02:47:59 +0800
committerriggs <riggs@FreeBSD.org>2018-10-17 02:47:59 +0800
commit215e5e42272095638d5f980b0766a9794e593062 (patch)
tree65052b5ab56d46c8b8e5c185792612332eca2684 /audio
parent0b7f31c066a4acbd09731bac99ddf65ac7d25223 (diff)
downloadfreebsd-ports-gnome-215e5e42272095638d5f980b0766a9794e593062.tar.gz
freebsd-ports-gnome-215e5e42272095638d5f980b0766a9794e593062.tar.zst
freebsd-ports-gnome-215e5e42272095638d5f980b0766a9794e593062.zip
Fix SIGABRT in IsFileNotFound (e.g. when creating an empty database)
While on it: - Add USES=gnome due to complaint in check-sanity PR: 232030 Reported by: korsani@free.fr MFH: 2018Q4
Diffstat (limited to 'audio')
-rw-r--r--audio/musicpd/Makefile4
-rw-r--r--audio/musicpd/files/patch-src_input_Error.hxx10
2 files changed, 12 insertions, 2 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index bb347a794888..b468759ee566 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= musicpd
PORTVERSION= 0.20.21
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio ipv6
MASTER_SITES= http://www.musicpd.org/download/mpd/${PORTVERSION:R}/
DISTNAME= mpd-${PORTVERSION}
@@ -18,7 +18,7 @@ BROKEN_powerpc64= Does not build on powerpc64
LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs \
libicudata.so:devel/icu
-USES= compiler:c++14-lang gmake pkgconfig tar:xz
+USES= compiler:c++14-lang gmake gnome pkgconfig tar:xz
GNU_CONFIGURE= yes
USE_GNOME= glib20
diff --git a/audio/musicpd/files/patch-src_input_Error.hxx b/audio/musicpd/files/patch-src_input_Error.hxx
new file mode 100644
index 000000000000..ab5cc4ca41bd
--- /dev/null
+++ b/audio/musicpd/files/patch-src_input_Error.hxx
@@ -0,0 +1,10 @@
+--- src/input/Error.hxx.orig 2018-07-06 17:17:27 UTC
++++ src/input/Error.hxx
+@@ -30,7 +30,6 @@
+ * exist? This function attempts to recognize exceptions thrown by
+ * various input plugins.
+ */
+-gcc_pure
+ bool
+ IsFileNotFound(std::exception_ptr e);
+