aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2012-10-02 14:53:38 +0800
committermadpilot <madpilot@FreeBSD.org>2012-10-02 14:53:38 +0800
commit23c938fff29f21963192e6cd68d9cd220d962cd0 (patch)
tree47d3ea8153a38a31eb943570aea43eccaed3fe6b /audio
parent6b8b1795d62d24d67eb1b4ba883b5ccd678779c8 (diff)
downloadfreebsd-ports-gnome-23c938fff29f21963192e6cd68d9cd220d962cd0.tar.gz
freebsd-ports-gnome-23c938fff29f21963192e6cd68d9cd220d962cd0.tar.zst
freebsd-ports-gnome-23c938fff29f21963192e6cd68d9cd220d962cd0.zip
- Update to 5.18.02
- Remove ABI version numbers from LIB_DEPENDS - Add patch to avoid a rare segfault - While here, trim Makefile headers PR: ports/172109 Submitted by: Chris Petrik <c.petrik.sosa@gmail.com> (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/csound/Makefile29
-rw-r--r--audio/csound/distinfo8
-rw-r--r--audio/csound/files/patch-H__sysdep.h16
-rw-r--r--audio/csound/files/patch-frontends_fltk_gui_CsoundPerformanceSettingsPanel.cpp14
-rw-r--r--audio/csound/pkg-plist57
5 files changed, 96 insertions, 28 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index f22cb367854b..e44db75889c3 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -1,14 +1,10 @@
-# New ports collection makefile for: csound
-# Date created: 2000-10-11
-# Whom: trevor
-#
+# Created by: Trevor Johnson <trevor@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= csound
-PORTVERSION= 5.17.11
+PORTVERSION= 5.18.02
CATEGORIES= audio lang
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION} \
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}5.18/ \
SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R}/manual:manual
DISTNAME= ${PORTNAME:S/c/C/}${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -24,7 +20,7 @@ DIST_SUBDIR= csound
BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13 \
${LOCALBASE}/include/gmm/gmm.h:${PORTSDIR}/math/gmm++ \
${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
-LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
OPTIONS_DEFINE= ALSA DSSI FLUIDSYNTH JACK OSC PORTAUDIO PULSEAUDIO FLTK
OPTIONS_DEFAULT=FLTK
@@ -58,7 +54,7 @@ SUB_FILES= pkg-message
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
SCONS_ARGS+= useALSA=1
PLIST_SUB+= ALSA=""
ALSA_H= alsa/asoundlib.h
@@ -79,7 +75,7 @@ PLIST_SUB+= DSSI="@comment "
.endif
.if ${PORT_OPTIONS:MFLUIDSYNTH}
-LIB_DEPENDS+= fluidsynth.1:${PORTSDIR}/audio/fluidsynth
+LIB_DEPENDS+= fluidsynth:${PORTSDIR}/audio/fluidsynth
PLIST_SUB+= FLUIDSYNTH=""
FLUIDSYNTH_H= fluidsynth.h
.else
@@ -88,7 +84,7 @@ FLUIDSYNTH_H= ##fluidsynth.h##
.endif
.if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
SCONS_ARGS+= useJack=1
PLIST_SUB+= JACK=""
.else
@@ -97,7 +93,7 @@ PLIST_SUB+= JACK="@comment "
.endif
.if ${PORT_OPTIONS:MOSC}
-LIB_DEPENDS+= lo.7:${PORTSDIR}/audio/liblo
+LIB_DEPENDS+= lo:${PORTSDIR}/audio/liblo
SCONS_ARGS+= useOSC=1
PLIST_SUB+= OSC=""
.else
@@ -120,7 +116,7 @@ PORTAUDIO_R= # empty
.endif
.if ${PORT_OPTIONS:MPULSEAUDIO}
-LIB_DEPENDS+= pulse-simple.0:${PORTSDIR}/audio/pulseaudio
+LIB_DEPENDS+= pulse-simple:${PORTSDIR}/audio/pulseaudio
PLIST_SUB+= PULSEAUDIO=""
PULSEAUDIO_H= pulse/simple.h
.else
@@ -129,7 +125,7 @@ PULSEAUDIO_H= ##pulse/simple.h##
.endif
.if ${PORT_OPTIONS:MFLTK}
-LIB_DEPENDS+= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS+= fltk:${PORTSDIR}/x11-toolkits/fltk
PLIST_SUB+= FLTK=""
SCONS_ARGS+= buildCsound5GUI=1 buildCSEditor=1 buildWinsound=1 useFLTK=1
.else
@@ -191,12 +187,13 @@ post-patch:
${WRKSRC}/InOut/rtpa.c
@${REINPLACE_CMD} -e "s|linux/if.h|sys/types.h|" \
${WRKSRC}/OOps/remote.c
-
+ @${REINPLACE_CMD} '1658,1659d' \
+ ${WRKSRC}/SConstruct
post-install:
@${LN} -sf libcsound64.so.5 ${PREFIX}/lib/libcsound64.so
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- @${ECHO_MSG} " Installing the manual."
+ @${ECHO_MSG} " Installing manual ${PORTVERSION}. "
@(cd ${WRKDIR}/html && ${COPYTREE_SHARE} . ${DOCSDIR})
@${ECHO_MSG} " Done."
.endif
diff --git a/audio/csound/distinfo b/audio/csound/distinfo
index dbca3a54162e..c19103c4b1c3 100644
--- a/audio/csound/distinfo
+++ b/audio/csound/distinfo
@@ -1,4 +1,4 @@
-SHA256 (csound/Csound5.17.11.tar.gz) = a86595c4328b63e9b37205b40bf1441182a453451b0ea20558a7777dbc0380b7
-SIZE (csound/Csound5.17.11.tar.gz) = 9152189
-SHA256 (csound/Csound5.17_manual_html.zip) = cad3ee307c801c972d9d5f626a79c88dddda6872d8a4af64dd4f3edfe7c0f626
-SIZE (csound/Csound5.17_manual_html.zip) = 9621312
+SHA256 (csound/Csound5.18.02.tar.gz) = 4c461cf3bf60b83671224949dd33805379b7121bf2c0ad6af5e191e7f6f8adc8
+SIZE (csound/Csound5.18.02.tar.gz) = 9211491
+SHA256 (csound/Csound5.18_manual_html.zip) = a7347bb1a6b5af3497de95a2df36217a6a42219e2f36a3d6d505cd53b2719cd4
+SIZE (csound/Csound5.18_manual_html.zip) = 9773269
diff --git a/audio/csound/files/patch-H__sysdep.h b/audio/csound/files/patch-H__sysdep.h
index 2e1b26a6162c..2f88fa13b509 100644
--- a/audio/csound/files/patch-H__sysdep.h
+++ b/audio/csound/files/patch-H__sysdep.h
@@ -1,26 +1,26 @@
---- H/sysdep.h.orig 2012-05-29 02:41:30.000000000 +0900
-+++ H/sysdep.h 2012-05-31 11:19:28.000000000 +0900
-@@ -96,7 +96,11 @@
+--- H/sysdep.h.bak 2012-09-27 02:58:13.000000000 +0000
++++ H/sysdep.h 2012-09-27 03:02:06.000000000 +0000
+@@ -100,6 +100,11 @@
#define EXP exp
#define LOG log
#define LOG10 log10
+#if __FreeBSD_version <= 704100 || (__FreeBSD_version >= 800000 && __FreeBSD_version < 802502) || (__FreeBSD_version >= 900000 && __FreeBSD_version < 900027)
+ #define LOG2(x) (log(x) / log(2))
+#else
- #define LOG2 log2
++ #define LOG2 log2
+#endif
+ /* #define LOG2 log2 */
#define POWER pow
#define SQRT sqrt
- #define HYPOT hypot
-@@ -122,7 +126,11 @@
+@@ -126,6 +131,11 @@
#define EXP expf
#define LOG logf
#define LOG10 log10f
+#if __FreeBSD_version <= 704100 || (__FreeBSD_version >= 800000 && __FreeBSD_version < 802502) || (__FreeBSD_version >= 900000 && __FreeBSD_version < 900027)
+ #define LOG2(x) (logf(x) / logf(2))
+#else
- #define LOG2 log2f
++ #define LOG2 log2f
+#endif
+ /* #define LOG2 log2f */
#define POWER powf
#define SQRT sqrtf
- #define HYPOT hypotf
diff --git a/audio/csound/files/patch-frontends_fltk_gui_CsoundPerformanceSettingsPanel.cpp b/audio/csound/files/patch-frontends_fltk_gui_CsoundPerformanceSettingsPanel.cpp
new file mode 100644
index 000000000000..fea6dd48a2f4
--- /dev/null
+++ b/audio/csound/files/patch-frontends_fltk_gui_CsoundPerformanceSettingsPanel.cpp
@@ -0,0 +1,14 @@
+--- frontends/fltk_gui/CsoundPerformanceSettingsPanel.cpp.orig 2012-08-31 15:40:35.000000000 +0200
++++ frontends/fltk_gui/CsoundPerformanceSettingsPanel.cpp 2012-10-01 23:21:42.734591150 +0200
+@@ -4,9 +4,11 @@
+ #endif
+
+ //CS5GUI_EXPERIMENTAL device query section left out for Windows and Mac while the problem is found
++#ifndef __FreeBSD__
+ #ifdef LINUX
+ #define CS5GUI_EXPERIMENTAL
+ #endif
++#endif
+
+
+ #include "csound.hpp"
diff --git a/audio/csound/pkg-plist b/audio/csound/pkg-plist
index d587d2067df7..acb2a247ceb8 100644
--- a/audio/csound/pkg-plist
+++ b/audio/csound/pkg-plist
@@ -48,6 +48,8 @@ include/csound/soundio.h
include/csound/sysdep.h
include/csound/text.h
include/csound/version.h
+include/csound/interlocks.h
+lib/csound/plugins64/libplaterev.so
lib/csound/plugins64/libampmidid.so
lib/csound/plugins64/libcellular.so
lib/csound/plugins64/libcontrol.so
@@ -2799,6 +2801,61 @@ lib/libcsound64.so.5
%%PORTDOCS%%%%DOCSDIR%%/zkr.html
%%PORTDOCS%%%%DOCSDIR%%/zkw.html
%%PORTDOCS%%%%DOCSDIR%%/zkwm.html
+%%PORTDOCS%%%%DOCSDIR%%/platerev.html
+%%PORTDOCS%%%%DOCSDIR%%/cosseg.html
+%%PORTDOCS%%%%DOCSDIR%%/images/gen18_2.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gentanh_3.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen14_3.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gentanh_1.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen14_4.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen14_2.png
+%%PORTDOCS%%%%DOCSDIR%%/images/genexp_2.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen18_1.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen18_3.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gentanh_2.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen14_1.png
+%%PORTDOCS%%%%DOCSDIR%%/images/gen23.png
+%%PORTDOCS%%%%DOCSDIR%%/images/genexp_1.png
+%%PORTDOCS%%%%DOCSDIR%%/log2.html
+%%PORTDOCS%%%%DOCSDIR%%/vbapg.html
+%%PORTDOCS%%%%DOCSDIR%%/examples/logicOR.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/Mixer.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/genwave.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/cossegb.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/cossegr.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/spectrum.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/plate.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/log2.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/readf.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/readfi.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/pwd.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/maxaccum.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/midipolyaftertouch.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/sym10.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/gen18.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/vbapg.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/cosseg.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/joystick.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/joystick-2.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/midiprogramchange.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/vbap.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/minabsaccum.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/minaccum.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/vbapmove.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/maxabsaccum.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/gen23.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/mididefault.csd
+%%PORTDOCS%%%%DOCSDIR%%/examples/centroid.csd
+%%PORTDOCS%%%%DOCSDIR%%/vbapmove.html
+%%PORTDOCS%%%%DOCSDIR%%/pwd.html
+%%PORTDOCS%%%%DOCSDIR%%/vbap.html
+%%PORTDOCS%%%%DOCSDIR%%/GENwave.html
+%%PORTDOCS%%%%DOCSDIR%%/joystick.html
+%%PORTDOCS%%%%DOCSDIR%%/readf.html
+%%PORTDOCS%%%%DOCSDIR%%/cossegr.html
+%%PORTDOCS%%%%DOCSDIR%%/centroid.html
+%%PORTDOCS%%%%DOCSDIR%%/cossegb.html
+%%PORTDOCS%%%%DOCSDIR%%/readfi.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images/callouts
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples