aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoremaste <emaste@FreeBSD.org>2018-09-26 21:33:22 +0800
committeremaste <emaste@FreeBSD.org>2018-09-26 21:33:22 +0800
commit23ca3fe570ca6e5c8606095122eda423a3b7c9f8 (patch)
tree62c17b5dbe34180aebe196f948c92a132ec193a2 /audio
parent8d6bdf481a7d238cbef0248710f4b37a504e11c2 (diff)
downloadfreebsd-ports-gnome-23ca3fe570ca6e5c8606095122eda423a3b7c9f8.tar.gz
freebsd-ports-gnome-23ca3fe570ca6e5c8606095122eda423a3b7c9f8.tar.zst
freebsd-ports-gnome-23ca3fe570ca6e5c8606095122eda423a3b7c9f8.zip
audio/xmms-sapplug: add -fPIC to linking with lld on i386 and arm64
By default lld disallows relocations against read-only segments and requires that shared objects are built with -fPIC (as they should be). This port already set -fPIC for amd64, so apply it to arm64 (which already uses lld as the system linker) and i386 (which will soon switch to lld as the system linker). Approved by: portmgr (lld blanket)
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-sapplug/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
index 9b814ed21d09..dbfd62353e99 100644
--- a/audio/xmms-sapplug/Makefile
+++ b/audio/xmms-sapplug/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmms-sapplug
DISTVERSION= 0.3f
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= LOCAL/ehaupt
DISTNAME= sapplug-xmms-${DISTVERSION}
@@ -13,8 +13,6 @@ COMMENT= XMMS input plugin for playing 8bit Atari(TM) .sap audio files
LICENSE= GPLv2
-BROKEN_aarch64= fails to link: can't create dynamic relocation R_AARCH64_ADR_PREL_PG_HI21 against symbol: gtk_widget_destroyed in readonly segment
-
BUILD_DEPENDS= xmms:multimedia/xmms
RUN_DEPENDS= xmms:multimedia/xmms
@@ -29,7 +27,9 @@ PLIST_FILES= lib/xmms/Input/libsap.so
OPTIONS_DEFINE= OPTIMIZED_CFLAGS
+CFLAGS_aarch64= -fpic -DPIC
CFLAGS_amd64= -fpic -DPIC
+CFLAGS_i386= -fpic -DPIC
.include <bsd.port.pre.mk>