aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2016-05-12 04:15:00 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2016-05-12 04:15:00 +0800
commit2cddef305baabafd588e9371a52eb1263abe65db (patch)
tree842f1a38ca9e0de1f5815705831c329b04c2de57 /audio
parent65137dad67d4c3f80046c4ccdefc2932a2bd94f2 (diff)
downloadfreebsd-ports-gnome-2cddef305baabafd588e9371a52eb1263abe65db.tar.gz
freebsd-ports-gnome-2cddef305baabafd588e9371a52eb1263abe65db.tar.zst
freebsd-ports-gnome-2cddef305baabafd588e9371a52eb1263abe65db.zip
Add new port audio/forked-daapd, a DAAP (iTunes), MPD (Music
Player Daemon) and RSP (Roku) media server. PR: 199743 Submitted by: takumiiinn@gmail.com, with extra work by pi Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D6326
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/forked-daapd/Makefile67
-rw-r--r--audio/forked-daapd/distinfo2
-rw-r--r--audio/forked-daapd/files/forked-daapd.in35
-rw-r--r--audio/forked-daapd/files/pkg-message.in21
-rw-r--r--audio/forked-daapd/pkg-descr15
-rw-r--r--audio/forked-daapd/pkg-plist6
7 files changed, 147 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 3ee03b5482e6..578c0c4a9041 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -167,6 +167,7 @@
SUBDIR += fluidsynth
SUBDIR += fluidsynth-dssi
SUBDIR += fmit
+ SUBDIR += forked-daapd
SUBDIR += fpc-a52
SUBDIR += fpc-mad
SUBDIR += fpc-modplug
diff --git a/audio/forked-daapd/Makefile b/audio/forked-daapd/Makefile
new file mode 100644
index 000000000000..4653cc02bb4d
--- /dev/null
+++ b/audio/forked-daapd/Makefile
@@ -0,0 +1,67 @@
+# Created by: Takumi Takahashi <takumiiinn@gmail.com>
+# $FreeBSD$
+
+PORTNAME= forked-daapd
+PORTVERSION= 24.1
+CATEGORIES= audio
+
+MAINTAINER= takumiiinn@gmail.com
+COMMENT= DAAP (iTunes), MPD (Music Player Daemon) and RSP (Roku) media server
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= antlr3:devel/antlr3
+LIB_DEPENDS= libantlr3c.so:devel/libantlr3c \
+ libavahi-client.so:net/avahi-app \
+ libavcodec.so:multimedia/ffmpeg \
+ libconfuse.so:devel/libconfuse \
+ libevent.so:devel/libevent2 \
+ libgcrypt.so:security/libgcrypt \
+ libinotify.so:devel/libinotify \
+ libmxml.so:textproc/mxml \
+ libunistring.so:devel/libunistring
+
+USE_GITHUB= yes
+GH_ACCOUNT= ejurgensen
+
+USES= autoreconf gettext gmake gperf iconv libtool localbase pathfix pkgconfig sqlite
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= ${LOCALBASE}/lib/forked-daapd
+CONFIGURE_ARGS+=--localstatedir=/var
+
+USE_RC_SUBR= ${PORTNAME}
+RC_NAME= forked_daapd
+SUB_LIST= PORTNAME=${PORTNAME} RC_NAME=${RC_NAME}
+SUB_FILES= pkg-message
+
+USERS= daapd
+GROUPS= daapd
+
+OPTIONS_DEFINE= ALSA ITUNES LASTFM MPD
+OPTIONS_DEFAULT=ITUNES LASTFM MPD
+
+ITUNES_DESC= iTunes XML support
+MPD_DESC= Music Player Daemon protocol support
+
+ALSA_CONFIGURE_WITH= alsa
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
+ITUNES_CONFIGURE_ENABLE=itunes
+ITUNES_LIB_DEPENDS= libplist.so:devel/libplist
+LASTFM_CONFIGURE_ENABLE=lastfm
+LASTFM_LIB_DEPENDS= libcurl.so:ftp/curl
+MPD_CONFIGURE_ENABLE= mpd
+
+.include <bsd.port.pre.mk>
+
+# Ensure FreeBSD 9 can find zlib library
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000712
+CONFIGURE_ENV+= ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-lz"
+.endif
+
+post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/etc/forked-daapd.conf ${STAGEDIR}${PREFIX}/etc/forked-daapd.conf.sample
+
+.include <bsd.port.post.mk>
diff --git a/audio/forked-daapd/distinfo b/audio/forked-daapd/distinfo
new file mode 100644
index 000000000000..f5fcef3c14df
--- /dev/null
+++ b/audio/forked-daapd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ejurgensen-forked-daapd-24.1_GH0.tar.gz) = 2d0353b318c10dc53928b40010ffeaca1264c8219dff15d715953ded2c3ba73d
+SIZE (ejurgensen-forked-daapd-24.1_GH0.tar.gz) = 344140
diff --git a/audio/forked-daapd/files/forked-daapd.in b/audio/forked-daapd/files/forked-daapd.in
new file mode 100644
index 000000000000..3aec20f281d8
--- /dev/null
+++ b/audio/forked-daapd/files/forked-daapd.in
@@ -0,0 +1,35 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: %%PORTNAME%%
+# REQUIRE: avahi_daemon dbus
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# %%RC_NAME%%_enable (bool): Set to NO by default.
+# Set it to YES to enable %%PORTNAME%%.
+# %%RC_NAME%%_config (path): Set to %%PREFIX%%/etc/forked-daapd.conf
+# by default.
+# %%RC_NAME%%_flags (str): Set to "" by default
+
+. /etc/rc.subr
+
+name=%%RC_NAME%%
+rcvar=${name}_enable
+
+load_rc_config $name
+
+: ${%%RC_NAME%%_enable:="NO"}
+: ${%%RC_NAME%%_config:="%%PREFIX%%/etc/forked-daapd.conf"}
+: ${%%RC_NAME%%_flags:=""}
+
+pidfile="/var/run/%%PORTNAME%%.pid"
+required_files="$%%RC_NAME%%_config"
+
+command="%%PREFIX%%/sbin/%%PORTNAME%%"
+command_args="-P $pidfile -c $%%RC_NAME%%_config $%%RC_NAME%%_flags"
+
+run_rc_command "$1"
diff --git a/audio/forked-daapd/files/pkg-message.in b/audio/forked-daapd/files/pkg-message.in
new file mode 100644
index 000000000000..3c39cdb1aee9
--- /dev/null
+++ b/audio/forked-daapd/files/pkg-message.in
@@ -0,0 +1,21 @@
+%%PORTNAME%% uses FFmpeg for transcoding audio playback.
+The default ports/pkg build of FFmpeg on FreeBSD has a number
+of options which could be SET/UNSET to provide support for
+additional audio codecs.
+
+If you find %%PORTNAME%% does not support the audio codecs you
+require, it is recommended to recompile the multimedia/ffmpeg
+package from ports with the necessary options ENABLED (SET).
+
+You should review and edit the %%PORTNAME%% configuration
+file %%PREFIX%%/etc/%%PORTNAME%%.conf before first use.
+
+To automatically start %%PORTNAME%% at boot time:
+# sysrc 'dbus_enable=YES'
+# sysrc 'avahi_daemon_enable=YES'
+# sysrc '%%RC_NAME%%_enable=YES'
+
+To then manually start %%PORTNAME%% without rebooting:
+# service dbus start
+# service avahi-daemon start
+# service %%PORTNAME%% start
diff --git a/audio/forked-daapd/pkg-descr b/audio/forked-daapd/pkg-descr
new file mode 100644
index 000000000000..39f49bda5e5c
--- /dev/null
+++ b/audio/forked-daapd/pkg-descr
@@ -0,0 +1,15 @@
+forked-daapd is a DAAP (iTunes), MPD (Music Player Daemon) and RSP (Roku) media
+server. It is a complete rewrite of mt-daapd (Firefly Media Server).
+
+It has support for AirPlay devices/speakers, Apple Remote (and compatibles),
+MPD clients, Chromecast, network streaming, internet radio, Spotify and LastFM.
+
+It does not support streaming video by AirPlay nor Chromecast.
+
+DAAP stands for Digital Audio Access Protocol, and is the protocol used
+by iTunes and friends to share/stream media libraries over the network.
+
+RSP is Roku's own media sharing protocol. Roku are the makers of the
+SoundBridge devices.
+
+WWW: http://ejurgensen.github.io/forked-daapd/
diff --git a/audio/forked-daapd/pkg-plist b/audio/forked-daapd/pkg-plist
new file mode 100644
index 000000000000..1b1ce98a8376
--- /dev/null
+++ b/audio/forked-daapd/pkg-plist
@@ -0,0 +1,6 @@
+@sample etc/forked-daapd.conf.sample
+lib/forked-daapd/forked-daapd-sqlext.so
+man/man8/forked-daapd.8.gz
+sbin/forked-daapd
+@dir(daapd,daapd,700) /var/cache/forked-daapd/libspotify
+@dir(daapd,daapd,700) /var/cache/forked-daapd