aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-07-22 03:50:22 +0800
committersat <sat@FreeBSD.org>2006-07-22 03:50:22 +0800
commit2d6e2951a4ba2ab84360b542f16087de419aaa25 (patch)
treedd2293317a2e26a2bb49ea179b33ebdd06aef9a8 /audio
parente0f1ba5566e3235c888064b439f5847ce60fba07 (diff)
downloadfreebsd-ports-gnome-2d6e2951a4ba2ab84360b542f16087de419aaa25.tar.gz
freebsd-ports-gnome-2d6e2951a4ba2ab84360b542f16087de419aaa25.tar.zst
freebsd-ports-gnome-2d6e2951a4ba2ab84360b542f16087de419aaa25.zip
Add port audio/p5-Audio-FLAC-Header:
This module returns a hash containing basic information about a FLAC file, a representation of the embedded cue sheet if one exists, as well as tag information contained in the FLAC file's Vorbis tags. There is no complete list of tag keys for Vorbis tags, as they can be defined by the user; the basic set of tags used for FLAC files include: * ALBUM * ARTIST * TITLE * DATE * GENRE * TRACKNUMBER * COMMENT WWW: http://search.cpan.org/dist/Audio-FLAC-Header/
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/p5-Audio-FLAC-Header/Makefile25
-rw-r--r--audio/p5-Audio-FLAC-Header/distinfo3
-rw-r--r--audio/p5-Audio-FLAC-Header/pkg-descr15
-rw-r--r--audio/p5-Audio-FLAC-Header/pkg-plist9
5 files changed, 53 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index dcca0d728bdb..dc9fd53e6b6f 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -403,6 +403,7 @@
SUBDIR += p5-Audio
SUBDIR += p5-Audio-Beep
SUBDIR += p5-Audio-CD
+ SUBDIR += p5-Audio-FLAC-Header
SUBDIR += p5-Audio-Scrobbler
SUBDIR += p5-Audio-TagLib
SUBDIR += p5-Audio-WMA
diff --git a/audio/p5-Audio-FLAC-Header/Makefile b/audio/p5-Audio-FLAC-Header/Makefile
new file mode 100644
index 000000000000..fb96f5e4a53f
--- /dev/null
+++ b/audio/p5-Audio-FLAC-Header/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Audio-FLAC-Header
+# Date created: 21 July 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Audio-FLAC-Header
+PORTVERSION= 1.4
+CATEGORIES= audio perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Audio
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Interface to FLAC header metadata
+
+LIB_DEPENDS= FLAC.7:${PORTSDIR}/audio/flac
+
+PERL_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+
+MAN3= Audio::FLAC::Header.3
+
+.include <bsd.port.mk>
diff --git a/audio/p5-Audio-FLAC-Header/distinfo b/audio/p5-Audio-FLAC-Header/distinfo
new file mode 100644
index 000000000000..ce815ac55425
--- /dev/null
+++ b/audio/p5-Audio-FLAC-Header/distinfo
@@ -0,0 +1,3 @@
+MD5 (Audio-FLAC-Header-1.4.tar.gz) = 55f896f35555840b225c24836a663f70
+SHA256 (Audio-FLAC-Header-1.4.tar.gz) = 4abbe531b67342c7ba239e2a4f377cf515bcb68574801962476cb6ad57a54a91
+SIZE (Audio-FLAC-Header-1.4.tar.gz) = 57318
diff --git a/audio/p5-Audio-FLAC-Header/pkg-descr b/audio/p5-Audio-FLAC-Header/pkg-descr
new file mode 100644
index 000000000000..7e5aea66251a
--- /dev/null
+++ b/audio/p5-Audio-FLAC-Header/pkg-descr
@@ -0,0 +1,15 @@
+This module returns a hash containing basic information about a FLAC file,
+a representation of the embedded cue sheet if one exists, as well as tag
+information contained in the FLAC file's Vorbis tags. There is no complete
+list of tag keys for Vorbis tags, as they can be defined by the user; the
+basic set of tags used for FLAC files include:
+
+* ALBUM
+* ARTIST
+* TITLE
+* DATE
+* GENRE
+* TRACKNUMBER
+* COMMENT
+
+WWW: http://search.cpan.org/dist/Audio-FLAC-Header/
diff --git a/audio/p5-Audio-FLAC-Header/pkg-plist b/audio/p5-Audio-FLAC-Header/pkg-plist
new file mode 100644
index 000000000000..5aa7efa9d593
--- /dev/null
+++ b/audio/p5-Audio-FLAC-Header/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Audio/FLAC/Header.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/FLAC/Header/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/FLAC/Header/Header.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/FLAC/Header/Header.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Audio/FLAC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Audio
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/FLAC/Header
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/FLAC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio