aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-04-24 16:11:33 +0800
committerpav <pav@FreeBSD.org>2008-04-24 16:11:33 +0800
commit2f4376e2f61a8f05d0166aef054d22851bbcd419 (patch)
tree5b9b9504d7abdee8b48c75fc76b14b3327fb715a /audio
parentad4732ab7cce03e4317d54d7bb8b4c7e551aa388 (diff)
downloadfreebsd-ports-gnome-2f4376e2f61a8f05d0166aef054d22851bbcd419.tar.gz
freebsd-ports-gnome-2f4376e2f61a8f05d0166aef054d22851bbcd419.tar.zst
freebsd-ports-gnome-2f4376e2f61a8f05d0166aef054d22851bbcd419.zip
MusicTracker is a plugin for Pidgin which displays the music track currently
playing in the status message of various accounts such as AIM, Yahoo, MSN, Gtalk (Jabber), etc., i.e. any protocol Pidgin supports custom statuses on. Support for a wide range of audio players on both Windows and UNIX platforms is planned. Currently supported players: Amarok, Rhythmbox, Audacious, XMMS, MPC/MPD, Exaile, Banshee and Quod Libet. WWW: http://code.google.com/p/musictracker/
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/pidgin-musictracker/Makefile26
-rw-r--r--audio/pidgin-musictracker/distinfo3
-rw-r--r--audio/pidgin-musictracker/pkg-descr8
-rw-r--r--audio/pidgin-musictracker/pkg-plist3
5 files changed, 41 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 181b2ef32c36..b08350360fbc 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -504,6 +504,7 @@
SUBDIR += penguinsap
SUBDIR += phatbeat
SUBDIR += picard
+ SUBDIR += pidgin-musictracker
SUBDIR += pimp3
SUBDIR += play
SUBDIR += playgsf
diff --git a/audio/pidgin-musictracker/Makefile b/audio/pidgin-musictracker/Makefile
new file mode 100644
index 000000000000..8c7fd82c6174
--- /dev/null
+++ b/audio/pidgin-musictracker/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gaim-guifications
+# Date created: 2004-05-04
+# Whom: ports@c0decafe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= musictracker
+PORTVERSION= 0.4.1
+CATEGORIES= audio
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= pidgin-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Plugin for Pidgin to displays the music track currently playing
+
+BUILD_DEPENDS= ${LOCALBASE}/include/pidgin/pidgin.h:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= "CPPFLAGS=-I${LOCALBASE}/include" "LIBS=-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/audio/pidgin-musictracker/distinfo b/audio/pidgin-musictracker/distinfo
new file mode 100644
index 000000000000..05e423d3d419
--- /dev/null
+++ b/audio/pidgin-musictracker/distinfo
@@ -0,0 +1,3 @@
+MD5 (musictracker-0.4.1.tar.bz2) = a424bc8355507e0c718deb367962f431
+SHA256 (musictracker-0.4.1.tar.bz2) = c2a38f73675c873a7f3ee9da823f85a84718f66daa54c2cd7d673f14b7d6d190
+SIZE (musictracker-0.4.1.tar.bz2) = 427110
diff --git a/audio/pidgin-musictracker/pkg-descr b/audio/pidgin-musictracker/pkg-descr
new file mode 100644
index 000000000000..49ce4b7f53c0
--- /dev/null
+++ b/audio/pidgin-musictracker/pkg-descr
@@ -0,0 +1,8 @@
+MusicTracker is a plugin for Pidgin which displays the music track currently
+playing in the status message of various accounts such as AIM, Yahoo, MSN,
+Gtalk (Jabber), etc., i.e. any protocol Pidgin supports custom statuses on.
+Support for a wide range of audio players on both Windows and UNIX platforms
+is planned. Currently supported players: Amarok, Rhythmbox, Audacious, XMMS,
+MPC/MPD, Exaile, Banshee and Quod Libet.
+
+WWW: http://code.google.com/p/musictracker/
diff --git a/audio/pidgin-musictracker/pkg-plist b/audio/pidgin-musictracker/pkg-plist
new file mode 100644
index 000000000000..1bc82226bb9a
--- /dev/null
+++ b/audio/pidgin-musictracker/pkg-plist
@@ -0,0 +1,3 @@
+lib/pidgin/musictracker.a
+lib/pidgin/musictracker.la
+lib/pidgin/musictracker.so