aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-05-08 13:35:37 +0800
committerahze <ahze@FreeBSD.org>2005-05-08 13:35:37 +0800
commit2f9c8b37aa7e3d6f31c4ba3be975cdbaf286c344 (patch)
tree0feaa6eeeae218bff7f0772628e12f3a1f3f8765 /audio
parent76656ea0b1883cb2fde05718cd8fb9447388216d (diff)
downloadfreebsd-ports-gnome-2f9c8b37aa7e3d6f31c4ba3be975cdbaf286c344.tar.gz
freebsd-ports-gnome-2f9c8b37aa7e3d6f31c4ba3be975cdbaf286c344.tar.zst
freebsd-ports-gnome-2f9c8b37aa7e3d6f31c4ba3be975cdbaf286c344.zip
- Add SSE support that is auto-detected from MACHINE_CPU:Msse
Diffstat (limited to 'audio')
-rw-r--r--audio/speex-devel/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/speex-devel/Makefile b/audio/speex-devel/Makefile
index 45fab4958d2a..925cd860f7f5 100644
--- a/audio/speex-devel/Makefile
+++ b/audio/speex-devel/Makefile
@@ -34,6 +34,12 @@ MAN1= speexdec.1 speexenc.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_CPU:Msse}!=""
+CONFIGURE_ARGS+= --enable-sse
+.endif
+
patch-autotools:
@(cd ${PATCH_WRKSRC}; \
for file in ${LIBTOOLFILES}; do \
@@ -50,4 +56,4 @@ post-patch:
@${REINPLACE_CMD} -e 's| in -lgnugetopt||g ; \
s|LIBS="-lgnugetopt|LIBS="|g' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>