aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2020-01-03 19:24:46 +0800
committerjbeich <jbeich@FreeBSD.org>2020-01-03 19:24:46 +0800
commit348bb66cc6746fe0cea0e98e979b9746e2c6257e (patch)
tree0bb1ac7a80cf44560970e1355dece9a3c807bc7b /audio
parenta6c563894e534f830d61d179c101e5d5b60b2ab9 (diff)
downloadfreebsd-ports-gnome-348bb66cc6746fe0cea0e98e979b9746e2c6257e.tar.gz
freebsd-ports-gnome-348bb66cc6746fe0cea0e98e979b9746e2c6257e.tar.zst
freebsd-ports-gnome-348bb66cc6746fe0cea0e98e979b9746e2c6257e.zip
audio/tagutil: mark BROKEN on FreeBSD 11 after r520736
FAILED: tagutil : && /usr/bin/cc -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -O0 -g -fsanitize=undefined -fstack-protector-strong -pie CMakeFiles/tagutil.dir/tagutil.c.o CMakeFiles/tagutil.dir/t_action.c.o CMakeFiles/tagutil.dir/t_renamer.c.o CMakeFiles/tagutil.dir/t_editor.c.o CMakeFiles/tagutil.dir/t_loader.c.o CMakeFiles/tagutil.dir/t_tune.c.o CMakeFiles/tagutil.dir/t_taglist.c.o CMakeFiles/tagutil.dir/t_tag.c.o CMakeFiles/tagutil.dir/t_backend.c.o CMakeFiles/tagutil.dir/t_format.c.o CMakeFiles/tagutil.dir/t_toolkit.c.o CMakeFiles/tagutil.dir/t_fttaglib.c.o CMakeFiles/tagutil.dir/t_ftflac.c.o CMakeFiles/tagutil.dir/t_ftoggvorbis.c.o CMakeFiles/tagutil.dir/t_yaml.c.o -o tagutil -lc -lsbuf -L/usr/local/lib -ltag_c -ltag -L/usr/local/lib -lFLAC -L/usr/local/lib -logg -L/usr/local/lib -lvorbis -L/usr/local/lib -lvorbisfile -L/usr/local/lib -lyaml && : /usr/bin/ld: undefined reference to symbol `__cxa_demangle@@CXXABI_1.3' (try adding -lcxxrt) //lib/libcxxrt.so.1: could not read symbols: Bad value cc: error: linker command failed with exit code 1 (use -v to see invocation) ninja: build stopped: subcommand failed. *** Error code 1 Reported by: pkg-fallout
Diffstat (limited to 'audio')
-rw-r--r--audio/tagutil/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/tagutil/Makefile b/audio/tagutil/Makefile
index 27012a585133..7bb153987796 100644
--- a/audio/tagutil/Makefile
+++ b/audio/tagutil/Makefile
@@ -10,6 +10,10 @@ COMMENT= Command line interface tool to manage tags in music files
LICENSE= BSD2CLAUSE
+.if exists(/usr/lib/libc++.so) && ${/usr/bin/ld:L:tA} != /usr/bin/ld.lld
+BROKEN= ld: undefined reference to symbol '__cxa_demangle@@CXXABI_1.3' (try adding -lcxxrt)
+.endif
+
LIB_DEPENDS= libyaml.so:textproc/libyaml
USE_GITHUB= yes