aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-17 18:00:34 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-17 18:00:34 +0800
commit36d16aa51514605001edf5e039a82a320b833b03 (patch)
tree643cbefc18379a7ec72b08e1fcfd5f1f44c73361 /audio
parente0ccdf0340ec32af6d1c39e7bd482dee19f1aea2 (diff)
downloadfreebsd-ports-gnome-36d16aa51514605001edf5e039a82a320b833b03.tar.gz
freebsd-ports-gnome-36d16aa51514605001edf5e039a82a320b833b03.tar.zst
freebsd-ports-gnome-36d16aa51514605001edf5e039a82a320b833b03.zip
dekagen is a front-end to several tools for the ripping, converting, and
naming of MP3 and Ogg-Vorbis files. It automates the whole process of ripping data from music compact discs (CD), the naming of the files, their converting into MP3 or Ogg-Vorbis format and the labelling of the MP3 files with an ID3 tag. dekagen uses dialog for a user interface that is intended to be "intuitive". Music data is read from CDs using cdda2wav, cdparanoia, dagrab, or tosha, and stored on your harddisk in wav-format. Note that this will have an excessive need of disk space. After this, the wav-data is converted into MP3 format using 8hz-mp3, bladeenc, l3enc, lame, mp3enc, or notlame, or into Ogg-Vorbis format using oggenc. This will take a while. To avoid manual naming and tagging for all the files, cda is used for CDDB lookups. To label the MP3 files with ID3 tags, id3ed, id3tag, id3tool, or mp3info, or the built-in capabilities of some encoders (lame, notlame) are used. Ogg-Vorbis files can be labelled with oggenc. WWW: http://userpage.fu-berlin.de/~mbayer/tools/dekagen.html
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/dekagen/Makefile43
-rw-r--r--audio/dekagen/distinfo1
-rw-r--r--audio/dekagen/files/patch-dekagen12
-rw-r--r--audio/dekagen/pkg-descr21
-rw-r--r--audio/dekagen/pkg-plist1
6 files changed, 79 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 09484796f562..29a09e15d42c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -50,6 +50,7 @@
SUBDIR += dagrab
SUBDIR += dap
SUBDIR += darkice
+ SUBDIR += dekagen
SUBDIR += denemo
SUBDIR += discid
SUBDIR += easytag
diff --git a/audio/dekagen/Makefile b/audio/dekagen/Makefile
new file mode 100644
index 000000000000..102b4279f106
--- /dev/null
+++ b/audio/dekagen/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: dekagen
+# Date created: 12 August 2003
+# Whom: Martin Kraft <martin.kraft@fal.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dekagen
+PORTVERSION= 1.0
+CATEGORIES= audio
+MASTER_SITES= http://userpage.fu-berlin.de/~mbayer/tools/
+
+MAINTAINER= martin.kraft@fal.de
+COMMENT= A frontend to rip, convert and name MP3/Ogg
+
+# The only reason for installing xmcd is, that dekagen uses cda
+# for CDDB inquiries. You can safely 'make -DWITHOUT_XMCD', if you
+# can do without inquiring the CDDB database. Dependencies of
+# the xmcd package will install the encoders lame and oggenc (vorbis-tools),
+# both of them are supported bye dekagen.
+
+.if !defined(WITHOUT_XMCD)
+RUN_DEPENDS+= cda:${PORTSDIR}/audio/xmcd
+.endif
+
+# If you want to use another ripper, eg. tosha or dagrab,
+# you can safely 'make -DWITHOUT_CDPARANOIA'.
+
+.if !defined(WITHOUT_CDPARANOIA)
+RUN_DEPENDS+= cdparanoia:${PORTSDIR}/audio/cdparanoia
+.endif
+
+MAN1= dekagen.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.pre.mk>
+
+NO_BUILD= Shell Script
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/dekagen ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/dekagen.1.gz ${PREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/audio/dekagen/distinfo b/audio/dekagen/distinfo
new file mode 100644
index 000000000000..f5be68dc5d96
--- /dev/null
+++ b/audio/dekagen/distinfo
@@ -0,0 +1 @@
+MD5 (dekagen-1.0.tar.gz) = 2e8cc4216e7fe482594964d836587308
diff --git a/audio/dekagen/files/patch-dekagen b/audio/dekagen/files/patch-dekagen
new file mode 100644
index 000000000000..1c9c6638521d
--- /dev/null
+++ b/audio/dekagen/files/patch-dekagen
@@ -0,0 +1,12 @@
+--- dekagen.orig Sat Jul 19 13:00:19 2003
++++ dekagen Tue Aug 12 23:02:30 2003
+@@ -42,7 +42,8 @@
+ BITRATE='128' # MP3/Ogg nominal encoding bitrate (KBits)
+ METHOD='manual' # 'manual' or 'cddb'
+ XMCDLIB='' # $XMCD_LIBDIR
+-DEVICE='/dev/cdrom' # device used for ripping
++# Adapted DEVICE to a reasonabe FreeBSD default. Martin Kraft.
++DEVICE='/dev/acd0c' # device used for ripping
+ NCONVENT='artist-name_of_song.mp3'
+ SELEC='1' # MP3/Ogg naming convention
+ WHOLE='no' # rip whole CD ('yes' or 'no')
diff --git a/audio/dekagen/pkg-descr b/audio/dekagen/pkg-descr
new file mode 100644
index 000000000000..d54ab137c0b9
--- /dev/null
+++ b/audio/dekagen/pkg-descr
@@ -0,0 +1,21 @@
+dekagen is a front-end to several tools for the ripping, converting, and
+naming of MP3 and Ogg-Vorbis files. It automates the whole process of ripping
+data from music compact discs (CD), the naming of the files, their converting
+into MP3 or Ogg-Vorbis format and the labelling of the MP3 files with an ID3
+tag. dekagen uses dialog for a user interface that is intended to be
+"intuitive".
+
+Music data is read from CDs using cdda2wav, cdparanoia, dagrab, or tosha, and
+stored on your harddisk in wav-format. Note that this will have an excessive
+need of disk space. After this, the wav-data is converted into MP3 format
+using 8hz-mp3, bladeenc, l3enc, lame, mp3enc, or notlame, or into Ogg-Vorbis
+format using oggenc. This will take a while. To avoid manual naming and
+tagging for all the files, cda is used for CDDB lookups. To label the MP3
+files with ID3 tags, id3ed, id3tag, id3tool, or mp3info, or the built-in
+capabilities of some encoders (lame, notlame) are used. Ogg-Vorbis files can
+be labelled with oggenc.
+
+WWW: http://userpage.fu-berlin.de/~mbayer/tools/dekagen.html
+
+- Martin Kraft
+martin.kraft@fal.de
diff --git a/audio/dekagen/pkg-plist b/audio/dekagen/pkg-plist
new file mode 100644
index 000000000000..a3fac2fb3d27
--- /dev/null
+++ b/audio/dekagen/pkg-plist
@@ -0,0 +1 @@
+bin/dekagen