aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
commit39e31de51fbf694ff20f162572dc22c61f7d1b9d (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b /audio
parent1ddd46af14a4033deba9f651fa531f8aa83ea3f7 (diff)
downloadfreebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.gz
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.zst
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'audio')
-rw-r--r--audio/faust/Makefile2
-rw-r--r--audio/gxplugins-lv2/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/audio/faust/Makefile b/audio/faust/Makefile
index d5cf839295ba..09ddcaf3f08d 100644
--- a/audio/faust/Makefile
+++ b/audio/faust/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libLLVM-${LLVM_VERSION:C/([1-9])([0-9])/\1.\2/}.so:devel/llvm${LLVM_VERSION}
-USES= gmake ncurses python pkgconfig shebangfix
+USES= compiler:c++11-lang gmake ncurses python pkgconfig shebangfix
USE_GITHUB= yes
GH_ACCOUNT= grame-cncm
GH_TUPLE= grame-cncm:faustlibraries:f889fe1:libs/libraries \
diff --git a/audio/gxplugins-lv2/Makefile b/audio/gxplugins-lv2/Makefile
index 3ef7a035988e..d6e6019a6634 100644
--- a/audio/gxplugins-lv2/Makefile
+++ b/audio/gxplugins-lv2/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= lv2>0:audio/lv2
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= gettext-runtime gmake localbase pkgconfig
+USES= compiler:c++11-lang gettext-runtime gmake localbase pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= brummer10
GH_PROJECT= GxPlugins.lv2