aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2017-11-06 15:18:57 +0800
committerriggs <riggs@FreeBSD.org>2017-11-06 15:18:57 +0800
commit3b59e038af36521284ed618f9767ba79f184619f (patch)
tree502a172729f64afcab473043d43f07dcf10e5d42 /audio
parent8f089220d5f9cb135adb883de05626c850a11c07 (diff)
downloadfreebsd-ports-gnome-3b59e038af36521284ed618f9767ba79f184619f.tar.gz
freebsd-ports-gnome-3b59e038af36521284ed618f9767ba79f184619f.tar.zst
freebsd-ports-gnome-3b59e038af36521284ed618f9767ba79f184619f.zip
Retain API compatibility with faac 1.29.9 and later
Details: - See PR 223416
Diffstat (limited to 'audio')
-rw-r--r--audio/darkice/Makefile1
-rw-r--r--audio/darkice/files/patch-src_FaacEncoder.cpp13
2 files changed, 14 insertions, 0 deletions
diff --git a/audio/darkice/Makefile b/audio/darkice/Makefile
index dff15408ebd8..2de7cc753984 100644
--- a/audio/darkice/Makefile
+++ b/audio/darkice/Makefile
@@ -3,6 +3,7 @@
PORTNAME= darkice
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= audio net
MASTER_SITES= SF
diff --git a/audio/darkice/files/patch-src_FaacEncoder.cpp b/audio/darkice/files/patch-src_FaacEncoder.cpp
new file mode 100644
index 000000000000..45969a66c562
--- /dev/null
+++ b/audio/darkice/files/patch-src_FaacEncoder.cpp
@@ -0,0 +1,13 @@
+--- src/FaacEncoder.cpp.orig 2015-05-18 17:38:07 UTC
++++ src/FaacEncoder.cpp
+@@ -95,7 +95,9 @@ FaacEncoder :: open ( void )
+ faacConfig->useTns = 1;
+ faacConfig->shortctl = SHORTCTL_NORMAL;
+ faacConfig->useLfe = 0;
+- faacConfig->allowMidside = 1;
++ //Do not set allowMidside for API compatibility with faac,
++ //see https://github.com/knik0/faac/issues/8 for details
++ //faacConfig->allowMidside = 1;
+ faacConfig->bitRate = getOutBitrate() * 1000 / getOutChannel();
+ faacConfig->bandWidth = lowpass;
+ faacConfig->quantqual = (unsigned long) (getOutQuality() * 1000.0);