aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-27 06:16:11 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-27 06:16:11 +0800
commit3e7191e6e003527bbecc82242bb73276d11e0a83 (patch)
tree909f2ea060ebd2db15fe2a5beafb012b6d585a33 /audio
parent54ec9958ecca96dd0a49d4032f3aa78f3b7ecfd6 (diff)
downloadfreebsd-ports-gnome-3e7191e6e003527bbecc82242bb73276d11e0a83.tar.gz
freebsd-ports-gnome-3e7191e6e003527bbecc82242bb73276d11e0a83.tar.zst
freebsd-ports-gnome-3e7191e6e003527bbecc82242bb73276d11e0a83.zip
Attempt to unbreak and undeprecate (chase libsigc++20 update)
Diffstat (limited to 'audio')
-rw-r--r--audio/ardour/Makefile15
-rw-r--r--audio/ardour/files/patch-SConstruct19
2 files changed, 25 insertions, 9 deletions
diff --git a/audio/ardour/Makefile b/audio/ardour/Makefile
index d44c604d4953..d316920e6bbb 100644
--- a/audio/ardour/Makefile
+++ b/audio/ardour/Makefile
@@ -13,10 +13,6 @@ COMMENT= Multichannel digital audio workstation
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= fails to build
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2018-01-27
-
LIB_DEPENDS= liblo.so:audio/liblo \
liblrdf.so:textproc/liblrdf \
libjack.so:audio/jack \
@@ -73,6 +69,17 @@ post-patch:
@${REINPLACE_CMD} -e 's|alsa_pcm|oss|g' ${WRKSRC}/templates/*.template
@${REINPLACE_CMD} -e 's|std::pair<double|std::pair<const double|' \
${WRKSRC}/gtk2_ardour/tempo_lines.h
+ @${REINPLACE_CMD} -e '/sigc++\/class_slot\.h/d' \
+ ${WRKSRC}/libs/ardour/audioregion.cc \
+ ${WRKSRC}/libs/ardour/region.cc
+ @${REINPLACE_CMD} -e 's|time_t|& *|' \
+ ${WRKSRC}/libs/ardour/audiosource.cc
+ @${REINPLACE_CMD} -e '/sigc++\/retype\.h/d' \
+ ${WRKSRC}/libs/ardour/audio_track.cc \
+ ${WRKSRC}/gtk2_ardour/editor_markers.cc \
+ ${WRKSRC}/libs/ardour/session.cc \
+ ${WRKSRC}/libs/ardour/session_transport.cc \
+ ${WRKSRC}/libs/ardour/track.cc
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/ardour2/templates
diff --git a/audio/ardour/files/patch-SConstruct b/audio/ardour/files/patch-SConstruct
index e898b5ec9852..c105c8132768 100644
--- a/audio/ardour/files/patch-SConstruct
+++ b/audio/ardour/files/patch-SConstruct
@@ -1,4 +1,4 @@
---- SConstruct.orig
+--- SConstruct.orig 2012-12-02 19:19:45 UTC
+++ SConstruct
@@ -784,10 +784,7 @@ if env['FPU_OPTIMIZATION']:
# handle x86/x86_64 libdir properly
@@ -27,7 +27,16 @@
if env['DEBUG'] == 1:
env.Append(CCFLAGS=" ".join (debug_flags))
-@@ -954,6 +945,7 @@ conf.Finish()
+@@ -866,7 +857,7 @@ if env['UNIVERSAL'] == 1:
+ #
+
+ env.Append(CCFLAGS="-Wall")
+-env.Append(CXXFLAGS="-Woverloaded-virtual")
++env.Append(CXXFLAGS="-Woverloaded-virtual -std=c++11")
+
+ if env['EXTRA_WARN']:
+ env.Append(CCFLAGS="-Wextra -pedantic -ansi")
+@@ -955,6 +946,7 @@ conf.Finish()
libraries['usb'] = LibraryInfo ()
prep_libcheck(env, libraries['usb'])
@@ -35,7 +44,7 @@
conf = Configure (libraries['usb'])
if conf.CheckLib ('usb', 'usb_interrupt_write'):
-@@ -1005,6 +997,7 @@ libraries['boost'] = conf.Finish ()
+@@ -1006,6 +998,7 @@ libraries['boost'] = conf.Finish ()
libraries['dmalloc'] = LibraryInfo ()
prep_libcheck(env, libraries['dmalloc'])
@@ -43,7 +52,7 @@
#
# look for the threaded version
-@@ -1062,8 +1055,10 @@ elif conf.CheckCHeader('/System/Library/
+@@ -1063,8 +1056,10 @@ elif conf.CheckCHeader('/System/Library/Frameworks/Cor
subst_dict['%MIDITAG%'] = "ardour"
subst_dict['%MIDITYPE%'] = "coremidi"
else:
@@ -56,7 +65,7 @@
pname = env['PROGRAM_NAME']
subst_dict['%MIDI_DEVICE_NAME%'] = pname.lower()
-@@ -1349,8 +1344,8 @@ if conf.CheckCHeader('/System/Library/Fr
+@@ -1352,8 +1347,8 @@ if conf.CheckCHeader('/System/Library/Frameworks/CoreA
subst_dict['%JACK_INPUT%'] = "coreaudio:Built-in Audio:in"
subst_dict['%JACK_OUTPUT%'] = "coreaudio:Built-in Audio:out"
else: