aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2014-07-20 22:48:53 +0800
committerChris Rees <crees@FreeBSD.org>2014-07-20 22:48:53 +0800
commit45287b74afc99da42b98f7909b91de1ebcdb9487 (patch)
tree9ae469d1001172ef161fecb244ae03989be9d430 /audio
parent844702f07c69a39193585d1120a96938cc7f2e74 (diff)
downloadfreebsd-ports-gnome-45287b74afc99da42b98f7909b91de1ebcdb9487.tar.gz
freebsd-ports-gnome-45287b74afc99da42b98f7909b91de1ebcdb9487.tar.zst
freebsd-ports-gnome-45287b74afc99da42b98f7909b91de1ebcdb9487.zip
Give up trying to make MPDDIR, and let pw useradd do it. Stop making
it customisable via make.conf; pointless with package installations. Modernise slightly. Correct IGNORE message-- there is no real problem with using .error here, but since it was mysteriously changed without notice assume that there was an extremely good reason for it.
Diffstat (limited to 'audio')
-rw-r--r--audio/musicpd/Makefile23
-rw-r--r--audio/musicpd/files/musicpd.in2
-rw-r--r--audio/musicpd/files/pkg-message.in2
-rw-r--r--audio/musicpd/pkg-plist4
4 files changed, 6 insertions, 25 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 86454fb526e5..940f8882b366 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -124,18 +124,12 @@ WAVPACK_LIB_DEPENDS=libwavpack.so:${PORTSDIR}/audio/wavpack
WILDMIDI_CONFIGURE_ENABLE=wildmidi
WILDMIDI_LIB_DEPENDS=libWildMidi.so:${PORTSDIR}/audio/wildmidi
-MPDDIR?= /var/mpd
MPDUSER?= mpd
MPDGROUP?= mpd
USERS= ${MPDUSER}
GROUPS= ${MPDGROUP}
-PLIST_SUB= MPDUSER=${MPDUSER} \
- MPDDIR=${MPDDIR} \
- MPDGROUP=${MPDGROUP}
-SUB_LIST+= MPDDIR=${MPDDIR}
-
.include <bsd.port.options.mk>
.ifdef MPDCONF
@@ -143,7 +137,7 @@ IGNORE=Please remove the MPDCONF line from make.conf, then rename ${PREFIX}/etc/
.endif
.if exists(${PREFIX}/etc/mpd.conf)
-MSG=You still have ${PREFIX}/etc/mpd.conf in existence-- this file is no longer used by musicpd.
+MSG=does not expect ${PREFIX}/etc/mpd.conf to exist.
.if !exists(${PREFIX}/etc/musicpd.conf)
IGNORE=${MSG} Move it to ${PREFIX}/etc/musicpd.conf.
.else
@@ -191,8 +185,8 @@ CONFIGURE_ARGS+=--disable-shout
.endif
post-patch:
-# Replace ~/ with MPDDIR and make musicpd run as mpd by default
- @${REINPLACE_CMD} -e 's,^#\([^"]*"\)~/,\1${MPDDIR}/,g' \
+# Replace ~/ with /var/mpd and make musicpd run as mpd by default
+ @${REINPLACE_CMD} -e 's,^#\([^"]*"\)~/,\1/var/mpd,g' \
-e 's,^#\(user[^"]*"\)nobody,\1${MPDUSER},g' \
${WRKSRC}/doc/mpdconf.example
# Uncomment OSS audio output part from MPDCONF; dragons!
@@ -227,16 +221,5 @@ do-install:
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}/${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/mpdconf.example \
${STAGEDIR}/${PREFIX}/etc/${PORTNAME}.conf.sample
- ${PRINTF} "%s\n%s\n%s\n" "@cwd /" "@owner ${MPDUSER}" \
- "@group ${MPDGROUP}" >> ${TMPPLIST}
- cd ${STAGEDIR} && ${MKDIR} -v ${MPDDIR:S,^/,,}/.mpd | ${SORT} -r | \
- ${SED} 's,^,@dirrmtry ,' >> ${TMPPLIST}
-.ifndef WITH_PKGNG
- # Cute, we can't use @dirrmtry with pkg_old...
- # Remove once all using pkgng
- ${REINPLACE_CMD} \
- 's,^@dirrmtry \(.*\),@unexec rmdir \1 > /dev/null || :,' \
- ${TMPPLIST}
-.endif
.include <bsd.port.mk>
diff --git a/audio/musicpd/files/musicpd.in b/audio/musicpd/files/musicpd.in
index f367cde80173..7b4b8ad127c0 100644
--- a/audio/musicpd/files/musicpd.in
+++ b/audio/musicpd/files/musicpd.in
@@ -30,7 +30,7 @@ musicpd_getpidfile()
if get_pidfile_from_conf pid_file %%PREFIX%%/etc/musicpd.conf ; then
pidfile="$_pidfile_from_conf"
else
- pidfile="%%MPDDIR%%/.mpd/pid"
+ pidfile="/var/mpd/.mpd/pid"
fi
}
diff --git a/audio/musicpd/files/pkg-message.in b/audio/musicpd/files/pkg-message.in
index 7487c93d98b3..01714a11462a 100644
--- a/audio/musicpd/files/pkg-message.in
+++ b/audio/musicpd/files/pkg-message.in
@@ -17,7 +17,7 @@ Then start the server with
or reboot.
The example configuration of MPD server requires music files to
-be stored in the %%MPDDIR%%/music directory.
+be stored in the /var/mpd/music directory.
NOTE: The musicpd server is pretty useless without a client.
You might want to install one of the following ports too:
diff --git a/audio/musicpd/pkg-plist b/audio/musicpd/pkg-plist
index 4bb63192564d..f4a7ac93e139 100644
--- a/audio/musicpd/pkg-plist
+++ b/audio/musicpd/pkg-plist
@@ -1,6 +1,4 @@
bin/musicpd
-@unexec if cmp -s %D/etc/musicpd.conf.sample %D/etc/musicpd.conf; then rm -f %D/etc/musicpd.conf; fi
-etc/musicpd.conf.sample
-@exec if [ ! -f %B/musicpd.conf ] ; then cp -p %D/%F %B/musicpd.conf; fi
+@sample etc/musicpd.conf.sample
man/man1/musicpd.1.gz
man/man5/musicpd.conf.5.gz