aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2019-04-29 02:04:01 +0800
committertcberner <tcberner@FreeBSD.org>2019-04-29 02:04:01 +0800
commit456dfcfd6d7b0babc5d153464d0c144664b5257a (patch)
treec45ea5bddb8c91bd97720fc9f06563df34d1ce8a /audio
parentb5a7baa2e287909b1be0c2a3541d54860b8124b7 (diff)
downloadfreebsd-ports-gnome-456dfcfd6d7b0babc5d153464d0c144664b5257a.tar.gz
freebsd-ports-gnome-456dfcfd6d7b0babc5d153464d0c144664b5257a.tar.zst
freebsd-ports-gnome-456dfcfd6d7b0babc5d153464d0c144664b5257a.zip
New port: audio/noson-app -- a SONOS controller
Noson is a SONOS controller for Linux platforms The fast and smart controller for your SONOS devices. You can browse your music library and play track or radio on any zones. You can manage grouping zones, queue, and playlists, and fully control the playback. Written with QML/C++ for maximal performance WWW: http://janbar.github.io/noson-app/index.html
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/noson-app/Makefile27
-rw-r--r--audio/noson-app/distinfo3
-rw-r--r--audio/noson-app/pkg-descr9
-rw-r--r--audio/noson-app/pkg-plist12
5 files changed, 52 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 62f7be87f613..5b8eeda362a5 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -566,6 +566,7 @@
SUBDIR += noise-repellent-lv2
SUBDIR += normalize
SUBDIR += nosefart
+ SUBDIR += noson-app
SUBDIR += nspmod
SUBDIR += nuvolaplayer
SUBDIR += oaml
diff --git a/audio/noson-app/Makefile b/audio/noson-app/Makefile
new file mode 100644
index 000000000000..43e1cb78581b
--- /dev/null
+++ b/audio/noson-app/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= noson-app
+DISTVERSION= 3.11.4
+CATEGORIES= audio net
+
+MAINTAINER= tcberner@FreeBSD.org
+COMMENT= Fast and smart SONOS controller
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libFLAC.so:audio/flac
+
+USES= cmake qt:5 ssl
+USE_QT= core declarative gui network quickcontrols2 \
+ svg widgets xml \
+ buildtools_build qmake_build
+USE_GITHUB= yes
+GH_ACCOUNT= janbar
+
+OPTIONS_DEFINE= PULSEAUDIO
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+PULSEAUDIO_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Pulse \
+ CMAKE_DISABLE_FIND_PACKAGE_Pulse-simple
+
+.include <bsd.port.mk>
diff --git a/audio/noson-app/distinfo b/audio/noson-app/distinfo
new file mode 100644
index 000000000000..d23bd69ca22e
--- /dev/null
+++ b/audio/noson-app/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1556469837
+SHA256 (janbar-noson-app-3.11.4_GH0.tar.gz) = 3d35194a147780b44f6e224b4fd4602731585db10e7d1dda937569c72e1bce37
+SIZE (janbar-noson-app-3.11.4_GH0.tar.gz) = 8398910
diff --git a/audio/noson-app/pkg-descr b/audio/noson-app/pkg-descr
new file mode 100644
index 000000000000..c8926a1d81a5
--- /dev/null
+++ b/audio/noson-app/pkg-descr
@@ -0,0 +1,9 @@
+Noson is a SONOS controller for Linux platforms
+
+The fast and smart controller for your SONOS devices. You can browse your music
+library and play track or radio on any zones. You can manage grouping zones,
+queue, and playlists, and fully control the playback.
+
+Written with QML/C++ for maximal performance
+
+WWW: http://janbar.github.io/noson-app/index.html
diff --git a/audio/noson-app/pkg-plist b/audio/noson-app/pkg-plist
new file mode 100644
index 000000000000..97bca2af1550
--- /dev/null
+++ b/audio/noson-app/pkg-plist
@@ -0,0 +1,12 @@
+bin/noson-app
+lib/noson/NosonApp/libNosonApp.so
+lib/noson/NosonApp/qmldir
+lib/noson/NosonMediaScanner/libNosonMediaScanner.so
+lib/noson/NosonMediaScanner/qmldir
+lib/noson/NosonThumbnailer/libNosonThumbnailer.so
+lib/noson/NosonThumbnailer/qmldir
+lib/noson/noson-cli
+lib/noson/noson-gui
+share/applications/io.github.janbar.noson.desktop
+share/icons/hicolor/256x256/apps/noson.png
+share/metainfo/io.github.janbar.noson.appdata.xml