aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2007-06-01 03:55:30 +0800
committerehaupt <ehaupt@FreeBSD.org>2007-06-01 03:55:30 +0800
commit46934a0dc3f787c595f64b2be39931429a58d0c7 (patch)
treecfe12356304551be133f3cbaf4d57cc44f91bc91 /audio
parent7dcf337b6d71b51ae39f982e00c8d9e43b709c89 (diff)
downloadfreebsd-ports-gnome-46934a0dc3f787c595f64b2be39931429a58d0c7.tar.gz
freebsd-ports-gnome-46934a0dc3f787c595f64b2be39931429a58d0c7.tar.zst
freebsd-ports-gnome-46934a0dc3f787c595f64b2be39931429a58d0c7.zip
Fix build on amd64
Notified by: kris (via pointyhat)
Diffstat (limited to 'audio')
-rw-r--r--audio/audacious-dumb/Makefile2
-rw-r--r--audio/audacious-dumb/files/patch-Makefile30
2 files changed, 27 insertions, 5 deletions
diff --git a/audio/audacious-dumb/Makefile b/audio/audacious-dumb/Makefile
index 123695dd73be..d64d04182f85 100644
--- a/audio/audacious-dumb/Makefile
+++ b/audio/audacious-dumb/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= audacious:${PORTSDIR}/multimedia/audacious \
USE_GMAKE= yes
USE_LDCONFIG= yes
-MAKE_ENV+= CC="${CC}"
+MAKE_ENV+= CC="${CC}" LOCALBASE="${LOCALBASE}"
ONLY_FOR_ARCHS= i386 amd64
diff --git a/audio/audacious-dumb/files/patch-Makefile b/audio/audacious-dumb/files/patch-Makefile
index 9a932b270fb4..da90b90183e3 100644
--- a/audio/audacious-dumb/files/patch-Makefile
+++ b/audio/audacious-dumb/files/patch-Makefile
@@ -1,6 +1,24 @@
---- ./Makefile.orig Sun May 27 12:12:15 2007
-+++ ./Makefile Sun May 27 12:12:23 2007
-@@ -24,10 +24,6 @@
+--- ./Makefile.orig Wed Feb 28 13:01:40 2007
++++ ./Makefile Wed May 30 10:34:31 2007
+@@ -7,7 +7,7 @@
+ CC ?= gcc
+ CFLAGS ?= -O2 -pipe
+
+-CFLAGS += -Wall -fPIC -DPIC -I/usr/local/include
++CFLAGS += -Wall -fPIC -DPIC -I$(LOCALBASE)/include
+ AUDACIOUSCFLAGS = $(shell pkg-config 'audacious >= 1.3' --cflags || echo "old")
+
+ ifeq ($(AUDACIOUSCFLAGS),old)
+@@ -16,6 +16,8 @@
+ CFLAGS += $(AUDACIOUSCFLAGS)
+ endif
+
++LDFLAGS+= -fPIC -DPIC
++
+ DUMBLIBS := -ldumb -L/usr/local/lib
+ AUDACIOUSLIBS := $(shell pkg-config audacious --libs)
+
+@@ -24,13 +26,9 @@
OBJECTS := $(SOURCES:%.c=$(OBJDIR)/%.o)
all: $(PLUGIN_FILE)
@@ -10,4 +28,8 @@
- @echo "make install-home - for installation to home directory $(INSTALL_DIR_HOME)"
$(PLUGIN_FILE): $(OBJECTS)
- $(CC) -shared -o $@ $^ $(DUMBLIBS) $(AUDACIOUSLIBS)
+- $(CC) -shared -o $@ $^ $(DUMBLIBS) $(AUDACIOUSLIBS)
++ $(CC) $(LDFLAGS) -shared -o $@ $^ $(DUMBLIBS) $(AUDACIOUSLIBS)
+
+ $(OBJDIR)/%.o: %.c
+ $(CC) -o $@ $(CFLAGS) -c $<