aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-10 04:22:21 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-10 04:22:21 +0800
commit497887b152a407b297ddab1021e51234dd082003 (patch)
tree39dc1c83cb59db23c3c58834d22706ec6103f4a0 /audio
parent0bd0d05b05100658dd0e8d2a2e350142f4f5e0c2 (diff)
downloadfreebsd-ports-gnome-497887b152a407b297ddab1021e51234dd082003.tar.gz
freebsd-ports-gnome-497887b152a407b297ddab1021e51234dd082003.tar.zst
freebsd-ports-gnome-497887b152a407b297ddab1021e51234dd082003.zip
Adplay is a command line AdLib player using the adplug library. It supports
many AdLib formats such as HSP and HSC. WWW: http://adplug.sourceforge.net/ PR: ports/80727 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/adplay/Makefile44
-rw-r--r--audio/adplay/distinfo2
-rw-r--r--audio/adplay/files/patch-src_adplay.cc21
-rw-r--r--audio/adplay/pkg-descr7
5 files changed, 75 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8cc4390c37be..22eb2e2b582a 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -10,6 +10,7 @@
SUBDIR += abcselect
SUBDIR += ac3dec
SUBDIR += adpcm
+ SUBDIR += adplay
SUBDIR += afsp
SUBDIR += akode
SUBDIR += akode-plugins-jack
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
new file mode 100644
index 000000000000..d76a9b9a0d69
--- /dev/null
+++ b/audio/adplay/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: adplay
+# Date created: 10 August 2004
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= adplay
+PORTVERSION= 1.4
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= adplug
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= AdLib player using adplug library
+
+LIB_DEPENDS= adplug-1.5.0:${PORTSDIR}/audio/libadplug
+
+PLIST_FILES= bin/adplay
+
+GNU_CONFIGURE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+MAN1= adplay.1
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} > 500000
+ ${RM} ${WRKSRC}/src/getopt.h
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/adplay ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/adplay.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/audio/adplay/distinfo b/audio/adplay/distinfo
new file mode 100644
index 000000000000..2574d396636a
--- /dev/null
+++ b/audio/adplay/distinfo
@@ -0,0 +1,2 @@
+MD5 (adplay-1.4.tar.gz) = 1fbb6ccbc3f559cbec8768e2554a1d59
+SIZE (adplay-1.4.tar.gz) = 338761
diff --git a/audio/adplay/files/patch-src_adplay.cc b/audio/adplay/files/patch-src_adplay.cc
new file mode 100644
index 000000000000..600fdf958a82
--- /dev/null
+++ b/audio/adplay/files/patch-src_adplay.cc
@@ -0,0 +1,21 @@
+--- src/adplay.cc.orig Fri May 6 19:23:17 2005
++++ src/adplay.cc Fri May 6 19:23:24 2005
+@@ -25,16 +25,15 @@
+ #include <adplug/adplug.h>
+ #include <adplug/emuopl.h>
+ #include <adplug/kemuopl.h>
++#include <getopt.h>
+
+ /*
+- * Apple (OS X) and Sun systems declare getopt in unistd.h, other systems
+- * (Linux) use getopt.h.
+- */
+ #if defined ( __APPLE__ ) || ( defined (__SVR4) && defined (__sun) )
+ # include <unistd.h>
+ #else
+ # include "getopt.h"
+ #endif
++*/
+
+ #include "defines.h"
+ #include "output.h"
diff --git a/audio/adplay/pkg-descr b/audio/adplay/pkg-descr
new file mode 100644
index 000000000000..03298633b9d5
--- /dev/null
+++ b/audio/adplay/pkg-descr
@@ -0,0 +1,7 @@
+Adplay is a command line AdLib player using the adplug library. It supports
+many AdLib formats such as HSP and HSC.
+
+WWW: http://adplug.sourceforge.net/
+
+- ehaupt
+ehaupt@critical.ch