aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-08-22 00:28:09 +0800
committermarcus <marcus@FreeBSD.org>2003-08-22 00:28:09 +0800
commit51d89953cb0c4d840cadee644f0f41d959fefcbe (patch)
treeb87cd35513fe310316f3ab27f9206a58d9b9f184 /audio
parent46ba74f2b0b902e6c0b68f473a924ab87c5cc239 (diff)
downloadfreebsd-ports-gnome-51d89953cb0c4d840cadee644f0f41d959fefcbe.tar.gz
freebsd-ports-gnome-51d89953cb0c4d840cadee644f0f41d959fefcbe.tar.zst
freebsd-ports-gnome-51d89953cb0c4d840cadee644f0f41d959fefcbe.zip
Add a WITH_XINE knob to build against the libxine backend. This fixes
a problem detecting certain MP3s tagged with ID3 2.3.0 tags. Submitted by: Frank Ruell <stoerte@dreamwarrior.net>
Diffstat (limited to 'audio')
-rw-r--r--audio/rhythmbox-devel/Makefile13
-rw-r--r--audio/rhythmbox/Makefile13
2 files changed, 24 insertions, 2 deletions
diff --git a/audio/rhythmbox-devel/Makefile b/audio/rhythmbox-devel/Makefile
index b7f03ab3bca9..1ba4c99b4cd9 100644
--- a/audio/rhythmbox-devel/Makefile
+++ b/audio/rhythmbox-devel/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= marcus@freebsd.org
COMMENT= Audio player for the Gnome 2 desktop environment
LIB_DEPENDS= musicbrainz.2:${PORTSDIR}/audio/libmusicbrainz \
- gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins \
FLAC.5:${PORTSDIR}/audio/flac \
mad.1:${PORTSDIR}/audio/mad
@@ -40,11 +39,23 @@ LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --disable-vorbistest
.endif
+.ifdef (WITH_XINE)
+LIB_DEPENDS+= xine.7:${PORTSDIR}/multimedia/libxine
+CONFIGURE_ARGS+= --enable-xine
+.else
+LIB_DEPENDS+= gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins
+.endif
+
pre-everything::
.if !defined(WITH_VORBIS)
@${ECHO_MSG}
@${ECHO_MSG} "Define WITH_VORBIS to enable Vorbis support"
@${ECHO_MSG}
.endif
+.if !defined(WITH_XINE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Define WITH_XINE to use xine backend instead of gstreamer"
+ @${ECHO_MSG}
+.endif
.include <bsd.port.post.mk>
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index b7f03ab3bca9..1ba4c99b4cd9 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= marcus@freebsd.org
COMMENT= Audio player for the Gnome 2 desktop environment
LIB_DEPENDS= musicbrainz.2:${PORTSDIR}/audio/libmusicbrainz \
- gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins \
FLAC.5:${PORTSDIR}/audio/flac \
mad.1:${PORTSDIR}/audio/mad
@@ -40,11 +39,23 @@ LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --disable-vorbistest
.endif
+.ifdef (WITH_XINE)
+LIB_DEPENDS+= xine.7:${PORTSDIR}/multimedia/libxine
+CONFIGURE_ARGS+= --enable-xine
+.else
+LIB_DEPENDS+= gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins
+.endif
+
pre-everything::
.if !defined(WITH_VORBIS)
@${ECHO_MSG}
@${ECHO_MSG} "Define WITH_VORBIS to enable Vorbis support"
@${ECHO_MSG}
.endif
+.if !defined(WITH_XINE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Define WITH_XINE to use xine backend instead of gstreamer"
+ @${ECHO_MSG}
+.endif
.include <bsd.port.post.mk>