aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-04-01 02:59:35 +0800
committerkwm <kwm@FreeBSD.org>2014-04-01 02:59:35 +0800
commit582223fe2c3982830719c8bb527d718eda7220e9 (patch)
tree77f6541fc43a6e2b0d8198a1dea666ebba5d817c /audio
parent0830e77ed8f7572d643d40b542d7a1a5d16347ee (diff)
downloadfreebsd-ports-gnome-582223fe2c3982830719c8bb527d718eda7220e9.tar.gz
freebsd-ports-gnome-582223fe2c3982830719c8bb527d718eda7220e9.tar.zst
freebsd-ports-gnome-582223fe2c3982830719c8bb527d718eda7220e9.zip
Stagify.
Diffstat (limited to 'audio')
-rw-r--r--audio/gnome-media/Makefile1
-rw-r--r--audio/goobox/Makefile4
-rw-r--r--audio/jack-rack/Makefile4
-rw-r--r--audio/libcanberra-gtk3/Makefile10
-rw-r--r--audio/libcanberra/Makefile1
-rw-r--r--audio/libopenspc/Makefile1
-rw-r--r--audio/pulseaudio/Makefile13
-rw-r--r--audio/pulseaudio/pkg-plist13
-rw-r--r--audio/sound-juicer/Makefile5
-rw-r--r--audio/sound-juicer/pkg-plist1
10 files changed, 22 insertions, 31 deletions
diff --git a/audio/gnome-media/Makefile b/audio/gnome-media/Makefile
index fe2aa3dad642..520a97df0502 100644
--- a/audio/gnome-media/Makefile
+++ b/audio/gnome-media/Makefile
@@ -19,7 +19,6 @@ LIB_DEPENDS= libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra \
CONFLICTS= gnome-control-center-3.[0-9]* libgnome-media-profiles-3.[0-9]*
USE_BZIP2= yes
-NO_STAGE= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/audio/goobox/Makefile b/audio/goobox/Makefile
index c8d8c1bc84d3..be3729d88203 100644
--- a/audio/goobox/Makefile
+++ b/audio/goobox/Makefile
@@ -20,7 +20,6 @@ LIB_DEPENDS= libdiscid.so:${PORTSDIR}/audio/libdiscid \
RUN_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
USE_XORG= x11
-NO_STAGE= yes
USES= gettext gmake pkgconfig
USE_BZIP2= yes
USE_GNOME= gnomeprefix gnomehack intlhack gtk20 gconf2 desktopfileutils
@@ -45,7 +44,4 @@ CONFIGURE_ARGS+=--enable-notification
CONFIGURE_ARGS+=--disable-notification
.endif
-post-install:
- @-update-desktop-database
-
.include <bsd.port.mk>
diff --git a/audio/jack-rack/Makefile b/audio/jack-rack/Makefile
index fa8d4d4705b4..ce24d0bdcd44 100644
--- a/audio/jack-rack/Makefile
+++ b/audio/jack-rack/Makefile
@@ -15,10 +15,8 @@ LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack \
liblrdf.so:${PORTSDIR}/textproc/liblrdf
RUN_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
-USE_BZIP2= yes
-NO_STAGE= yes
USE_GNOME= libgnomeui libxml2
-USES= gettext shebangfix pkgconfig
+USES= gettext shebangfix pkgconfig tar:bzip2
USE_PYTHON= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/audio/libcanberra-gtk3/Makefile b/audio/libcanberra-gtk3/Makefile
index 3d1792fde8e4..ed30028fbdc3 100644
--- a/audio/libcanberra-gtk3/Makefile
+++ b/audio/libcanberra-gtk3/Makefile
@@ -10,7 +10,6 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Implementation of the Freedesktop sound theme spec
MASTERDIR= ${.CURDIR}/../../audio/libcanberra
-NO_STAGE= yes
SLAVEPORT= gtk3
PLIST= ${.CURDIR}/pkg-plist
@@ -25,13 +24,14 @@ do-build:
do-install:
${INSTALL_DATA} ${WRKSRC}/libcanberra-gtk3.pc \
- ${PREFIX}/libdata/pkgconfig/
+ ${STAGEDIR}${PREFIX}/libdata/pkgconfig/
.for i in .a .la .so .so.0
${INSTALL_DATA} ${WRKSRC}/src/.libs/libcanberra-gtk3${i} \
- ${PREFIX}/lib/
+ ${STAGEDIR}${PREFIX}/lib/
.endfor
- cd ${WRKSRC}/src && ${GMAKE} install-gtk3moduleLTLIBRARIES
- cd ${PREFIX}/lib/gtk-3.0/modules && \
+ cd ${WRKSRC}/src && ${SETENV} DESTDIR=${STAGEDIR} \
+ ${GMAKE} install-gtk3moduleLTLIBRARIES
+ cd ${STAGEDIR}${PREFIX}/lib/gtk-3.0/modules && \
${LN} -sf libcanberra-gtk3-module.so libcanberra-gtk-module.so
.include "${MASTERDIR}/Makefile"
diff --git a/audio/libcanberra/Makefile b/audio/libcanberra/Makefile
index 0ae40952f9eb..5bf74ccf2b46 100644
--- a/audio/libcanberra/Makefile
+++ b/audio/libcanberra/Makefile
@@ -17,7 +17,6 @@ LICENSE_FILE= ${WRKSRC}/LGPL
LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
USES= gmake pkgconfig
-NO_STAGE= yes
USE_GNOME= gnomeprefix gnomehack gtk20 ltverhack gconf2
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool libltdl
diff --git a/audio/libopenspc/Makefile b/audio/libopenspc/Makefile
index c8231a17c246..b1e279917756 100644
--- a/audio/libopenspc/Makefile
+++ b/audio/libopenspc/Makefile
@@ -14,7 +14,6 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
GNU_CONFIGURE= yes
USES= gmake
-NO_STAGE= yes
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index 0f5d1375351e..1a3f12688f5a 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -25,7 +25,6 @@ LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libck-connector.so:${PORTSDIR}/sysutils/consolekit
USE_GNOME= gnomehack glib20 intltool ltverhack
-NO_STAGE= yes
USE_XORG= x11 sm xtst ice
USE_LDCONFIG= yes
USES= gettext gmake pkgconfig
@@ -62,10 +61,6 @@ OPTIONS_DEFAULT= AVAHI HAL GCONF
PULSE_VERSION= ${PORTVERSION}
PLIST_SUB= PULSE_VERSION=${PULSE_VERSION}
-MAN1= esdcompat.1 pabrowse.1 pacat.1 pacmd.1 pactl.1 padsp.1 \
- paplay.1 pasuspender.1 pax11publish.1 pulseaudio.1
-MAN5= default.pa.5 pulse-client.conf.5 pulse-daemon.conf.5
-
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MJACK}
@@ -112,14 +107,10 @@ post-patch:
${WRKSRC}/configure
post-install:
- ${MKDIR} ${PREFIX}/etc/pulse
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/pulse
.for ii in default.pa daemon.conf client.conf system.pa
${INSTALL_DATA} ${WRKSRC}/src/${ii} \
- ${PREFIX}/etc/pulse/${ii}-dist
-. if !exists(${PREFIX}/etc/pulse/${II})
- ${INSTALL_DATA} ${WRKSRC}/src/${ii} \
- ${PREFIX}/etc/pulse/${ii}
-. endif
+ ${STAGEDIR}${PREFIX}/etc/pulse/${ii}-dist
.endfor
.include <bsd.port.post.mk>
diff --git a/audio/pulseaudio/pkg-plist b/audio/pulseaudio/pkg-plist
index c512535a9d12..6cff9c48ea31 100644
--- a/audio/pulseaudio/pkg-plist
+++ b/audio/pulseaudio/pkg-plist
@@ -225,6 +225,19 @@ libdata/pkgconfig/libpulse-mainloop-glib.pc
libdata/pkgconfig/libpulse-simple.pc
libdata/pkgconfig/libpulse.pc
%%GCONF%%libexec/pulse/gconf-helper
+man/man1/esdcompat.1.gz
+man/man1/pabrowse.1.gz
+man/man1/pacat.1.gz
+man/man1/pacmd.1.gz
+man/man1/pactl.1.gz
+man/man1/padsp.1.gz
+man/man1/paplay.1.gz
+man/man1/pasuspender.1.gz
+man/man1/pax11publish.1.gz
+man/man1/pulseaudio.1.gz
+man/man5/default.pa.5.gz
+man/man5/pulse-client.conf.5.gz
+man/man5/pulse-daemon.conf.5.gz
share/locale/as/LC_MESSAGES/pulseaudio.mo
share/locale/bn_IN/LC_MESSAGES/pulseaudio.mo
share/locale/ca/LC_MESSAGES/pulseaudio.mo
diff --git a/audio/sound-juicer/Makefile b/audio/sound-juicer/Makefile
index 42d23554231f..2dba284fc16d 100644
--- a/audio/sound-juicer/Makefile
+++ b/audio/sound-juicer/Makefile
@@ -21,7 +21,6 @@ LIB_DEPENDS= libmusicbrainz3.so:${PORTSDIR}/audio/libmusicbrainz3 \
libbrasero-media.so:${PORTSDIR}/sysutils/brasero
USE_BZIP2= yes
-NO_STAGE= yes
USES= gettext gmake pathfix pkgconfig
INSTALLS_OMF= yes
USE_GNOME= intlhack gnomeprefix gconf2 libglade2 gnomedocutils
@@ -32,7 +31,6 @@ INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= sound-juicer.1
GCONF_SCHEMAS= sound-juicer.schemas
post-patch:
@@ -40,7 +38,4 @@ post-patch:
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|" == "|" = "|g' ${WRKSRC}/configure
-post-install:
- @-update-desktop-database
-
.include <bsd.port.mk>
diff --git a/audio/sound-juicer/pkg-plist b/audio/sound-juicer/pkg-plist
index 72611f2658dc..774f610d3dad 100644
--- a/audio/sound-juicer/pkg-plist
+++ b/audio/sound-juicer/pkg-plist
@@ -1,4 +1,5 @@
bin/sound-juicer
+man/man1/sound-juicer.1.gz
share/applications/sound-juicer.desktop
share/gnome/help/sound-juicer/C/figures/prefs.png
share/gnome/help/sound-juicer/C/figures/startup.png