aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-08-20 14:33:23 +0800
committerdaichi <daichi@FreeBSD.org>2003-08-20 14:33:23 +0800
commit5e49e1c0c2bfe5d28aa650048ddc50c35e0ca9fd (patch)
tree03fdf14661993bf2735126a1331f5fd4c89b2052 /audio
parentff5349017560a0df238bab0877804834909976e3 (diff)
downloadfreebsd-ports-gnome-5e49e1c0c2bfe5d28aa650048ddc50c35e0ca9fd.tar.gz
freebsd-ports-gnome-5e49e1c0c2bfe5d28aa650048ddc50c35e0ca9fd.tar.zst
freebsd-ports-gnome-5e49e1c0c2bfe5d28aa650048ddc50c35e0ca9fd.zip
update audio/aureal-kmod: broken by busdma commit
PR: 55513 Submitted by: James E. Flemer <jflemer@alum.rpi.edu>
Diffstat (limited to 'audio')
-rw-r--r--audio/aureal-kmod/Makefile2
-rw-r--r--audio/aureal-kmod/files/patch-au88x0.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/audio/aureal-kmod/Makefile b/audio/aureal-kmod/Makefile
index 71fbb701d7e8..40f01fd63331 100644
--- a/audio/aureal-kmod/Makefile
+++ b/audio/aureal-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= aureal-kmod
PORTVERSION= 1.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://home.columbus.rr.com/amatey/au88x0/
DISTNAME= au88x0-${PORTVERSION}_${PORTREVISION}
diff --git a/audio/aureal-kmod/files/patch-au88x0.c b/audio/aureal-kmod/files/patch-au88x0.c
index 4612ffc0c489..1b64f382b9bb 100644
--- a/audio/aureal-kmod/files/patch-au88x0.c
+++ b/audio/aureal-kmod/files/patch-au88x0.c
@@ -13,3 +13,16 @@ $FreeBSD$
#include <pci/pcireg.h>
#include <pci/pcivar.h>
+@@ -852,7 +853,11 @@
+ /*highaddr*/BUS_SPACE_MAXADDR,
+ /*filter*/NULL, /*filterarg*/NULL,
+ /*maxsize*/AU_BUFFSIZE, /*nsegments*/1, /*maxsegz*/0x3ffff,
+- /*flags*/0, &au->parent_dmat) != 0) {
++ /*flags*/0,
++#if __FreeBSD_version > 501102
++ /*lockfunc*/NULL, /*lockarg*/NULL,
++#endif
++ &au->parent_dmat) != 0) {
+ device_printf(dev, "unable to create dma tag\n");
+ goto bad;
+ }