aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortdb <tdb@FreeBSD.org>2006-12-15 23:14:11 +0800
committertdb <tdb@FreeBSD.org>2006-12-15 23:14:11 +0800
commit6174de4e5e378f228293ebc468f987da02b7b3e1 (patch)
treef31bf07993df8b38f048617eb1d61d371cca7f6e /audio
parent67c5f504637988f46b735a4fb25f1c1424321cb3 (diff)
downloadfreebsd-ports-gnome-6174de4e5e378f228293ebc468f987da02b7b3e1.tar.gz
freebsd-ports-gnome-6174de4e5e378f228293ebc468f987da02b7b3e1.tar.zst
freebsd-ports-gnome-6174de4e5e378f228293ebc468f987da02b7b3e1.zip
- Add new port audio/slimserver-lazysearch.
Description: This is a SlimServer plugin to add lazy search capabilities. Lazy searching allows for much faster entry of search text by allowing you to forget about multi-tapping and instead just press each of the remote control buttons once for each of the letters in the text, whatever position the letter appears in above the button. WWW: http://hickinbottom.demon.co.uk/lazysearch/
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/slimserver-lazysearch/Makefile33
-rw-r--r--audio/slimserver-lazysearch/distinfo3
-rw-r--r--audio/slimserver-lazysearch/pkg-descr7
-rw-r--r--audio/slimserver-lazysearch/pkg-plist1
5 files changed, 45 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8a324ed1cd99..1094f3951bdf 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -547,6 +547,7 @@
SUBDIR += slimserver
SUBDIR += slimserver-dynamictransition
SUBDIR += slimserver-lastfm
+ SUBDIR += slimserver-lazysearch
SUBDIR += slimserver-slimscrobbler
SUBDIR += snack
SUBDIR += snett
diff --git a/audio/slimserver-lazysearch/Makefile b/audio/slimserver-lazysearch/Makefile
new file mode 100644
index 000000000000..f9c2d4606a6a
--- /dev/null
+++ b/audio/slimserver-lazysearch/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: slimserver-lazysearch
+# Date created: 10 December 2006
+# Whom: Tim Bishop <tdb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lazysearch
+PORTVERSION= 2.3
+CATEGORIES= audio
+# Distfile mirrored due to being unversioned on author's site
+MASTER_SITES= ftp://ftp.i-scream.org/pub/slimserver/${PORTNAME}/ \
+ http://ftp.i-scream.org/pub/slimserver/${PORTNAME}/
+PKGNAMEPREFIX= slimserver-
+DIST_SUBDIR= slimserver
+
+MAINTAINER= tdb@FreeBSD.org
+COMMENT= SlimServer plugin for performing lazy searches
+
+RUN_DEPENDS= softsqueeze:${PORTSDIR}/audio/slimserver
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+SLIMDIR?= slimserver
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${SLIMDIR}/Plugins
+ ${INSTALL_DATA} ${WRKSRC}/LazySearch2.pm ${PREFIX}/${SLIMDIR}/Plugins
+
+.include <bsd.port.mk>
diff --git a/audio/slimserver-lazysearch/distinfo b/audio/slimserver-lazysearch/distinfo
new file mode 100644
index 000000000000..ca6a12b1c739
--- /dev/null
+++ b/audio/slimserver-lazysearch/distinfo
@@ -0,0 +1,3 @@
+MD5 (slimserver/lazysearch-2.3.zip) = 6f661a71ecb41ff09515101096d305e4
+SHA256 (slimserver/lazysearch-2.3.zip) = 70ff59ec320266cad4b5762a8864f873f8e69c2170bbf299c82ba7837a9ae267
+SIZE (slimserver/lazysearch-2.3.zip) = 34219
diff --git a/audio/slimserver-lazysearch/pkg-descr b/audio/slimserver-lazysearch/pkg-descr
new file mode 100644
index 000000000000..0d92a2d2c81d
--- /dev/null
+++ b/audio/slimserver-lazysearch/pkg-descr
@@ -0,0 +1,7 @@
+This is a SlimServer plugin to add lazy search capabilities. Lazy
+searching allows for much faster entry of search text by allowing
+you to forget about multi-tapping and instead just press each of
+the remote control buttons once for each of the letters in the text,
+whatever position the letter appears in above the button.
+
+WWW: http://hickinbottom.demon.co.uk/lazysearch/
diff --git a/audio/slimserver-lazysearch/pkg-plist b/audio/slimserver-lazysearch/pkg-plist
new file mode 100644
index 000000000000..76406e4a753d
--- /dev/null
+++ b/audio/slimserver-lazysearch/pkg-plist
@@ -0,0 +1 @@
+%%SLIMDIR%%/Plugins/LazySearch2.pm