aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpkubaj <pkubaj@FreeBSD.org>2019-12-06 16:59:47 +0800
committerpkubaj <pkubaj@FreeBSD.org>2019-12-06 16:59:47 +0800
commit6183702eff39ec12f2a993d6b6800d0a94c5ae34 (patch)
tree17a86f310b109b2566f9a53e163f6f82a086c4a1 /audio
parentd6b127546118be3756bbb89917858d9942c02abb (diff)
downloadfreebsd-ports-gnome-6183702eff39ec12f2a993d6b6800d0a94c5ae34.tar.gz
freebsd-ports-gnome-6183702eff39ec12f2a993d6b6800d0a94c5ae34.tar.zst
freebsd-ports-gnome-6183702eff39ec12f2a993d6b6800d0a94c5ae34.zip
audio/alure: fix build on GCC architectures
C++11 compiler is necessary: /usr/local/lib/libopenal.so: undefined reference to `std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >::_M_mutate(unsigned long, unsigned long, char const*, unsigned long)@GLIBCXX_3.4.21' Approved by: mentors (implicit approval)
Diffstat (limited to 'audio')
-rw-r--r--audio/alure/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/alure/Makefile b/audio/alure/Makefile
index b20324cb736f..227e5e6ed236 100644
--- a/audio/alure/Makefile
+++ b/audio/alure/Makefile
@@ -13,7 +13,7 @@ COMMENT= Utility library to help manage common tasks with OpenAL
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake openal:soft pkgconfig
+USES= cmake compiler:c++11-lang openal:soft pkgconfig
USE_LDCONFIG= yes
LLD_UNSAFE= yes # lld disallows preemption of protected visibility syms
CMAKE_OFF= BUILD_DOCS BUILD_STATIC