aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2018-09-26 06:09:55 +0800
committerbrooks <brooks@FreeBSD.org>2018-09-26 06:09:55 +0800
commit63306064889dc8ca29a26d93365b2f4abbd10768 (patch)
tree30995ce1eccd9733c0d5cf8851558fc15429abd3 /audio
parent98c3133bdde51856cfc0801ddf52d44ee36762a2 (diff)
downloadfreebsd-ports-gnome-63306064889dc8ca29a26d93365b2f4abbd10768.tar.gz
freebsd-ports-gnome-63306064889dc8ca29a26d93365b2f4abbd10768.tar.zst
freebsd-ports-gnome-63306064889dc8ca29a26d93365b2f4abbd10768.zip
Update dependency on llvm40 to llvm60 and constrain to FreeBSD 10.x.
PR: 231287 Approved by: hselasky (maintainer) Sponsored by: DARPA, AFRL
Diffstat (limited to 'audio')
-rw-r--r--audio/zynaddsubfx/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/audio/zynaddsubfx/Makefile b/audio/zynaddsubfx/Makefile
index 7af816d17667..626aaace82df 100644
--- a/audio/zynaddsubfx/Makefile
+++ b/audio/zynaddsubfx/Makefile
@@ -82,13 +82,14 @@ CMAKE_ARGS+= -DZYN_DATADIR:STRING=${DATADIR}
CMAKE_ARGS+= -DZYN_EXAMPLESDIR:STRING=${EXAMPLESDIR}
.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100000
# Build fix for ZynAddSubFx
-BUILD_DEPENDS+= clang40:devel/llvm40
-CC= clang40
-CXX= clang++40
-
-.include <bsd.port.pre.mk>
+BUILD_DEPENDS+= clang60:devel/llvm60
+CC= clang60
+CXX= clang++60
+.endif
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
CFLAGS+= -DASM_F2I_YES