aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2015-06-11 22:49:50 +0800
committerxmj <xmj@FreeBSD.org>2015-06-11 22:49:50 +0800
commit63ef7ad2c3a48fcf24821cf274fa44f3b0f64fdb (patch)
treecdd50723f73bbae1eecb3db953ebc7494845b8bf /audio
parentc4f0f54b34b97049e59795860b223a5eb95caaf6 (diff)
downloadfreebsd-ports-gnome-63ef7ad2c3a48fcf24821cf274fa44f3b0f64fdb.tar.gz
freebsd-ports-gnome-63ef7ad2c3a48fcf24821cf274fa44f3b0f64fdb.tar.zst
freebsd-ports-gnome-63ef7ad2c3a48fcf24821cf274fa44f3b0f64fdb.zip
audio/linux-skype_oss_wrapper: add port.
A fake libpulse.so library that mimics pulseaudio behavior for skype WWW: https://github.com/waterlaz/skype_oss_wrapper PR: 200675 Submitted by: Andriy Voskoboinyk <s3erios@gmail.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/linux-skype_oss_wrapper/Makefile41
-rw-r--r--audio/linux-skype_oss_wrapper/distinfo2
-rw-r--r--audio/linux-skype_oss_wrapper/pkg-descr3
4 files changed, 47 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 2beb50fb122c..fb91360c8797 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -433,6 +433,7 @@
SUBDIR += linux-laudio
SUBDIR += linux-mbrola
SUBDIR += linux-neroaaccodec
+ SUBDIR += linux-skype_oss_wrapper
SUBDIR += linuxsampler
SUBDIR += listener
SUBDIR += lmms
diff --git a/audio/linux-skype_oss_wrapper/Makefile b/audio/linux-skype_oss_wrapper/Makefile
new file mode 100644
index 000000000000..06a2bad49c6a
--- /dev/null
+++ b/audio/linux-skype_oss_wrapper/Makefile
@@ -0,0 +1,41 @@
+# Created by: Andriy Voskoboinyk <s3erios@gmail.com>
+# $FreeBSD$
+
+PORTNAME= skype_oss_wrapper
+PORTVERSION= 0.1.1
+CATEGORIES= audio linux
+PKGNAMEPREFIX= linux-
+
+MAINTAINER= s3erios@gmail.com
+COMMENT= Partial PulseAudio API implementation using OSS backend
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LINUXBASE}/usr/bin/gcc:${PORTSDIR}/devel/linux-c6-devtools
+
+USE_GITHUB= yes
+GH_ACCOUNT= s3erios
+GH_TAGNAME= v${PORTVERSION}
+
+USE_LINUX= yes
+USE_LINUX_PREFIX= yes
+# do not define USE_LDCONFIG, it's not for global use
+
+ONLY_FOR_ARCHS= i386 amd64
+PLIST_FILES= lib/skype_oss_wrapper/libpulse.so.0
+
+LIB_DIR= ${PREFIX}/lib/${PORTNAME}
+
+# hardcode compiler path
+post-patch:
+ @${REINPLACE_CMD} -e 's|?= cc| = ${LINUXBASE}/usr/bin/gcc|' \
+ -e 's|$${CC}|${LINUXBASE}/usr/bin/gcc|' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ @${RM} ${STAGEDIR}${PREFIX}/bin/skype_oss
+ @${RMDIR} ${STAGEDIR}${PREFIX}/bin
+ @${BRANDELF} -t Linux ${STAGEDIR}${LIB_DIR}/libpulse.so.0
+
+.include <bsd.port.mk>
diff --git a/audio/linux-skype_oss_wrapper/distinfo b/audio/linux-skype_oss_wrapper/distinfo
new file mode 100644
index 000000000000..a45886fec075
--- /dev/null
+++ b/audio/linux-skype_oss_wrapper/distinfo
@@ -0,0 +1,2 @@
+SHA256 (s3erios-skype_oss_wrapper-0.1.1-v0.1.1_GH0.tar.gz) = 0106c7962eb39e68204f266e310eebb03e351aefe6cc1c7befe1a01fc43aeb92
+SIZE (s3erios-skype_oss_wrapper-0.1.1-v0.1.1_GH0.tar.gz) = 12401
diff --git a/audio/linux-skype_oss_wrapper/pkg-descr b/audio/linux-skype_oss_wrapper/pkg-descr
new file mode 100644
index 000000000000..3b85a060c673
--- /dev/null
+++ b/audio/linux-skype_oss_wrapper/pkg-descr
@@ -0,0 +1,3 @@
+A fake libpulse.so library that mimics pulseaudio behavior for skype
+
+WWW: https://github.com/waterlaz/skype_oss_wrapper