aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2019-08-13 09:32:48 +0800
committeracm <acm@FreeBSD.org>2019-08-13 09:32:48 +0800
commit643e59e3611854bc12d4ef8e6c18f63ffc811251 (patch)
tree15a4e8c04e6852e3a0100889fed8552d68149146 /audio
parent405ab8584cacf3f8ae62882ee4924972ef041b14 (diff)
downloadfreebsd-ports-gnome-643e59e3611854bc12d4ef8e6c18f63ffc811251.tar.gz
freebsd-ports-gnome-643e59e3611854bc12d4ef8e6c18f63ffc811251.tar.zst
freebsd-ports-gnome-643e59e3611854bc12d4ef8e6c18f63ffc811251.zip
- Fix build on non-x86
- Fix build on powerpc64 PR: 239437 Submitted by: pkubaj
Diffstat (limited to 'audio')
-rw-r--r--audio/mixxx/Makefile5
-rw-r--r--audio/mixxx/files/patch-plugins_soundsourcem4a_soundsourcem4a.h11
2 files changed, 13 insertions, 3 deletions
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index 0f0df2c52e70..377932b414ce 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -4,7 +4,7 @@
PORTNAME= mixxx
DISTVERSIONPREFIX= release-
DISTVERSION= 2.2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MAINTAINER= acm@FreeBSD.org
@@ -14,7 +14,6 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_aarch64= fails to compile: Exception("invalid machine type")
-BROKEN_powerpc64= fails to configure: unmet dependencies: Could not find libprotobuf, libchromaprint, libmp4, and libwavpack
BUILD_DEPENDS= lv2>=1.14.0:audio/lv2
LIB_DEPENDS= libchromaprint.so:audio/chromaprint \
@@ -48,7 +47,7 @@ USE_QT= buildtools concurrent core dbus gui network opengl script scripttools \
CONFLICTS= mixxx20* mixxx21*
MAKE_ARGS= qtdir="${PREFIX}" install_root="${PREFIX}" \
- build=release optimize=native ${GUI} battery=0 vamp=1 modplug=1
+ build=release optimize=off ${GUI} battery=0 vamp=1 modplug=1
LATE_INSTALL_ARGS= --install-sandbox=${STAGEDIR}
GUI= qt5=1
diff --git a/audio/mixxx/files/patch-plugins_soundsourcem4a_soundsourcem4a.h b/audio/mixxx/files/patch-plugins_soundsourcem4a_soundsourcem4a.h
new file mode 100644
index 000000000000..d45a2ae4a508
--- /dev/null
+++ b/audio/mixxx/files/patch-plugins_soundsourcem4a_soundsourcem4a.h
@@ -0,0 +1,11 @@
+--- plugins/soundsourcem4a/soundsourcem4a.h.orig 2019-07-19 22:36:09 UTC
++++ plugins/soundsourcem4a/soundsourcem4a.h
+@@ -5,6 +5,8 @@
+
+ #include "util/readaheadsamplebuffer.h"
+
++#include <sys/types.h>
++
+ #ifdef __MP4V2__
+ #include <mp4v2/mp4v2.h>
+ #else