aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-16 20:37:25 +0800
committerpav <pav@FreeBSD.org>2005-07-16 20:37:25 +0800
commit6791b9055e63651ab873051a51e6bfe155a23a4a (patch)
treecad29266cb1c368bd918285f3ed7fff328b22ce7 /audio
parent451076402ffae319e4ce6bf1c49904885e4d585f (diff)
downloadfreebsd-ports-gnome-6791b9055e63651ab873051a51e6bfe155a23a4a.tar.gz
freebsd-ports-gnome-6791b9055e63651ab873051a51e6bfe155a23a4a.tar.zst
freebsd-ports-gnome-6791b9055e63651ab873051a51e6bfe155a23a4a.zip
Add song rating control to the XMMS playlist
Adds extra control to the XMMS playlist and automatically skips songs you don't like and play the ones you do like. * High rated songs will be played privileged * Manual manipulation of the assessment of single songs * Ignore single songs * Configurable PR: ports/83484 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xmms-rateplug/Makefile41
-rw-r--r--audio/xmms-rateplug/distinfo2
-rw-r--r--audio/xmms-rateplug/files/install-user22
-rw-r--r--audio/xmms-rateplug/pkg-descr12
-rw-r--r--audio/xmms-rateplug/pkg-message4
6 files changed, 82 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index c2c577119392..aa488227045e 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -545,6 +545,7 @@
SUBDIR += xmms-osssurround
SUBDIR += xmms-pipe
SUBDIR += xmms-quix3dn
+ SUBDIR += xmms-rateplug
SUBDIR += xmms-real-random
SUBDIR += xmms-sapplug
SUBDIR += xmms-scrobbler
diff --git a/audio/xmms-rateplug/Makefile b/audio/xmms-rateplug/Makefile
new file mode 100644
index 000000000000..de9de52cbaf8
--- /dev/null
+++ b/audio/xmms-rateplug/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: xmms-rateplug
+# Date created: 15 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-rateplug
+DISTVERSION= 0.4.2-3
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= xmmsassesment
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Add song rating control to the XMMS playlist
+
+BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk12
+
+CXXFLAGS+= -w -shared -fPIC `xmms-config --cflags` `gtk-config --cflags` \
+ `gtk-config --libs`
+PLUGIN= rateplug
+
+PLIST_FILES= lib/xmms/General/rateplug.so
+
+do-build:
+ ${CXX} ${CXXFLAGS} ${WRKSRC}/${PLUGIN}.c++ -o ${WRKSRC}/${PLUGIN}.so
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PLUGIN}.so ${PREFIX}/lib/xmms/General
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+install-user:
+ ${SH} ${FILESDIR}/install-user
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-rateplug/distinfo b/audio/xmms-rateplug/distinfo
new file mode 100644
index 000000000000..78771ca42304
--- /dev/null
+++ b/audio/xmms-rateplug/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmms-rateplug-0.4.2-3.tar.gz) = a29ddbf2b16632ce5c26228c8ee3a76c
+SIZE (xmms-rateplug-0.4.2-3.tar.gz) = 20041
diff --git a/audio/xmms-rateplug/files/install-user b/audio/xmms-rateplug/files/install-user
new file mode 100644
index 000000000000..a0230195f394
--- /dev/null
+++ b/audio/xmms-rateplug/files/install-user
@@ -0,0 +1,22 @@
+#!/bin/sh
+#
+# Emanuel Haupt <ehaupt@critical.ch>
+#
+# This script creates the users configfile that needs to
+# exist in order to use this plugin
+#
+# $FreeBSD$
+
+
+if [ ! -d ~/.xmms ]; then
+ echo "===> Creating xmms directory"
+ mkdir ~/.xmms
+fi
+
+if [ -f ~/.xmms/database.txt ]; then
+ echo "===> Database already exists"
+else
+ echo "===> Initializing database"
+ touch ~/.xmms/database.txt
+ echo "===> Database initialized"
+fi
diff --git a/audio/xmms-rateplug/pkg-descr b/audio/xmms-rateplug/pkg-descr
new file mode 100644
index 000000000000..cc757715d03a
--- /dev/null
+++ b/audio/xmms-rateplug/pkg-descr
@@ -0,0 +1,12 @@
+Adds extra control to the XMMS playlist and automatically skips songs you don't
+like and play the ones you do like.
+
+ * High rated songs will be played privileged
+ * Manual manipulation of the assessment of single songs
+ * Ignore single songs
+ * Configurable
+
+WWW: http://xmmsassesment.sourceforge.net/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/audio/xmms-rateplug/pkg-message b/audio/xmms-rateplug/pkg-message
new file mode 100644
index 000000000000..02c0fcb93ade
--- /dev/null
+++ b/audio/xmms-rateplug/pkg-message
@@ -0,0 +1,4 @@
+===============================================================================
+You can run "make install-user" in this directory as user to initialize the
+rating database.
+===============================================================================